Powermail: überschreiben von Absender/Empfänger [Gelöst]

  • 0 x
    24 Beiträge
    0 Hilfreiche Beiträge
    14. 10. 2009, 14:18

    Noch mal als Follow-Up zu diesem Thread:

    http://www.typo3.net/forum/list/list_post//93627/

    ich habe versucht, die Absender/Empfänger zu überschreiben - leider mit keinem Erfolg.
    Im Root-Template Setup steht bei mir folgendes unter Constants:

    plugin.tx_powermail_pi1 {
    # Some settings for Emails
    email {

    # Settings for mail to the default receiver(s)
    recipient_mail {
    # Sender name (overwrite)
    sender.name = TEXT
    sender.name.value =

    # Sender email (overwrite)
    sender.email = TEXT
    sender.email.value =
    }
    }
    }

    Alternativ habe ich folgende Notation probiert:

    plugin.powermail {
    markerALL.hideLabel = 1
    email.overwritesendername = Name of Sender
    email.overwritereceipient = info@fks.de
    email.overwritereceipientname = Name of Receipient
    }

    klappt beides nicht ;(


  • einpraegsam.net einpraegs...
    MacGyver
    0 x
    9340 Beiträge
    80 Hilfreiche Beiträge
    14. 10. 2009, 14:56

    Welche pm version?
    Du willst den Absender an den normalen Empfänger überschreiben?

    in2code.de - Wir leben TYPO3
    - Möchtest du TYPO3 komplett verstehen? Eigene Erweiterungen erstellen? Bei uns gibt es auch Schulungen https://www.in2code.de/produkte/typo3-schulungen/
    - Die Arbeit mit TYPO3 macht dir Spaß? Du stehst auf Berge? Komm zu uns! https://www.in2code.de/agentur/karriere/

  • 0 x
    24 Beiträge
    0 Hilfreiche Beiträge
    14. 10. 2009, 15:00

    version 1.4.17

    ich habe meine Empfänger als FE_User und lasse den Kunden den Empfänger über eine Selectbox auswählen. (http://www.typo3.net/forum/list/list_post//93627/)

    Daher habe ich keinen Default Namen für den Absender für die Bestätigungsmail, weswegen da "powermail" als Name steht.

  • 0 x
    24 Beiträge
    0 Hilfreiche Beiträge
    14. 10. 2009, 15:02

    zum zweiten ist es so, dass wenn der Kunde die Felder Vorname und Nachname nicht ausfüllt, die email-adresse (pflichtfeld) als Name verwendet wird. Daher möchte ich auch hier den Absendernamen an den internen Empfänger überschreiben.

  • einpraegsam.net einpraegs...
    MacGyver
    0 x
    9340 Beiträge
    80 Hilfreiche Beiträge
    14. 10. 2009, 15:23

    Aktuelle powermail installieren...

    in2code.de - Wir leben TYPO3
    - Möchtest du TYPO3 komplett verstehen? Eigene Erweiterungen erstellen? Bei uns gibt es auch Schulungen https://www.in2code.de/produkte/typo3-schulungen/
    - Die Arbeit mit TYPO3 macht dir Spaß? Du stehst auf Berge? Komm zu uns! https://www.in2code.de/agentur/karriere/

  • 0 x
    24 Beiträge
    0 Hilfreiche Beiträge
    14. 10. 2009, 16:44

    danke.. wußte nicht, dass das ein last-minute-bug war

  • einpraegsam.net einpraegs...
    MacGyver
    0 x
    9340 Beiträge
    80 Hilfreiche Beiträge
    14. 10. 2009, 16:56

    [quote="freestyle"]
    danke.. wußte nicht, dass das ein last-minute-bug war
    [/quote]

    War es auch nicht, es hat sich nur was geändert in der Definition

    in2code.de - Wir leben TYPO3
    - Möchtest du TYPO3 komplett verstehen? Eigene Erweiterungen erstellen? Bei uns gibt es auch Schulungen https://www.in2code.de/produkte/typo3-schulungen/
    - Die Arbeit mit TYPO3 macht dir Spaß? Du stehst auf Berge? Komm zu uns! https://www.in2code.de/agentur/karriere/

  • puntila puntila
    T3PO
    0 x
    9 Beiträge
    0 Hilfreiche Beiträge
    25. 10. 2009, 17:10

    Sorry Jungs,

    ich bekomme es nicht hin! #angry#

    Funzt alles prima, bis auf den Sender-Name. Im Registerblatt "Sender" habe ich unter "Sender email address" das entsprechende E-Mail-Feld gewählt und unter "Sender name" den entsprechenden Namen (aus dem Formular) eingetragen. Die Bestätigungs-E-Mail hat trotzdem als Absendername "powermail". Wie kann ich das ändern?

    Und, gibt es eine andere Möglichkeit, die Bestätigungs-E-Mail auszuschalten, als das "Sender"-Feld im Registerblatt "Sender" leer zu lassen?

    Gruß,
    Puntila

  • 0 x
    24 Beiträge
    0 Hilfreiche Beiträge
    25. 10. 2009, 17:41

    Hallo puntila,

    das hier müsstest Du z.B. in das Root-Setup schreiben:

    plugin.tx_powermail_pi1 {
    markerALL.hideLabel = 1
    # Some settings for Emails
    email {

    # Settings for mail to the default receiver(s)
    recipient_mail {
    # Sender name (overwrite)
    sender.name = TEXT
    sender.name.value =Absender Name

    # Sender email (overwrite)
    sender.email = TEXT
    sender.email.value =absender@email.de
    }
    sender_mail {
    # Sender name (overwrite)
    sender.name = TEXT
    sender.name.value = Absender
    # Sender email (overwrite)
    sender.email = TEXT
    sender.email.value = absender@email.de
    }
    }
    }

  • 0 x
    24 Beiträge
    0 Hilfreiche Beiträge
    25. 10. 2009, 17:47

    ach ja:

    plugin.tx_powermail_pi1.allow.email2sender >

    damit sollte man die bestätigungsemail abschalten
    können (habs gerade nicht getestet).