tt_products & paymentlib_paypal

  • pleo pleo
    T3PO
    0 x
    16 Beiträge
    0 Hilfreiche Beiträge
    10. 09. 2009, 09:28

    Hallo Cracks;-)

    Ich habe ein kleines Problem bei der Integration der EXT:paymentlib_paypal.
    [b]Installiert sind:[/b]
    paymentlib_paypal 0.0.4
    paysuite 0.0.1
    paymentlib 0.3.2
    lib 0.1.0
    div 0.1.0
    div2007 0.2.0
    static_info_tables 2.1.1
    tt_products

    Der Shop arbeitet einwandfrei, das bezahlen via PayPal ebenfalls.

    Ich habe mir 2 Testaccounts auf sandbox.paypal.com angelegt.

    formActionUri = https://www.sandbox.paypal.com/de/cgi-bin/webscr
    Die Transaktionen laufen auch soweit.
    Beim Verkäufer bzw. beim Käufer werden die Beträge richtig gebucht und der Warenkorb wird auch übermittelt.
    Nach Ende der Bezahlung werde ich auf meinen Warenkorb zur Stelle des CONFIRM_TEMPLATES geleitet. Soweit so gut.
    Nun sollten doch die Transkationen im sysordner den ich in der EXT:paymentlib angegeben habe gespeichert werden oder ?!

    Ich gehe mal davon aus, dass ich unter
    Request url for pdt-synchronisation
    syncUri = http://www.sandbox.paypal.com/de/cgi-bin/webscr
    eintragen muss.
    Das authToken = xxxxx
    habe ich mir wie folgt organisiert:

    Im Business-Konto bin ich über :
    Mein Konto => mein Profil => Website Zahlunsoptionen gegangen.
    Dort habe ich den Punkt Automatische Rückleitung (Rückleitungs-URL:
    meine-domain.de ?! auf welche seite?!?)aktiviert und Übertragung der Zahlungsdaten ebenfalls.
    Nun hat er mir ein Token generiert das ich in der conf der EXT:paymentlib_paypal unter authToken eintrug.

    Leider schreibt er mir keinerlei Transaktionen in den angegebenen Sysordner.

    Woran kann das liegen?! Hat da jemand ein ähnliches Problem gehabt oder sieht einer meinen Fehler ?!


  • 1
  • myrddin myrddin
    Jar Jar Binks
    0 x
    1 Beiträge
    0 Hilfreiche Beiträge
    19. 05. 2010, 10:30

    [quote="pleo"]
    Leider schreibt er mir keinerlei Transaktionen in den angegebenen Sysordner.
    [/quote]

    Hallo pleo,

    dein Beitrag ist zwar schon ein paar Tage alt, aber das Problem ist zumindest bei mir aktuell. Dazu habe ich mir einen -ebenfalls- alten Beitrag [url=]http://jambage.com/index.php?id=203&tx_ttboard_pi_tree[uid]=1448[/url] von Franz Holzinger, 08.05.2008 ergoogelt, in dem er schreibt:
    "Es werden derzeit keine Transaktionen gespeichert. Das sollte aber..."

    Hat jemand inzwischen eine Lösung gefunden, oder ist die Aussage von Herrn Holzinger die "Lösung"?

  • 1