Probleme mit IM 6.5.2-9

  • taliah taliah
    T3PO
    0 x
    11 Beiträge
    0 Hilfreiche Beiträge
    14. 07. 2009, 15:03

    Hallo zusammen!

    Vielleicht kann mir da jemand weiterhelfen:

    IM finktioniert, und bis auf die Formate für png, pdf und ai bekomm ich auch brav das Testbild angezeigt.

    Desweiteren sagt er mir dann beim Schreiben des gifs, dass die Größe erheblich von der Referenz abweiche:

    Your server: Reference:
    21 K, 170x136 pixels 14.4 K, 170x136 pixels
    File size is very different from reference
    21799 14794
    The 'gif_compress' method used was 'IM'.
    Previous filesize: 21 K. Current filesize:21 K

    png schreiben verursacht hingegen so gar keinen Fehler.

    Beim Skalieren der Bilder dann ebenfalls Fehler:
    - png gar nicht
    - gifs erzeugen wiederum das Größenproblem

    Combine funzt soweit, aber auch hier wieder das Größenproblem.

    Und immer steht am Ende bei Errors:
    It seems that you had some fatal errors in this test. Please make sure that your ImageMagick and GDLib settings are correct. Refer to the 'Basic Configuration' section for more information and debugging of your settings.

    Ich bin derzeit etwas ratlos und weiß nicht, wie ich dagegen angehen sollte, da die Fehler so speziell auftreten und ich bisher noch keine troubleshootings finden konnte.

    Hier mal der Konfig-Report:

    Current configuration
    ImageMagick enabled: 1
    ImageMagick path: /opt/local/bin/ (6.5.2-9)
    ImageMagick path/LZW: /opt/local/bin/ (6.5.2-9)
    Version 5/GraphicsMagick flag: im6

    GDLib enabled: 1
    GDLib using PNG: 1
    GDLib 2 enabled: 1
    IM5 effects enabled: 0 (Blurring/Sharpening with IM 5+)
    Freetype DPI: 72 (Should be 96 for Freetype 2)
    Mask invert: 1 (Should be set for some IM versions approx. 5.4+)

    File Formats: gif,jpg,jpeg,tif,bmp,pcx,tga,png,pdf,ai

    Sharpening hab ich disabled, was ja aber ohnehin nur auf die Schärfe des Bildes Auswirkungen haben sollte, nicht auf das Format.

    Für eine schnelle Antwort wäre ich mächtig dankbar :)

    LG
    tali

    P.S.: Ach so, ich nutze MAC OS X Leopard, Typo3 4.2.8 (falls das wichtig sein sollte)


  • 1
  • birgitr birgitr
    Jedi-Meister
    0 x
    337 Beiträge
    0 Hilfreiche Beiträge
    04. 02. 2010, 22:25

    Für alle, die es noch wissen wollen:

    Im Install Tool unter "All Configuration" die richtigen Einstellungen für die ImageMagick/Graphicsmagick Version vornehmen und dann wieder in den Imagetests prüfen.

  • 1