RealUrl: Fehler (404) in der zweiten Ebene der Seite

  • 0 x
    24 Beiträge
    0 Hilfreiche Beiträge
    17. 05. 2009, 14:32

    Hallo Forum!

    folgendes Problem hat sich aufgetan und ich bin um jede Hilfe in der Sache sehr dankbar:

    Bei aktivierter RealUrl Extension habe ich nur Zugriff auf die erste Seitenebene der Website.
    Sprich:
    "[i]http://www.xyz.de/aktuelles.html[/i]" funktioniert,
    "[i]http://www.xyz.de/aktuelles/unterseite.html[/i]" funktioniert nicht!

    Die Seiten sind vorhanden und können bei deaktiviertem RealUrl (also über index.php?id=#) ganz normal über direkte Eingabe im Adressfeld des Browsers wie über die FrontEnd Navigation erreicht werden.

    Die Fehlerausgabe bei RealUrl ist ein "404er", d.h."Die Seite kann nicht gefunden werden..."

    Also muss in der Konfiguration der Wurm drinnen sein, dass unterhalb der ersten Ebene die Unterverzeichnisse nicht richtig verlinkt werden.

    Dies ist meine RealUrl Konfiguration (via aeUrlTool):

    1. <?php
    2. $GLOBALS['TYPO3_CONF_VARS']['EXTCONF']['realurl'] = array (
    3. '_DEFAULT' => array (
    4. 'init' => array (
    5. 'enableCHashCache' => '1',
    6. 'appendMissingSlash' => 'ifNotFile',
    7. 'enableUrlDecodeCache' => '1',
    8. 'enableUrlEncodeCache' => '1',
    9. ),
    10. 'redirects' => array (
    11. ),
    12. 'preVars' => array (
    13. '0' => array (
    14. 'GETvar' => 'no_cache',
    15. 'valueMap' => array (
    16. 'nc' => '1',
    17. ),
    18. 'noMatch' => 'bypass'
    19. ),
    20. '1' => array (
    21. 'GETvar' => 'L',
    22. 'valueMap' => array (
    23. 'de' => '0',
    24. 'en' => '1',
    25. ),
    26. 'noMatch' => 'bypass',
    27. ),
    28. '2' => array (
    29. 'GETvar' => 'lang',
    30. 'valueMap' => array (
    31. 'de' => 'de',
    32. 'en' => 'en',
    33. ),
    34. 'noMatch' => 'bypass',
    35. ),
    36. ),
    37. 'pagePath' => array (
    38. 'type' => 'user',
    39. 'userFunc' => 'EXT:realurl/class.tx_realurl_advanced.php:&tx_realurl_advanced->main',
    40. 'spaceCharacter' => '-',
    41. 'languageGetVar' => 'L',
    42. 'expireDays' => '7',
    43. 'rootpage_id' => '17',
    44. ),
    45. 'fixedPostVars' => array (
    46. ),
    47. 'postVarSets' => array (
    48. '_DEFAULT' => array (
    49.  
    50. 'galerie' => array(
    51.  
    52.  
    53. 'GETvar' => 'tx_chgallery_pi1[pointer]',
    54.  
    55. ),
    56.  
    57.  
    58. 'GETvar' => 'tx_chgallery_pi1[dir]',
    59.  
    60. ),
    61.  
    62.  
    63. 'GETvar' => 'tx_chgallery_pi1[single]',
    64.  
    65. ),
    66.  
    67. ),
    68.  
    69.  
    70.  
    71. 'photobook' => array(
    72. array('GETvar' => 'tx_gooffotoboek_pi1[srcdir]'),
    73. array('GETvar' => 'tx_gooffotoboek_pi1[fid]'),
    74. array('GETvar' => 'tx_gooffotoboek_pi1[func]',
    75. 'valueMap' => array('thumbnails' =>'thumb',
    76. ),
    77. ),
    78. ),
    79.  
    80.  
    81. 'archive' => array (
    82. '0' => array (
    83. 'GETvar' => 'tx_ttnews[year]',
    84. ),
    85. '1' => array (
    86. 'GETvar' => 'tx_ttnews[month]',
    87. 'valueMap' => array (
    88. 'january' => '01',
    89. 'february' => '02',
    90. 'march' => '03',
    91. 'april' => '04',
    92. 'may' => '05',
    93. 'june' => '06',
    94. 'july' => '07',
    95. 'august' => '08',
    96. 'september' => '09',
    97. 'october' => '10',
    98. 'november' => '11',
    99. 'december' => '12',
    100. ),
    101. ),
    102. ),
    103. 'browse' => array (
    104. '0' => array (
    105. 'GETvar' => 'tx_ttnews[pointer]',
    106. ),
    107. ),
    108. 'select_category' => array (
    109. '0' => array (
    110. 'GETvar' => 'tx_ttnews[cat]',
    111. ),
    112. ),
    113. 'article' => array (
    114. '0' => array (
    115. 'GETvar' => 'tx_ttnews[tt_news]',
    116. 'lookUpTable' => array (
    117. 'table' => 'tt_news',
    118. 'id_field' => 'uid',
    119. 'alias_field' => 'title',
    120. 'addWhereClause' => ' AND NOT deleted',
    121. 'useUniqueCache' => '1',
    122. 'useUniqueCache_conf' => array (
    123. 'strtolower' => '1',
    124. 'spaceCharacter' => '-',
    125. ),
    126. ),
    127. ),
    128. '1' => array (
    129. 'GETvar' => 'tx_ttnews[swords]',
    130. ),
    131. ),
    132. ),
    133. ),
    134. 'fileName' => array (
    135. //
    136. // if you don't want .html-URLs set the following to "false" (e.g. 'defaultToHTMLsuffixOnPrev' => false,)
    137. // then you get http://www.yourdomain.com/imprint/ instead of http://www.yourdomain.com/imprint.html
    138. //
    139. 'defaultToHTMLsuffixOnPrev' => true,
    140. 'index' => array (
    141. 'rss.xml' => array (
    142. 'keyValues' => array (
    143. 'type' => '100',
    144. ),
    145. ),
    146. 'rss091.xml' => array (
    147. 'keyValues' => array (
    148. 'type' => '101',
    149. ),
    150. ),
    151. 'rdf.xml' => array (
    152. 'keyValues' => array (
    153. 'type' => '102',
    154. ),
    155. ),
    156. 'atom.xml' => array (
    157. 'keyValues' => array (
    158. 'type' => '103',
    159. ),
    160. ),
    161. ),
    162. ),
    163. ),
    164.  
    165. );
    166.  
    167. ?>

    Ansonsten habe ich RealUrl ganz gewöhnlich über TS ins Template integriert und aktiviert:

    [TS]####################################################
    #realURL
    ####################################################
    config {
    simulateStaticDocuments = 0
    baseURL = http://p#########.typo3server.info
    tx_realurl_enable = 1
    }[/TS]

    Versionen:
    RealUrl Version: 1.5.3

    Ich hoffe Ihr könnt mir weiterhelfen, auf einem anderen Mittwald-Typo3 Account habe ich mit gleicher Konfiguration (natürlich bei veränderter rootPid im realurl.conf) eine andere Seite ohne Probleme am laufen.

    Schon einmal vielen Dank und viele Grüße
    Lord_Sinclair


  • 1
  • 1