Typo3 Ver. 4.2.6 sehr langsam

  • Zanu Zanu
    TYPO3-Anwärter
    0 x
    4 Beiträge
    0 Hilfreiche Beiträge
    12. 03. 2009, 19:29

    Guten Abend,
    ich hoffe es kann mir jemand Auskunft geben.

    Habe langsamen Seitenaufbau nach Versionswechsel.
    Neue Vereinsseite aufgebaut auf Typo3/4.2.6 - Ordner fileadmin und uploads von Version 4.2.2 manuell rüberkopiert, die DB habe ich auch von Version 4.2.2 übernommen.
    Typo3 4.2.6 wurde vorher neu installiert.
    Version 4.2.6 läuft nun einige Zeit ohne Fehlermeldungen, kleine Umstellungsprobleme habe ich behoben. Jedoch kommt mir der Seitenaufbau bei der neuen Version sehr langsam vor.

    Frage 1, habe ich etwas Grundlegendes übersehen?

    Frage 2, der Ordner typo3temp enthält viele Dateien, auch in den Unterordnern von typo3temp hat sich so einiges angesammelt. Darf ich die Dateien im Root von typo3temp und in den Unterordnern löschen ohne Typo3 abzuschiessen? Ich denke die temp Dateien drücken auch auf die Performance, oder liege ich da falsch?

    Danke im Voraus für Hilfe,
    Grüsse aus Österreich,
    Zanu
    [url]www.vsv-amstetten.at[/url]


  • 1
  • 0 x
    29 Beiträge
    0 Hilfreiche Beiträge
    13. 03. 2009, 05:22

    100% sicher das der cache greift? kannste am besten kontrollieren wenn du dir n syslog ausgeben lässt... einfach in die typo3conf/localconf.php sowas in der richtung eintragen

    1. $TYPO3_CONF_VARS['SYS']['systemLog'] = 'file,%absoluterpfadzurdatei%,0';

    (die ...,0 is für loglevel=info)... kannste auch im install tool unter all config eintragen.
    da werden dann einträge erscheinen, die darauf weisen, ob irgendwo vielleicht doch eine no_cache anweisung gesetzt wird.
    hatte auch schon den fall eines verseuchten url caches von realurl, wo der chash nachher nicht mehr stimmte und deswegen der cache nie benutzt wurde... löschen der realurl caches hats dann behoben.
    im zweifelsfall kannste ja mal alle no_cache versuche unterbinden (auch die auf den pages explizit gesetzten) in dem du folgendes in die localconf einträgst:
    1. $TYPO3_CONF_VARS['FE']['disableNoCacheParameter'] = '1';

    und dann mal schaust ob's dann was zügiger läuft...

    die dateien im typo3temp/ verzeichniss kann man übrigens soweit bedenkenlos löschen, und auch das kann man auch übers install tool machen über die option (tadaaa) 'typo3temp/' ;) der füllstand in ebendiesem verzeichniss sollte aber keinen wirklichen einfluss auf die performance haben, wobei natürlich n volles dateisystem auch langsamer wird irgendwann.

  • Zanu Zanu
    TYPO3-Anwärter
    0 x
    4 Beiträge
    0 Hilfreiche Beiträge
    13. 03. 2009, 09:23

    hallo sensomedia,

    $TYPO3_CONF_VARS['FE']['disableNoCacheParameter'] = '1';

    dürfte geholfen haben, die seite ist nun optisch schneller!
    das löschen der temp-dateien werde ich noch aufheben, bis ich nach einigen tagen mit sicherheit sagen kann, das system läuft zufriedenstellend.

    danke für deine hilfe,
    Grüsse,
    Zanu

  • 1