GDLIB_2 mit Graphicsmagick

  • pixel24 pixel24
    T3PO
    0 x
    15 Beiträge
    0 Hilfreiche Beiträge
    13. 02. 2009, 13:57

    Hallo zusammen,

    erst mal ein "Hallo" in die Runde, ich bin neu in diesem Forum und in den ersten Typo3-Zügen ....

    Ich betreibe die Version 4.2.6 von Typo3 auf einem lokalen Entwicklungs-Server (Debian Etch / 64Bit) mit den Paketen:

    - graphicsmagick
    - graphicsmagick-imagemagick-compat

    jeweils in Version 1.1.7.

    Es funktioniert auch alles soweit. Wie im Buch von Rober Meyer beschrieben habe ich, um die Qualität der mit dem GIFBUILDER ausgegebenen Grafiken zu erhöhen, die Variable gdlib_2 = 1 gesetzt. Das hatte auch den gewünschten Effekt allerdings wird nun im Installationstool unter Image Processing / Scaling images folgende Warnungen angezeigt:

    ** PNG to PNG, 150 pixels wide **
    Your server: Reference:
    13.7 K, 150x120 pixels 6.0 K, 150x120 pixels
    File size is very different from reference
    14040 6164
    ImageMagick commands executed:
    /usr/X11R6/bin/gm convert -geometry 150x120! /home/web/gehr/typo3/sysext/install/imgs/jesus2_transp.png[0]/home/web/gehr/typo3temp/pics/install_scale_png.png

    ** GIF to JPG, 150 pixels wide **
    Your server: Reference:
    11.0 K, 150x120 pixels 2.4 K, 150x120 pixels
    File size is very different from reference
    11248 2445
    ImageMagick commands executed:
    /usr/X11R6/bin/gm convert -geometry 150x120! -colorspace RGB -quality 100 /home/web/gehr/typo3/sysext/install/imgs/jesus2_transp.gif[0]/home/web/gehr/typo3temp/pics/install_scale_jpg.jpg

    Außerdem wird unter "Reading image formats" bei allen Formaten die Meldung:

    File size is very different from reference

    Sind da noch andere Einstellungen falsch oder wie muss ich die GFX-Optionen setzen um mit Graphicsmagick zu arbeiten? Meine Optionen:

    $TYPO3_CONF_VARS['GFX']['im_version_5'] = 'gm';
    $TYPO3_CONF_VARS['GFX']['jpg_quality'] = '100';
    $TYPO3_CONF_VARS['GFX']['enable_typo3temp_db_tracking'] = '1';
    $TYPO3_CONF_VARS['GFX']['TTFdpi'] = '96';
    $TYPO3_CONF_VARS['GFX']['png_truecolor'] = '1';
    $TYPO3_CONF_VARS['GFX']['gdlib_2'] = '1';
    $TYPO3_CONF_VARS['GFX']['gdlib_png'] = '0';

    Viele Grüße
    pixel24


  • 1
  • fragolina fragolina
    Padawan
    0 x
    39 Beiträge
    0 Hilfreiche Beiträge
    18. 01. 2010, 12:05

    Hallo pixel24 :)

    hab das gleiche Problem. Konntest Du das lösen??
    danke lg

  • 1