PMK MP3 Player findet Datei nicht

  • anneon anneon
    T3PO
    0 x
    13 Beiträge
    0 Hilfreiche Beiträge
    06. 02. 2009, 19:27

    hi zusammen!

    Hoffe jemand von euch kann mir helfen.

    Ich habe die Extension PMK MP3 Player auf meiner
    Typo3 Seite installiert.
    Der MP3 Player wird auch ganz toll dargestellt, aber
    er findet das mp3-File irgendwie nicht.
    Obwohl alles sauper verlinkt ist.
    Wenn ich auf Play drücke, steht nur immer: "Error opening file"

    Hat jemand von euch mit dem Player Erfahrung
    oder weiss einen Rat?

    Ich kann die MP3-Datei über den direkten
    Link (also: /uploads/tx_pmkmp3player/song.mp3) ansprechen,
    aber er irgendwie nicht..
    Die Rechtevergabe sollte auch stimmen..

    Hoffe jemand von euch kann helfen.

    Danke schonmal im voraus.

    Anneon


  • 1
  • moritz moritz
    Jedi-Meister
    0 x
    369 Beiträge
    0 Hilfreiche Beiträge
    16. 02. 2009, 10:04

    ... ist bei mir das gleiche Problem.

    Schade, denn diesen Player finde ich eigentlich total gut. o.O

    Allerdings gibt es von diesem Player eine Menge Extensions, die auf der gleichen Basis funktionieren (wennauch meist im Alpa-/Beta-Stadium)), vielleicht läuft ja ein andere Player dieser Familie.

    Vielleicht hat auch der Source (Wordpress Flash player from 1 Pixel Out) ein Problem mit dem neuen Flash-Player, dann funktionieren die natürlich alle nicht. :'(

  • neo2001 neo2001
    Padawan
    0 x
    44 Beiträge
    0 Hilfreiche Beiträge
    01. 03. 2010, 00:51

    Ich hab das gleiche Problem.

    Grundsätzlich sollte der Player funktionieren, da ich ihn erst kürzlich "manuell" auf einer non-Typo3 Seite verwendet habe.

    Ich möchte den Player gern per TS ins Template einbinden:

    [TS]plugin.tx_pmkmp3player_pi1 {
    file = fileadmin/music/intro-song.mp3
    autostart = 1
    loop = 0
    bg = #ffffff
    }

    temp.navFooter.30 < plugin.tx_pmkmp3player_pi1
    [/TS]

    Der Player wird angezeigt und findet dann aber eben die besagte Datei nicht.

    Hat jemand hier das Problem lösen können?
    Würde den Player grundsätzlich schon gern verwenden.

  • neo2001 neo2001
    Padawan
    0 x
    44 Beiträge
    0 Hilfreiche Beiträge
    01. 03. 2010, 18:30

    Nach genauerer Betrachtung der PHP-Datei der Extension ist mir aufgefallen, dass die MP3-Datei zwingend im angelegten Upload-Order liegen muss.

    Zudem hab ich die aktuelle player.swf anstatt der mitgelieferten verwendet. Wobei letzteres wohl nicht notwendig gewesen wäre.

    Auf jeden Fall funktioniert es jetzt.

  • 1