Artikelattribut "Datum" wird abgeschnitten und als Zahl interpretiert

  • smeagul smeagul
    Padawan
    0 x
    58 Beiträge
    0 Hilfreiche Beiträge
    21. 01. 2009, 19:26

    ich arbeite mit commerce 0.9.8

    Mein Problem betrifft die Zuordnung von Datumswerten an Artikel.
    Wenn ich das Attribut "Datum" einem Artikel zuweise, wie 29.05.2009, im Backend wird dieses korrekt angezeigt, aber im Frontend wird lediglich 29.05 angezeigt.

    Ich habe in der Tabelle tx_commerce_articles_article_attributes_mm nachgeschaut wo dieses Attribut abgespeichert wird.
    Es wird in der "default_value" Spalte gespeichert. Diese hat double als Datentyp.
    Folglich wird mein Datum als Zahl interpretiert.

    Wo kann ich das beheben ? Oder hat jemand diesen Bug schon behoben?

    Manfred


  • 1
  • swingtra swingtra
    Sternenflotten-Admiral
    0 x
    185 Beiträge
    0 Hilfreiche Beiträge
    11. 02. 2009, 18:48

    Irgentwie scheint mir in der pi1_...php oder in den angrenzenden require_once - Dateien, also irgendwo , wo das Datum aus der DB mit der Funktion date bearbeitet wird, die Jahreszahl abgeschnitten.

    Könnte auch unter Typoscript das Problem sein, daß da ein falsches Format existiert , mal nach "date" suchen.
    Typoscript-info:
    php.info: http://de.php.net/manual/de/function.date.php

    ... Evtl könnte in php auch die Funktion: str_replace an besagter Stelle falsch eingestellt sein (kann ich mir aber nicht vorstellen)

    info: http://de.php.net/str_replace

  • 1