RealUrl: Bei Aufruf der Unterseite wird übergeordnete Seite angezeigt [Gelöst]

  • 0 x
    103 Beiträge
    0 Hilfreiche Beiträge
    29. 12. 2008, 22:17

    Hallo Freunde!
    Habe folgende Seitenstruktur:
    -Home
    -Dienstleistungen
    --Webdesign
    --Programmierung
    --Automatisierung
    --Individuell
    -Referenzen

    Das Menü wird richtig dargestellt. Wenn ich aber jetzt einer der Unterseiten bei Dienstleistungen anklicke, zum Beispiel "Webdesign", dann gelange ich immer auf die Seite "Dienstleistungen". Habt ihr eine Idee warum??
    Hier meine realurl Konfiguration:

    1. <?php
    2.  
    3.  
    4. $TYPO3_CONF_VARS['EXTCONF']['realurl']['_DEFAULT'] = array(
    5. 'init' => array(
    6. 'enableCHashCache' => 1,
    7. 'appendMissingSlash' => 'ifNotFile',
    8. 'enableUrlDecodeCache' => 1,
    9. 'enableUrlEncodeCache' => 1,
    10. 'respectSimulateStaticURLs' => 0,
    11. 'postVarSet_failureMode'=>'redirect_goodUpperDir',
    12. ),
    13. 'redirects_regex' => array (
    14.  
    15. ),
    16. 'preVars' => array(
    17. 'GETvar' => 'no_cache',
    18. 'valueMap' => array(
    19. 'no_cache' => 1,
    20. ),
    21. 'noMatch' => 'bypass',
    22. ),
    23. 'GETvar' => 'L',
    24. 'valueMap' => array(
    25. 'en' => '1',
    26. ),
    27. 'noMatch' => 'bypass',
    28. ),
    29. ),
    30. 'pagePath' => array (
    31. 'type' => 'user',
    32. 'userFunc' => 'EXT:aoe_realurlpath/class.tx_aoerealurlpath_pagepath.php:&tx_aoerealurlpath_pagepath->main',
    33. 'spaceCharacter' => '-',
    34. 'cacheTimeOut'=>'100',
    35. 'languageGetVar' => 'L',
    36. 'rootpage_id' => '1',
    37. 'segTitleFieldList'=>'alias,tx_aoerealurlpath_overridesegment,nav_title,title,subtitle',
    38. ),
    39. 'postVarSets' => array(
    40. '_DEFAULT' => array(
    41. // news archive parameters
    42. 'archive' => array(
    43. 'GETvar' => 'tx_ttnews[year]' ,
    44. ),
    45. 'GETvar' => 'tx_ttnews[month]' ,
    46. 'valueMap' => array(
    47. 'january' => '01',
    48. 'february' => '02',
    49. 'march' => '03',
    50. 'april' => '04',
    51. 'may' => '05',
    52. 'june' => '06',
    53. 'july' => '07',
    54. 'august' => '08',
    55. 'september' => '09',
    56. 'october' => '10',
    57. 'november' => '11',
    58. 'december' => '12',
    59. )
    60. ),
    61. ),
    62. // news pagebrowser
    63. 'browse' => array(
    64. 'GETvar' => 'tx_ttnews[pointer]',
    65. ),
    66. ),
    67. // news categories
    68. 'select_category' => array (
    69. 'GETvar' => 'tx_ttnews[cat]',
    70. ),
    71. ),
    72. // news articles and searchwords
    73. 'article' => array(
    74. 'GETvar' => 'tx_ttnews[tt_news]',
    75. 'lookUpTable' => array(
    76. 'table' => 'tt_news',
    77. 'id_field' => 'uid',
    78. 'alias_field' => 'title',
    79. 'addWhereClause' => ' AND NOT deleted',
    80. 'useUniqueCache' => 1,
    81. 'useUniqueCache_conf' => array(
    82. 'strtolower' => 1,
    83. 'spaceCharacter' => '-',
    84. ),
    85. ),
    86. ),
    87. 'GETvar' => 'tx_ttnews[swords]',
    88. ),
    89. ),
    90. ),
    91. ),
    92.  
    93. 'fileName' => array(
    94. 'defaultToHTMLsuffixOnPrev'=>1,
    95. 'index' => array(
    96. 'rss.xml' => array(
    97. 'keyValues' => array(
    98. 'type' => 100,
    99. ),
    100. ),
    101. 'rss091.xml' => array(
    102. 'keyValues' => array(
    103. 'type' => 101,
    104. ),
    105. ),
    106. 'rdf.xml' => array(
    107. 'keyValues' => array(
    108. 'type' => 102,
    109. ),
    110. ),
    111. 'atom.xml' => array(
    112. 'keyValues' => array(
    113. 'type' => 103,
    114. ),
    115. ),
    116. ),
    117. ),
    118. );
    119.  
    120.  
    121. ?>

    Ich verwende übrigens die Extension danp_realurlconfigurator.

    LG,
    Emanuel


  • 1
  • 0 x
    103 Beiträge
    0 Hilfreiche Beiträge
    29. 12. 2008, 22:30

    Hallo Leute!
    *g* ich weiß leider nicht mehr genau wie, aber nachdem ich den RealUrl Cache gelöscht habe, die Extension aoe_realurlpath installiert und wieder deinstalliert habe gab es das beschriebene Problem nicht mehr - die Unterseiten werden dargestellt.
    LG

  • 1