powermail Email-Validierung

  • jenses jenses
    Flash Gordon
    0 x
    3087 Beiträge
    106 Hilfreiche Beiträge
    11. 12. 2008, 13:19

    Hi!

    Die Validierung in powermail ist fehlerhaft,
    eine gültige Email-Adresse wie [b]name@big-company.com[/b]
    führt zur Fehlermeldung "Die eingegebene E-Mail Adresse existiert nicht"


  • einpraegsam.net einpraegs...
    MacGyver
    0 x
    9340 Beiträge
    80 Hilfreiche Beiträge
    11. 12. 2008, 16:38

    Mein heißer Tipp: Falsch gesetztes E-Mail Feld im Reiter Absendermail

    in2code.de - Wir leben TYPO3
    - Möchtest du TYPO3 komplett verstehen? Eigene Erweiterungen erstellen? Bei uns gibt es auch Schulungen https://www.in2code.de/produkte/typo3-schulungen/
    - Die Arbeit mit TYPO3 macht dir Spaß? Du stehst auf Berge? Komm zu uns! https://www.in2code.de/agentur/karriere/

  • jenses jenses
    Flash Gordon
    0 x
    3087 Beiträge
    106 Hilfreiche Beiträge
    11. 12. 2008, 17:13

    [quote="einpraegsam.net"]
    Mein heißer Tipp: Falsch gesetztes E-Mail Feld im Reiter Absendermail
    [/quote]
    Falsch geraten, da ist alles korrekt.

    Bei anderen Email-Adressen wie [b]name@bigcompany.com[/b] [b]OHNE[/b] Bindestrich im Teil nach dem @ funktioniert ja auch alles prima.

    Ich würde stattdessen auf einen regexp-Fehler tippen,
    nur habe ich nicht die Zeit danach zu suchen.
    Änderungen an ext/powermail/js/mandatoryjs/validation.js bringen jedenfalls nix.

  • jenses jenses
    Flash Gordon
    0 x
    3087 Beiträge
    106 Hilfreiche Beiträge
    12. 12. 2008, 08:46

    Wo findet die Validierung bei unverändertem TS-Setup (also in "Werkseinstellung") statt?
    In welchem Script muß ich danach suchen?

  • jenses jenses
    Flash Gordon
    0 x
    3087 Beiträge
    106 Hilfreiche Beiträge
    12. 12. 2008, 09:36

    mit
    [TS]email.checkMX = 0[/TS]
    funktioniert es.

    Liegt es daran,
    daß die ins Formular eingetragene Email-Adresse zur selben Domän gehört wie die Seite,
    auf der sich das PlugIn befindet?

  • einpraegsam.net einpraegs...
    MacGyver
    0 x
    9340 Beiträge
    80 Hilfreiche Beiträge
    12. 12. 2008, 13:07

    nein - scheinbar geht der MX Check bei dir nicht siehe Funktion checkMX in der lib/tx_powermail_functions_div.php

    in2code.de - Wir leben TYPO3
    - Möchtest du TYPO3 komplett verstehen? Eigene Erweiterungen erstellen? Bei uns gibt es auch Schulungen https://www.in2code.de/produkte/typo3-schulungen/
    - Die Arbeit mit TYPO3 macht dir Spaß? Du stehst auf Berge? Komm zu uns! https://www.in2code.de/agentur/karriere/

  • jenses jenses
    Flash Gordon
    0 x
    3087 Beiträge
    106 Hilfreiche Beiträge
    12. 12. 2008, 14:05

    [quote="einpraegsam.net"]
    nein - scheinbar geht der MX Check bei dir nicht siehe Funktion checkMX in der lib/tx_powermail_functions_div.php
    [/quote]

    Hmmh, dann ist der MX check aber ziemlich wertlos,
    wenn Emailadressen als ungültig zurückgewiesen werden, weil der MX-check FALSE liefert, obwohl die Adresse definitiv korrekt ist?

    Vielleicht wäre es da besser sie per deafault zu deaktivieren...

  • einpraegsam.net einpraegs...
    MacGyver
    0 x
    9340 Beiträge
    80 Hilfreiche Beiträge
    12. 12. 2008, 14:25

    Noch besser: Bugfixen - scheint wohl ein Fehler zu sein

    in2code.de - Wir leben TYPO3
    - Möchtest du TYPO3 komplett verstehen? Eigene Erweiterungen erstellen? Bei uns gibt es auch Schulungen https://www.in2code.de/produkte/typo3-schulungen/
    - Die Arbeit mit TYPO3 macht dir Spaß? Du stehst auf Berge? Komm zu uns! https://www.in2code.de/agentur/karriere/

  • 0 x
    11 Beiträge
    0 Hilfreiche Beiträge
    05. 10. 2009, 12:38

    ist zwar schon ein 3/4 Jahr alt der Thread, aber hat mir doch etliche Stunden sucherei erspart :-)

  • kitze kitze
    T3PO
    0 x
    25 Beiträge
    0 Hilfreiche Beiträge
    19. 11. 2009, 13:49

    und mir auch ;-)