lz_gallery benutzt die falschen Bilder

  • TheDuke TheDuke
    T3PO
    0 x
    15 Beiträge
    0 Hilfreiche Beiträge
    23. 01. 2004, 10:22

    Hallo,

    ich habe bei mir lz_gallery installiert und benutzte simulateStaticDocuments mit md5.

    Am Anfang lief alles wunderbar. Jetzt habe ich ca. 15 Gallery's angelegt und nun tritt das Problem auf, dass sich lz_gallery bei 3 Gallery's die falschen Bilder zieht.

    Die Thumb's sind in der Vorschau noch richtig. Die Überschrift der Gallery auch. Nur die Bilder sind halt aus einer ganz anderen Gallery.

    Kennt jemand das Problem und kann mir vielleicht einen kleine Tip geben woran das liegen kann? thx

    Gruß
    bucky


  • 1
  • Lord Lord
    R2-D2
    0 x
    127 Beiträge
    0 Hilfreiche Beiträge
    30. 05. 2004, 11:55

    hmm ich hab das gleiche problem,... wie hast du es gelöst???

  • jamiro jamiro
    T3PO
    0 x
    30 Beiträge
    0 Hilfreiche Beiträge
    06. 06. 2004, 05:06

    ich auch ,. wenn ich die subgalerie (B) verstecke oder loesche deren thumbs frecherweise in einer anderen galerie (A) angezigt werden, dann werden die richtigen thumbs angezeigt, lege ich eine neue galerie (B-neu) an werden wieder die falschen angezeigt. (in A)

    :o(

  • jamiro jamiro
    T3PO
    0 x
    30 Beiträge
    0 Hilfreiche Beiträge
    06. 06. 2004, 16:00

    und hier die loesung, bei mir hat es geholfen:

    yes, this is a bug. I've added a comment to the documentation:
    http://typo3.org/documentation/document-library/lz_gallery/Known_problems-54/

    that should solve your problem.

    also:

    Solution: you have to edit the code, specifically file pi1/class.tx_lzgallery_pi1.php, find the function "getImages":

    Code Listing:

    find:

    $storekey = md5('pathinfo'.filemtime($fullpath));

    and change it into this:

    $storekey = md5(serialize(array('pathinfo', $fullpath, filemtime($fullpath))));

  • Lord Lord
    R2-D2
    0 x
    127 Beiträge
    0 Hilfreiche Beiträge
    07. 06. 2004, 07:27

    Hehe, ja :) Das war mein Bug den ich bei dem gemeldet hab, nachdem hier nix kam hab ich ihn direkt angeschrieben und es kam kurz darauf schon eine Antwort, allerdings kam keine Antwort auf meine Frage ob die Gallerie denn nun erweitert wird oder nicht :(

    Schade eigentlich!!

    gruss aus Rheinhessen!

  • 1