FE-User bekommen nur geschützte Seiten als Treffer? [Gelöst]

  • Julian.Hofmann Julian.Ho...
    Flash Gordon
    0 x
    2854 Beiträge
    106 Hilfreiche Beiträge
    20. 10. 2008, 12:16

    Hallo.

    Stehe gerade vor einem Problem (oder auf dem Schlauch).

    Haben die indexed_search (2.11.0) in einer TYPO3 4.2.1 laufen. Es wird indiziert, die Suche liefert Ergebnisse,... soweit so gut.
    Ist jedoch ein FE-User eingeloggt, so bekommt er in der Trefferliste nur Ergebnisse aus der Menge der geschützten (für ihn zugänglichen) Seiten - aber keine allgemeinzugänglichen Seiten.

    Mir scheint das nicht sehr logisch. Passt an unserer Konfiguration was nicht? Oder passt an der indexed_search da was nicht?

    Über Tipps würde ich mich freuen

    Viele Grüße
    Julian


  • just2b just2b
    TYPO3-Yoda
    0 x
    18741 Beiträge
    2 Hilfreiche Beiträge
    20. 10. 2008, 12:28

    Hallo,

    das ist ein nachteil der inxeded-search, er sollte die seiten dann bekommen, sobald er sie als eingeloggter user auch gesehen hat, IMO

    georg

  • Julian.Hofmann Julian.Ho...
    Flash Gordon
    0 x
    2854 Beiträge
    106 Hilfreiche Beiträge
    30. 10. 2008, 14:26

    Hallo Georg.

    Danke für die Antwort.

    Ist irgendwie etwas frustrierend für eine Intranetanwendung, wenn man erst die Seite besucht haben muss, nach der man sucht... :(

    Viele Grüße
    Julian

  • just2b just2b
    TYPO3-Yoda
    0 x
    18741 Beiträge
    2 Hilfreiche Beiträge
    30. 10. 2008, 14:31

    naja ansonsten musst du halt den crawler einrichten

    georg

  • Julian.Hofmann Julian.Ho...
    Flash Gordon
    0 x
    2854 Beiträge
    106 Hilfreiche Beiträge
    30. 10. 2008, 15:16

    Hallo georg.

    An den Crawler hab ich mich schon mehrmals rangemacht - nur nie zum Laufen bekommen. Was an Beschreibungen zur Einrichtung zu finden ist, unterscheidet sich ja doch ziemlich (bzw. ist von TYPO3-Version abhängig, ohne dass es erwähnt wird). :(

    Fällt Dir spontan eine Quelle ein, die sich mit aktuellem TYPO3 (4.2.x) und der aktuellen crawler-Version befasst?

    Viele Grüße
    Julian

  • just2b just2b
    TYPO3-Yoda
    0 x
    18741 Beiträge
    2 Hilfreiche Beiträge
    30. 10. 2008, 15:17

    ich hab eigenltich keine probleme gehabt, außer bei windows servern, genommen hab ich was ich gefunden habe

    georg

  • Julian.Hofmann Julian.Ho...
    Flash Gordon
    0 x
    2854 Beiträge
    106 Hilfreiche Beiträge
    13. 12. 2016, 10:53

    Hallo.

    Stehe gerade vor einem Problem (oder auf dem Schlauch).

    Haben die indexed_search (2.11.0) in einer TYPO3 4.2.1 laufen. Es wird indiziert, die Suche liefert Ergebnisse,... soweit so gut.
    Ist jedoch ein FE-User eingeloggt, so bekommt er in der Trefferliste nur Ergebnisse aus der Menge der geschützten (für ihn zugänglichen) Seiten - aber keine allgemeinzugänglichen Seiten.

    Mir scheint das nicht sehr logisch. Passt an unserer Konfiguration was nicht? Oder passt an der indexed_search da was nicht?

    Über Tipps würde ich mich freuen

    Viele Grüße
    Julian

  • just2b just2b
    TYPO3-Yoda
    0 x
    18741 Beiträge
    2 Hilfreiche Beiträge
    13. 12. 2016, 10:53

    Hallo,

    das ist ein nachteil der inxeded-search, er sollte die seiten dann bekommen, sobald er sie als eingeloggter user auch gesehen hat, IMO

    georg

  • Julian.Hofmann Julian.Ho...
    Flash Gordon
    0 x
    2854 Beiträge
    106 Hilfreiche Beiträge
    13. 12. 2016, 10:53

    Hallo Georg.

    Danke für die Antwort.

    Ist irgendwie etwas frustrierend für eine Intranetanwendung, wenn man erst die Seite besucht haben muss, nach der man sucht... :(

    Viele Grüße
    Julian

  • just2b just2b
    TYPO3-Yoda
    0 x
    18741 Beiträge
    2 Hilfreiche Beiträge
    13. 12. 2016, 10:53

    naja ansonsten musst du halt den crawler einrichten

    georg