tt_news RSS XML gibt Division by zero aus

  • 0 x
    77 Beiträge
    0 Hilfreiche Beiträge
    24. 09. 2008, 17:58

    Hallo und zwar versuche ich mit typo3 4.2.1 den Feed auszugeben.

    Rufe ich nun die Feedseite auf: http://www.meinedomain.de/index.php?id=44&type=100

    erhalte ich leider folgende Meldungen:

    Warning: Division by zero in /typo3conf/ext/tt_news/pi/class.tx_ttnews.php on line 991

    Warning: Division by zero in /typo3conf/ext/tt_news/pi/class.tx_ttnews.php on line 991

    Warning: Division by zero in /typo3conf/ext/tt_news/pi/class.tx_ttnews.php on line 991

    Warning: Division by zero in /typo3conf/ext/tt_news/pi/class.tx_ttnews.php on line 991

    Warning: Division by zero in /typo3conf/ext/tt_news/pi/class.tx_ttnews.php on line 991

    Warning: Division by zero in /typo3conf/ext/tt_news/pi/class.tx_ttnews.php on line 991

    Warning: Division by zero in /typo3conf/ext/tt_news/pi/class.tx_ttnews.php on line 991

    Warning: Cannot modify header information - headers already sent by (output started at /typo3conf/ext/tt_news/pi/class.tx_ttnews.php:991) in /typo3/sysext/cms/tslib/class.tslib_fe.php on line 3221

    Warning: Cannot modify header information - headers already sent by (output started at typo3conf/ext/tt_news/pi/class.tx_ttnews.php:991) in /typo3/sysext/cms/tslib/class.tslib_fe.php on line 3234

    Habe jetzt zum 10 mal alles neu eingebunden unter Constants und Setup - auch diverse Tutorials durchgegangen.

    Constants:
    [TS]

    xmlnewsfeed_id = 44

    plugin.tt_news.displayXML.xmlLimit = 10
    plugin.tt_news.displayXML.xmlCaching = 1
    plugin.tt_news.displayXML.xmlTitle = News von diedomain.de
    plugin.tt_news.displayXML.xmlLink = http://www.diedomain.de
    plugin.tt_news.displayXML.xmlDesc = News von diedomain.de
    plugin.tt_news.displayXML.xmlLang = de
    plugin.tt_news.displayXML.xmlIcon = EXT:tt_news/ext_icon.gif
    plugin.tt_news.displayXML.xmlFormat = rss2
    plugin.tt_news.displayXML.title_stdWrap.htmlSpecialChars = 1
    plugin.tt_news.displayXML.title_stdWrap.htmlSpecialChars.preserveEntities = 1
    plugin.tt_news.displayXML.subheader_stdWrap.stripHtml = 1
    plugin.tt_news.displayXML.subheader_stdWrap.htmlSpecialChars = 1
    plugin.tt_news.displayXML.subheader_stdWrap.htmlSpecialChars.preserveEntities = 1
    plugin.tt_news.displayXML.subheader_stdWrap.crop = 425 | ...
    plugin.tt_news.displayXML.subheader_stdWrap.ifEmpty.field = bodytext
    plugin.tt_news.displayXML.xmlLastBuildDate = 1
    plugin.tt_news.displayXML.xmlIcon = typo3conf/ext/tt_news/ext_icon.gif

    [/TS]

    Setup:
    [TS]page.headerData.500 = TEXT
    page.headerData.500.value = <link rel="alternate" type="application/rss+xml" title="RSS-Feed" href="http://www.diedmoain.de/index.php?id=44&type=100" />
    xmlnews = PAGE
    xmlnews {
    typeNum = 100
    10 >
    10 < plugin.tt_news
    10.pid_list >
    10.pid_list = {$plugin.tt_news.pid_list}
    10.singlePid = {$plugin.tt_news.singlePid}
    10.defaultCode = XML
    config {
    disableAllHeaderCode = 1
    additionalHeaders = Content-type:text/xml
    no_cache = 1
    xhtml_cleaning = 0
    }
    }[/TS]

    vielen Dank im Voraus


  • 1
  • thePIXEL thePIXEL
    Jar Jar Binks
    0 x
    1 Beiträge
    0 Hilfreiche Beiträge
    16. 02. 2010, 16:31

    Hallo zusammen,
    auch wenn seit der Frage von electric-x schon geraume Zeit verstrichen ist...ich habe exakt das gleiche problem und finde keine lösung. Habe gefühlt das halbe internet durchsucht und alles was ich gefunden habe ist der selbe fehler ohne lösung...kann vielleicht doch noch jemand was sagen/helfen?

    Auf jeden Fall schon mal besten dank

  • 1