chgallery Probleme Mit Verlinkung

  • timmy2007 timmy2007
    Jedi-Meister
    0 x
    426 Beiträge
    0 Hilfreiche Beiträge
    22. 09. 2008, 16:54

    Habe nun mal die chgallery Extension als Test installiert.

    Wird alles soweit angezeigt. Doch mit der Verlinkung der Bilder komme ich nicht klar.

    Wenn man auf ein Bild klickt, daß vergrößert angezeigt werden soll, ohne Slimbox (oder so), einfach auf einer neuen Seite, muß ich dann das Plugin erneut auf der entsprechenden SEite einfügen oder wie klappt das?


  • just2b just2b
    TYPO3-Yoda
    0 x
    18741 Beiträge
    2 Hilfreiche Beiträge
    22. 09. 2008, 16:55

    Hallo,

    wenn du eine Single-View willst, dann musst du noch 2-3 Tage warten, dann kommt das ins TER siehe http://www.rggooglemap.com/dev/chgallery/einzelansicht.html

    Wenn du die Einzelansicht als Popup haben willst, dann ist das via TS möglich

    georg

  • timmy2007 timmy2007
    Jedi-Meister
    0 x
    426 Beiträge
    0 Hilfreiche Beiträge
    22. 09. 2008, 16:58

    Aha, na dann warte ich und werde erst einmal das alles per Slimbox aktivieren. Danke!

  • just2b just2b
    TYPO3-Yoda
    0 x
    18741 Beiträge
    2 Hilfreiche Beiträge
    22. 09. 2008, 16:59

    single view bleibt aber vorerst nur auf der gleichen seite möglich

    lg georg

  • timmy2007 timmy2007
    Jedi-Meister
    0 x
    426 Beiträge
    0 Hilfreiche Beiträge
    22. 09. 2008, 17:13

    Ok, das wird ja dann hoffentlich genauer erklärt.

    Noch etwas anderes: Wie ist denn der TS Code für die perfectlightbox? Der für die pkslimbox ist ja in der Demo vorhanden. Habe aber die pkslimbox nicht installiert, sondern die perfectlightbox.

    Wird dann das Bild automatisch durch den TS Code der Slimbox anklickbar?

  • just2b just2b
    TYPO3-Yoda
    0 x
    18741 Beiträge
    2 Hilfreiche Beiträge
    22. 09. 2008, 17:37

    Hallo,

    perfectlightbox ist ident

    georg

  • timmy2007 timmy2007
    Jedi-Meister
    0 x
    426 Beiträge
    0 Hilfreiche Beiträge
    22. 09. 2008, 18:16

    Das geht irgendwie nicht. Den TS Code füge ich ins Setup?

  • just2b just2b
    TYPO3-Yoda
    0 x
    18741 Beiträge
    2 Hilfreiche Beiträge
    22. 09. 2008, 18:35

    ja, hat aber mit meiner ext nichts zu tun

    georg

  • timmy2007 timmy2007
    Jedi-Meister
    0 x
    426 Beiträge
    0 Hilfreiche Beiträge
    23. 09. 2008, 16:22

    So, ich habe nun die aktuellste Version von chgallery installiert.

    Folgenden TS Code habe ich ins Setup eingefügt:
    [TS]plugin.tx_chgallery_pi1 {
    # general settings
    _DEFAULT_PI_VARS.single = 1

    fileTypes = jpg,gif,png
    templateFile = EXT:chgallery/res/template.html
    pathToCSS = EXT:chgallery/res/gallery.css
    ajaxScript = EXT:chgallery/res/js/ajax.js
    pathToMootools = EXT:chgallery/res/js/mootools.js
    pagebrowser = 9
    ajax = 0
    useAnchor = 1
    exif = 1
    ratings = 1
    ratings {
    # config of ratings to override default settings of the ext
    }

    #################
    #### SINGLE VIEW
    #################
    single {
    pass = 1

    image {
    file.maxW = 554
    }

    download {
    labelStdWrap.field= tx_chgalleryTitle // tx_chgalleryFilename
    icon = 1
    icon_link = 1
    icon {
    noTrimWrap = | | |
    }
    size = 0
    size {
    noTrimWrap = | (| Bytes) |
    bytes = 1
    bytes.labels = | Kb| Mb| Gb
    }
    jumpurl = 1
    jumpurl.secure = 1
    }

    exif_size {
    bytes = 1
    bytes.labels = | Kb| Mb| Gb
    }
    exif_time {
    strftime= %d.%m.%Y %H:%m
    }

    }

    #################
    #### CATEGORY VIEW
    #################
    category {
    image {
    file.maxW = 100
    }

    link {
    useCacheHash = 1
    }

    date = %d.%m.%Y %H:%m

    }

    #################
    #### GALLERY VIEW
    #################
    gallery <.single
    gallery {
    dir_description {
    required = 1
    stdWrap.wrap = <br />|<br />
    }
    dir_title {
    required = 1
    stdWrap.wrap = <strong>|</strong>
    }
    description {
    ifEmpty = &nbsp;
    }
    image {
    file {
    maxW = 139
    maxH = 110
    }
    }

    renderAllLinks = 1
    renderAllLinks {
    title.field= tx_chgalleryTitle

    parameter.override.cObject = IMG_RESOURCE
    parameter.override.cObject {
    file.import.field = tx_chgalleryImageLong
    file.maxW = 800
    file.maxH = 600
    }

    ATagParams = rel="lightbox"
    ATagParams.override = rel="lightbox[presentlb{field:uid}]"
    ATagParams.insertData = 1
    }
    }

    }

    ## Set up page/type number:
    export_chgallery >
    export_chgallery = PAGE
    export_chgallery {
    typeNum=9712
    config.disableAllHeaderCode = 1
    config.metaCharset = utf-8
    config.additionalHeaders = Content-Type:text/xml;charset=utf-8
    config.xhtml_cleaning = 0
    config.admPanel = 0
    config.sendNoCacheHeaders = 1
    config.no_cache = 1

    ## Inserting the USER cObject for XML rendering
    10 = CONTENT
    10 {
    table = tt_content
    select {
    pidInList = this
    max = 1
    andWhere = list_type='chgallery_pi1'
    }

    renderObj = COA
    renderObj {
    10 < plugin.tx_chgallery_pi1
    10.userFunc = tx_chgallery_pi1->xmlFunc
    }
    }
    }
    [/TS]

    In der Flexform zum Plugin habe ich die Galerie Ansicht, den Pfad zum Bilderverzeichnis, wieviele Bilder pro Seite angezeigt werden sollen und noch "Benutze Detail Ansicht" angeklickt.

    Jetzt fährt man mit der Maus über die jeweiligen Bilder und man kann auch darauf klicken. Nur öffnet sich keine Single-Ansicht, sondern man kommt zur ursprünglichen Fotoübersicht zurück!

    Was ist da falsch?

  • just2b just2b
    TYPO3-Yoda
    0 x
    18741 Beiträge
    2 Hilfreiche Beiträge
    23. 09. 2008, 16:27

    Hallo,

    warum kopierst du das ganze TS nochmal in dein TS? wird ja e schon inkludiert.. hier bitte nur die änderungen rein!

    für einzelansicht musst du 2x das plugin auf der gleichen seite haben:
    1.) kategorie oder gallery view mit checkbox "einzelansicht" aktiviert
    2.) einzelansicht view

    beide plugins brauchen den gleichen pfad drin und die gleiche zahl beim pagebrowser

    georg