Datenverlust durch mysql import

  • fschnidi fschnidi
    Sternenflotten-Admiral
    0 x
    192 Beiträge
    0 Hilfreiche Beiträge
    15. 08. 2008, 02:23

    Hallo zusammen
    Ich habe meinen typo3 Auftritt gerade au einen neuen Server umgezogen. Beim Import der mysql Datenbank über phpmyadmin sind aber ganze Textfetzen verloren gegangen! So fehlt teilweise die Hälfte des bodytextes eines Inhaltselementes, oder auch bei den Constants fehlt ein Stück...wie abgeschnitten nach einer bestimmten Anzahl Zeichen.

    Kann sich jemand erklären womit das zusammenhängen könnte? Ich habe auch versucht einzelne Tabellen einzeln zu im-/exportieren, da ich dachte es sind zu grosse dumps, aber da passiert das gleiche..

    Gruss Flo


  • 1
  • typo3tester typo3test...
    Jedi-Meister
    0 x
    260 Beiträge
    0 Hilfreiche Beiträge
    15. 08. 2008, 10:06

    Seltsam, das habe ich noch nicht erlebt.
    Kannst Du genau feststellen, in welcher Zeile Deines SQL-Scripts das passiert und wie die aussieht?
    Welcher Feldtyp ist das?
    Welche Sprach-codierung ist eingestellt für die Datenbank, bzw. Tabelle, bzw. Feld?

    Grundsätzlich importiere ich die Scripte nicht per PhPMyAdmin, sondern über die Konsole mit Mysql-Befehlen, weil ich dann sicher gehen kann, daß es nicht zu einem Timeout kommt bei großen Tabellen.

    Wenn das aber immer an der gleichen Stelle passiert, auch wenn Du einzelne Tabellen importierst, dann kann es ja nicht die Masse sein.

    Vielleicht mußt Du auch das Backup-Script mal über Konsole machen und vergleichen, was anders ist.

    Gruß, Regina

  • 1