ve_guestbook Email richtig formatieren. [Gelöst]

  • Suriel Suriel
    TYPO3-Anwärter
    0 x
    4 Beiträge
    0 Hilfreiche Beiträge
    11. 08. 2008, 22:41

    Guten Abend,

    ich möchte einige Einträge der locallang-xml über TS ändern.

    Habe z.B hiermit die Bezeichnung der Text Box fett dargestellt

    [TS]plugin.tx_veguestbook_pi1 {
    _LOCAL_LANG.de.form_entry = <b>Nachricht</b> }[/TS]

    Dies wurde auch wie gewollt dargstellt, nun wollte ich als nächstes die Email umformatieren.

    [TS]plugin.tx_veguestbook_pi1 {
    _LOCAL_LANG.de.notification_mail_text = Neuer Gätebucheintrag: E-Mail: ###EMAIL### <br />Ort: ###PLACE### <br />Website: ###HOMEPAGE### <br />Nachricht: ###ENTRY### <br /><br />Hier geht es direkt zum Gästebuch: ###URL### }
    [/TS]

    Allerdings werden hier die HTML Tags einfach ignoriert und in der Email als normaler Text ausgegeben. Das ist aber nicht sinn und zweck. Ich möchte ja nicht den ganzen Text unschön in einer Zeile als Email bekommen.

    Weiß jemand rat ?

    gruß Suriel


  • 1
  • Andrea_Herzog Andrea_He...
    Jedi-Meister
    0 x
    432 Beiträge
    0 Hilfreiche Beiträge
    14. 08. 2008, 13:19

    Jawoll. So geht es: Du musst die brs entfernen und eine runde Klammer um den Text setzen. Alles, was in einer Zeile stehen soll wird dann auch so dargestellt.

    Beste Grüße

    Andrea

    [TS]

    plugin.tx_veguestbook_pi1._LOCAL_LANG {

    de {
    ...
    notification_mail_text(
    Sie haben einen neuen Gästebucheintrag!
    E-Mail: ###EMAIL###
    Ort: ###PLACE###
    WebsEite: ###HOMEPAGE###
    Nachricht: ###ENTRY###
    Hier geht es direkt zum Gästebuch: ###URL###
    )

    ....
    [/TS]

  • Suriel Suriel
    TYPO3-Anwärter
    0 x
    4 Beiträge
    0 Hilfreiche Beiträge
    14. 08. 2008, 15:08

    Danke sehr hat wunderbar funktioniert.

    Was aber wenn ich andere Tags als <br> verwenden möchte ?

  • Andrea_Herzog Andrea_He...
    Jedi-Meister
    0 x
    432 Beiträge
    0 Hilfreiche Beiträge
    14. 08. 2008, 17:46

    Wozu willst du das haben? Ich verstehe nicht ganz :o

  • 0 x
    75 Beiträge
    0 Hilfreiche Beiträge
    10. 09. 2010, 15:17

    Da muss ich "Danke" zu sagen, denn so was habe ich gerade verzweifelt gesucht. Jetzt klappt alles. :)

  • kolki kolki
    Jedi-General
    0 x
    1044 Beiträge
    5 Hilfreiche Beiträge
    24. 10. 2012, 17:24

    Überall im Web findet man die gleichen Codeschnipsel wie hier. Hab ich bereits ausprobiert, aber ich kann machen, was ich will.

    Bei der Mail an den Absender (feedback_mail_text) klappt alles.
    Bei der Mail an den Webmaster (notification_mail_text) werden die Marker nicht ersetzt.
    Hat jemand 'ne Idee, was hier die Ursache ist?

    Edit: In Verwendung ist TYPO3 4.7.x und ve_guestbook 2.12.0

  • 1