Extensions.MD5 allow_url_fopen, curl und deutsche Spracheinstellung

  • saccade saccade
    Typ im Roten Hemd
    0 x
    2 Beiträge
    0 Hilfreiche Beiträge
    12. 06. 2008, 00:56

    Hallo,

    ich habe bei der Neuinstallation der Version 4.2.1 Probleme mit der Einstellung der deutschen Benutzeroberfläche.
    Zwar ist mir das Verfahren klar, aber schon bei den ersten Schritten stimmt etwas nicht:

    1. Unter den "User settings" wird unter Language nur "English" angeboten.
    2. Im "Ext manager"/"Import extensions" kann ich weder die "reviewed" noch die komplette Liste der Extensions anzeigen lassen. In beiden Fällen gibt es folgende Fehlermeldung:
    "Error: The extension MD5 sum could not be fetched from extensions.md5. Possible reasons: network problems, allow_url_fopen is off, curl is not enabled in Install tool."
    3. Unter "Ext manager"/"Translation handling" kann ich zwar "German" auswählen und die Einstellung auch speichern, aber weder beim "Ckeck" noch beim "Update" kommt etwas heraus. Im ersteren Fall (check) ist die Version aller Modle "N/A" (klar, weil die ja wohl immer noch english sind). Im zweiten Fall (update) kommt die Meldung "Could not fetch translation status".
    Diese Fehler betrifft ja dann auch offensichtlich alle Versuche, eine Extension zu laden.
    4. Selbst das manuelle Herunterladen und Hochladen/Installieren der Extension "German language pack" (aber die ist ja schon älter - gibt es nicht eine neuere?) bringt keine Veränderung. Immer noch gibt es nur die english-Einstellung für die Benutzersprache.

    5. Den Cache habe ich immer wieder geleert und mich dann auch noch ausgeloggt und wieder eingeloggt.
    6. Immer wieder dasselbe Ergebnis: Die angebotene Sprache in den "User settings" bleibt bei einzig und allein "english".

    7. allow_url_fopen ist bei mir "off". Wohl aus gutem Security-Grund. Das war es aber voher auch und da ging die Sprachumstellung meines Erachtens nach.
    PHP ist 5.2.5
    8. Eine Einstellung für curl habe ich nicht direkt gefunden.
    Es gibt im Install-Menü so etwas wie "curlUse" - aber auch dieses anzukreuzen brachte keine Änderung.

    Also: Hat jemand einen Tipp woran es liegen kann?
    Habe ich etwas Entscheidendes übersehen?
    Oder gibt es für Typo3 4.2.1 etwa noch gar kein passendes deutsches Language pack?

    Edit: Genauer gefragt: Muss ich tatsächlich allo_url_fopen umstellen - und was bedeutet das sicherheitstechnisch?
    Oder wie kann ich die passenden Einstellungen bei curl vornehmen - und was bedeutet das wiederum?
    Oder ist es am Ende ein Repository-Problem? Denn ich kriege die volle Liste auch nicht auf meinen Browser, wenn ich direkt auf die Webseite gehe.

    Vielen Dank für jeden Hinweis!


  • 1
  • saccade saccade
    Typ im Roten Hemd
    0 x
    2 Beiträge
    0 Hilfreiche Beiträge
    12. 06. 2008, 11:23

    Ich habe inzwischen einmal kurz die Einstellung allow_url_fopen in meiner php.ini auf On gestellt und das ganze dann nochmals versucht.
    Diesmal ging alles problemlos: Translation handling (check und update) - und auch die Extension-Liste wurde aktualisiert.

    Ich habe danach allow_url_fopen wieder auf Off gesetzt, weil mir die sicherheitstechnischen Bedenken eine Warnung sind.

    Kann mir vielleicht jemand einen kurzen Hinweis geben, was hier geschieht?
    Und was im Sinne einer gut gesicherten Typo3-Installation geschehen sollte?

    Vielen Dank!

  • Plotz Plotz
    Padawan
    0 x
    62 Beiträge
    0 Hilfreiche Beiträge
    24. 03. 2010, 22:37

    1. alle *-l10n-de.zip Dateien im typo3temp Ordner löschen
    2. deutsches Sprachupdate machen
    3. neue Extension Liste holen

    fertig. :D

  • 1