rgecard utf8 meets iso

  • TW TW
    Jedi-General
    0 x
    1560 Beiträge
    0 Hilfreiche Beiträge
    14. 05. 2008, 12:38

    hallo nochmal,

    hmpf...erstmal sorry für mein penetrantes posting wegen dieser extension ;)

    folgendes problem.
    bestehende webseite ist in iso - extension schreibt die daten allerdings in utf8 in die db.
    beim auslesen der daten, wenn ich mir die ecard abhole - wird demzufolge mein name und der anderer inkl. message mit uf8 codierung ausgegeben.

    mir ist schon klar, das die webseite mit einem utf8 charset besser leben könnte, jedoch lässt sich das nun mit dem rest der seite nicht mehr ändern!

    meine frage:
    mittels $GLOBALS['TSFE']->csConv($tmp,'ISO-8859-1') habe ich probiert die ausgabe der daten auf iso zu zwängen - hat aber leidern icht geklappt.

    was kann ich noch machen bzw. probieren?
    für sachdienliche hinweise schon mal meinen dank und der dank meines projektmanagers ;)

    gruß


  • 1
  • just2b just2b
    TYPO3-Yoda
    0 x
    18741 Beiträge
    2 Hilfreiche Beiträge
    14. 05. 2008, 13:07

    dann mach in der ext einfach ein utf8en/decode wo du es brauchst

    georg

  • TW TW
    Jedi-General
    0 x
    1560 Beiträge
    0 Hilfreiche Beiträge
    14. 05. 2008, 16:01

    jo auch shcon probiert....

    im aufruf function getMarker

    1. $markerArray['###MSG_SLIMBOX###'] = $this->cObj->stdWrap(utf8_encode($row['msg']),$this->conf[$prefix]['msg_slimbox.']);

    funtz nicht. obschon er mir eigentlich das title tag des bildes hätte richtig ausgeben müssen....

    oder bin ich da völlig falsch?

    gruß[/code]

  • 1