Gifbuilder Jpg-Qualität

  • DerSvend DerSvend
    R2-D2
    0 x
    119 Beiträge
    0 Hilfreiche Beiträge
    09. 05. 2008, 12:13

    Hallo Forum!

    Ich habe auf einer Seite Kopfgrafiken, welche ich wie folgt über die Seiteneigenschaften einbinde:

    [TS]temp.head = IMAGE
    temp.head {
    file = GIFBUILDER
    file {
    XY = 960,185
    quality = 100
    format = jpg

    10 = IMAGE
    10 {
    file.import = uploads/media/
    file.import.data = levelmedia:-1, slide
    file.import.listNum = 0
    file.width = 960
    file.height = 185
    }
    }
    }
    [/TS]

    Die Qualität ist aber miserabel im Frontend. Keine JPG-Arktefakte, aber es sieht so aus, als wenn das Bild nur 256 Farben hat (ist aber jpg). Wenn ich im Install Tool gdlib_2 und gdlib_png aktiviere sieht es gut aus! Jedoch werden dann auch die transparenten Menügrafiken als 24-Bit Png erstellt und das kann der IE6 nicht. :-(

    Weiß jemand wie man die Kopfgrafiken vernünftig ausgibt und das Menü trotzdem als gif ausgegeben wird?


  • 1
  • maik maik
    Jedi-General
    0 x
    1194 Beiträge
    1 Hilfreiche Beiträge
    09. 05. 2008, 13:41

    Stell mal die JPG Qualität im Instrall tool auf 90 oder 100.
    Default ist glaube ich 70.
    Vielleicht hilft das.
    Grafiken natürlich einmal löschen, damit die auch neu generiert werden. ;)

    http://www.caroonline.de

  • DerSvend DerSvend
    R2-D2
    0 x
    119 Beiträge
    0 Hilfreiche Beiträge
    09. 05. 2008, 22:15

    Die Qualität hab ich auf 100 gesetzt im Install Tool. Bringt leider nichts :-(

    Was mir sonst noch einfallen würde als Lösung: das IE7-Script von Dean Edwards, da müssen dann aber alle PNG's "-trans" am Ende haben. Kann man irgendwie die Dateinamen mittels Typoscript beeinflussen?

  • moritz moritz
    Jedi-Meister
    0 x
    369 Beiträge
    0 Hilfreiche Beiträge
    15. 05. 2008, 01:00

    ... ich stehe vor dem selben Problem. (TYPO3 4.1.6)
    Was ich vor allem nicht verstehe:

    Das hier erzeugt eine miese Bildqualität:
    [TS]# Eyecacher zusammenbauen
    Eyecacher = IMAGE
    Eyecacher.stdWrap.typolink.parameter = 60
    Eyecacher.file = GIFBUILDER
    Eyecacher.file.XY = 210,210
    Eyecacher.file.format = jpg
    Eyecacher.file.quality = 100
    Eyecacher.file.10 = IMAGE
    Eyecacher.file.10.file = fileadmin/Kollektion/Eyecacher.jpg[/TS]

    Das hier sieht SUPER aus:
    [TS]GallerySmall = HMENU
    GallerySmall.entryLevel = 0
    GallerySmall.special = directory
    GallerySmall.special.value = 41
    GallerySmall.1 = GMENU
    GallerySmall.1 {
    NO = 1
    NO {
    XY = 420,420
    wrap = |
    10 = IMAGE
    10 {
    file.import.field = media
    file.import = uploads/media/
    file.import.listNum = 0
    }
    15 = SCALE
    15.width = 105
    15.height = 105[/TS]

    Und das, obwohl das GMENU das Bild erst noch klein rechnen muss, dem Gifbuilder gebe ich es ja schon in der richtigen Größe. (SCALE beim Gifbuilder brigt allerdings auch nix...)

    Offensichtlich geht es ja, aber warum dann nicht auch im Gifbuilder? Die benutzen doch beide nur ImageMagic, würde ich mal vermuten...

  • moritz moritz
    Jedi-Meister
    0 x
    369 Beiträge
    0 Hilfreiche Beiträge
    15. 05. 2008, 02:58

    Vergesst meine Mail von oben.
    Jetzt habe ich mir die halbe Nacht um die Ohren gehauen und verstehe es nicht:

    Ich bekomme alles völlig verpixelt, sowohl im Gifbuilder, wie auch im GMENU.

    Nun habe ich allerdings die ganze Zeit als Dummy dieses Bild hier benutzt:
    [img]http://www.ce-signo.com/diverses/Eyecacher.jpg[/img]

    Dieses eine Bild ist überall kristallklar, wenn ich es mit SCALE verkleinere. Wieso?

    Die anderen Bilder hatte ich auch einfach mal weichgezeichnet, ich dachte, es liegt an der Unschärfe meines Testbildes... tut es aber nicht.
    Alle Testbilder hatten 420x420 px, 96dpi, jpg 100% ... alles verpixelt, nur diese blöde Jacke nicht. #angry#

  • 0 x
    24 Beiträge
    0 Hilfreiche Beiträge
    09. 09. 2008, 15:49

    Hatte gerade das gleiche Problem - JPGs aus dem GIFBUILDER sehen verpixelt (oder nach reduzierter Farbpalette aus). Nachdem ich diesbezüglich diverse Threads durch bin, hat folgende Konfiguration Abhilfe geschafft - wenn man einen der 3 Parameter weglässt, läuft's schon nicht mehr - bei mir hat es nur die Kombi gebracht:

    [GFX][gdlib_png] = 1
    [GFX][png_truecolor] = 1
    [GFX][gdlib-2] = 1

    Die Default-JPG Qualität habe ich nicht auf 100 gesetzt, die Qualität lässt sich ja genauso per TS im Template bestimmen.

    Achtung, die erste Zeile hat als "Nebenwirkung", das jetzt generell PNGs anstelle von GIFs gerendert werden. Warum sich die PNG-Einstellungen auch auf die JPGs auswirken verstehe ich nicht. Aber gut ... solange es hilft ;)

    Folgende Info noch - bin nicht sicher ob relevant - habe GraphicsMagick statt ImageMagick auf dem Server, Typo3 Version ist eine 4.1.5.

  • Benjamecho Benjamech...
    Sternenflotten-Admiral
    0 x
    202 Beiträge
    0 Hilfreiche Beiträge
    12. 03. 2009, 18:13

    Danke Pausenbrot, das hat sehr geholfen!!! Hatte schon befürchtet auf Guifbuilder verzichten zu müssen, aber so klappt es wunderbar.

  • 1