Zum Download bereitgestellte PDF-Dokumente nicht aktuell

  • althoffc althoffc
    Padawan
    0 x
    51 Beiträge
    0 Hilfreiche Beiträge
    17. 04. 2008, 17:29

    Hallo,

    auf unserer Website werden PDF-Dokumente zum Download bereitgestellt.

    Diese Dokumente werden im Typo3 über [Dateiliste][Datei-Upload] in ein Verzeichnis unter /fileadmin/... hochgeladen.

    Inhaltlich werden die Dokumente regelmäßig aktualisiert und unter gleichen Namen in das gleiche Verzeichnis abgestellt (wiederum im Typo3 über [Datei-Upload], Überschreiben vorhandener Dateien: ja).

    In den Thumbnails und über "Info" (rechter Mausklick auf das PDF-Icon) können die inhaltlichen Änderungen der PDF-Dokumente nachvollzogen werden.

    Klicke ich in der Dateiliste auf den Namen des PDF-Dokuments, wird es mit dem Standard-PDF-Viewer angezeigt. Jedoch wird dann der vorherige Inhalt des PDF-Dokuments angezeigt.

    Auch wenn dann auf der Website der Link für den PDF-Download angeklickt wird, wird ein PDF-Dokument mit vorherigen/altem Inhalt angezeigt/gespeichert.
    (Cache habe ich auch zwischenzeitlich geleert, jedoch keine Änderung.)

    Was läuft da schief?
    Ich hätte erwartet, dass das aktualisierte PDF-Dokument mit dem Download zur Verfügung steht. (Thumbnail und 'Info' im Typo3 zeigen ja auch die aktuellen Änderungen).

    Weiss jemand Rat?

    Gruß,
    Carsten


  • 1
  • just2b just2b
    TYPO3-Yoda
    0 x
    18741 Beiträge
    2 Hilfreiche Beiträge
    17. 04. 2008, 17:30

    Hallo,

    und was sagt der Pfad im Quellcode?

    georg

  • althoffc althoffc
    Padawan
    0 x
    51 Beiträge
    0 Hilfreiche Beiträge
    18. 04. 2008, 17:39

    Der Pfad im Quelltext beinhaltet den korrekten Datei und Verzeichnisnamen.
    Merkwürdig ist halt, dass über 'Info' (rechter Mausklick in der Dateiliste auf das PDF-Icon) der aktualisierte Inhalt des PDF-Dokuments angezeigt wird, aber durch einen Klick auf den Dateinamen eine alte Version des PDF-Dokuments geladen und angezeigt wird.

    Ich weiss einfach nicht mehr weiter.
    Kannn im Typo3-Install-Tool evtl. ein Cache für Upload-Dateien oder Ähnliches konfiguriert werden.
    Welche anderen Aspekte könnten da mitspielen?

    Gruß,
    Carsten

  • karlchen karlchen
    Jedi-General
    0 x
    1433 Beiträge
    30 Hilfreiche Beiträge
    19. 04. 2008, 00:52

    hast du auch den Browser Cache geleert ?

  • althoffc althoffc
    Padawan
    0 x
    51 Beiträge
    0 Hilfreiche Beiträge
    21. 04. 2008, 09:57

    Hallo karlchen,

    ja, den Browser-Cache habe ich auch geleert. Auch bei anderen Browsern wurden nicht die aktuellen PDF-Dokumente geladen.

    Inzwischen werden beim Klick auf die Links die aktualisierten Dokumente vom 18.04.2008 angezeigt.

    Kurz nach dem Upload der Dokumente und Leeren des Typo3- und des Browser-Cache wurden die aktualisierten PDFs nicht angezeigt, sondern die vorherige Version.
    Im Typo3 wurden aber im Backend in der Dateiliste über 'Info' (rechter Mausklick) zu den PDF-Dokumenten eine aktuelle Vorschau angezeigt, jedoch beim Öffnen eines PDFs (ebenfalls im Backend) die alte Version angezeigt.
    Dieser Widerspruch macht mich einfach stutzig. #paralyzed#

    Dass aktualiserte Dokumente scheinbar etwas "Anlaufzeit" benötigen, bis sie als Download bereitstehen, kann ich in diesem Fall verkraften, obwohl ich es nicht wirklich verstehe.

    Gruß, Carsten

  • karlchen karlchen
    Jedi-General
    0 x
    1433 Beiträge
    30 Hilfreiche Beiträge
    22. 04. 2008, 00:10

    kann es sein das du bzw. dein Provider nocch hinter einem Proxy sitzen ?

    Die werden oft genutzt um Seiten zwischen zuspeichern um Netz und Serverlast zu verringern.
    Eventuell könnte da noch was sein...

  • 1