Korrektes setzen Rewrite

  • felis felis
    Sternenflotten-Admiral
    0 x
    249 Beiträge
    0 Hilfreiche Beiträge
    30. 01. 2008, 15:56

    Hallo!
    Habe eine "alte typo3 3.8" Installation am Laufen, bei der folgende .htaccess
    [TS]RewriteEngine On
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteRule ^typo3$ typo3/index_re.php
    RewriteRule ^[^/]*\.html$ index.php
    [/TS]
    plus dementsprechend gesetzt Variablen im Typoscript und den Aliaseinträgen.

    = Funktioniert problemlos und damit Suchmaschinen freundlich :-)

    Meine Frage:
    Warum schaff ich das gleiche nicht in typo3 4.0.6:
    [TS]RewriteEngine On
    RewriteRule ^(typo3|typo3temp|typo3conf|t3lib|tslib|fileadmin|uploads|showpic\.php)/ - [L]RewriteRule ^typo3$ typo3/index_re.php [L]RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteCond %{REQUEST_FILENAME} !-l
    RewriteRule ^[^/]*\.html$ index.php
    [/TS]
    plus gesetzter Aliaseinträge und "config.simulateStaticDocuments = 1"

    Dort funktioniert der Rewrite zwar, aber es kommt ein:
    "Not Found
    The requested URL /kuenstler.html was not found on this server." sobald man einen Menüpunkt auswählt.

    Wenn man fqdn/index.php/kuenstler.html eingibt wechselt er zur korrekten Seite, allerdings im gängigen "id=xyz style"

    Woran liegt das?


  • 1
  • felis felis
    Sternenflotten-Admiral
    0 x
    249 Beiträge
    0 Hilfreiche Beiträge
    02. 02. 2008, 19:06

    Hat niemand eine Idee! Ich komme einfach nicht dahinter!

  • mic_jan mic_jan
    Jedi-Ratsmitglied
    0 x
    597 Beiträge
    0 Hilfreiche Beiträge
    02. 02. 2008, 19:24

    index_re.php gibt es nicht mehr. Ansonsten würde ich mir einfach die htaccess angucken, die bei den neuen Installationen dabei ist.

    Gruss,

    Michael

  • felis felis
    Sternenflotten-Admiral
    0 x
    249 Beiträge
    0 Hilfreiche Beiträge
    03. 02. 2008, 08:09

    Hallo! Danke für Deine Antwort!
    Ich verwende die htaccess die bei der Installation dabei war - da ist das index_re.php drinen.

    Muß man das gegen was anderes ersetzen? Oder einfach raus damit?

  • brokemeister brokemeis...
    Jedi-Ratsmitglied
    0 x
    762 Beiträge
    0 Hilfreiche Beiträge
    06. 02. 2008, 21:23

    Setze mal nen "/" vor die index.php ;)

  • felis felis
    Sternenflotten-Admiral
    0 x
    249 Beiträge
    0 Hilfreiche Beiträge
    07. 02. 2008, 08:54

    Leider bewirkt es nichts. - Der Pfad scheint zu passen.
    Hab auch das "logging" aufgedreht und für mich scheint der "Apache2-Teil" zu passen - da es keine Fehlermeldungen gibt, zumindest würde ich keine Meldungen als Fehler erkennen:
    [TS]213.185.165.242 - - [07/Feb/2008:08:46:48 +0100] [www.suth.ca/sid#8247cc8][rid#841cb58/initial] (2) init rewrite engine with requested uri /
    213.185.165.242 - - [07/Feb/2008:08:46:48 +0100] [www.suth.ca/sid#8247cc8][rid#841cb58/initial] (1) pass through /
    213.185.165.242 - - [07/Feb/2008:08:46:48 +0100] [www.suth.ca/sid#8247cc8][rid#8416b00/subreq] (2) init rewrite engine with requested uri /index.html
    213.185.165.242 - - [07/Feb/2008:08:46:48 +0100] [www.suth.ca/sid#8247cc8][rid#8416b00/subreq] (1) pass through /index.html
    213.185.165.242 - - [07/Feb/2008:08:46:48 +0100] [www.suth.ca/sid#8247cc8][rid#8416b00/subreq] (2) init rewrite engine with requested uri /index.htm
    213.185.165.242 - - [07/Feb/2008:08:46:48 +0100] [www.suth.ca/sid#8247cc8][rid#8416b00/subreq] (1) pass through /index.htm
    213.185.165.242 - - [07/Feb/2008:08:46:48 +0100] [www.suth.ca/sid#8247cc8][rid#8416b00/subreq] (2) init rewrite engine with requested uri /index.cgi
    213.185.165.242 - - [07/Feb/2008:08:46:48 +0100] [www.suth.ca/sid#8247cc8][rid#8416b00/subreq] (1) pass through /index.cgi
    213.185.165.242 - - [07/Feb/2008:08:46:48 +0100] [www.suth.ca/sid#8247cc8][rid#8416b00/subreq] (2) init rewrite engine with requested uri /index.pl
    213.185.165.242 - - [07/Feb/2008:08:46:48 +0100] [www.suth.ca/sid#8247cc8][rid#8416b00/subreq] (1) pass through /index.pl
    213.185.165.242 - - [07/Feb/2008:08:46:48 +0100] [www.suth.ca/sid#8247cc8][rid#8416b00/subreq] (2) init rewrite engine with requested uri /index.php
    213.185.165.242 - - [07/Feb/2008:08:46:48 +0100] [www.suth.ca/sid#8247cc8][rid#8416b00/subreq] (1) pass through /index.php
    213.185.165.242 - - [07/Feb/2008:08:46:48 +0100] [suth.at/sid#8247cc8][rid#84167e0/initial] (2) init rewrite engine with requested uri /
    213.185.165.242 - - [07/Feb/2008:08:46:48 +0100] [suth.at/sid#8247cc8][rid#84167e0/initial] (1) pass through /
    213.185.165.242 - - [07/Feb/2008:08:46:48 +0100] [suth.at/sid#8247cc8][rid#841a7f0/subreq] (2) init rewrite engine with requested uri /index.html
    213.185.165.242 - - [07/Feb/2008:08:46:48 +0100] [suth.at/sid#8247cc8][rid#841a7f0/subreq] (1) pass through /index.html
    213.185.165.242 - - [07/Feb/2008:08:46:48 +0100] [suth.at/sid#8247cc8][rid#841a7f0/subreq] (2) init rewrite engine with requested uri /index.htm
    213.185.165.242 - - [07/Feb/2008:08:46:48 +0100] [suth.at/sid#8247cc8][rid#841a7f0/subreq] (1) pass through /index.htm
    213.185.165.242 - - [07/Feb/2008:08:46:48 +0100] [suth.at/sid#8247cc8][rid#841a7f0/subreq] (2) init rewrite engine with requested uri /index.cgi
    213.185.165.242 - - [07/Feb/2008:08:46:48 +0100] [suth.at/sid#8247cc8][rid#841a7f0/subreq] (1) pass through /index.cgi
    213.185.165.242 - - [07/Feb/2008:08:46:48 +0100] [suth.at/sid#8247cc8][rid#841a7f0/subreq] (2) init rewrite engine with requested uri /index.pl
    213.185.165.242 - - [07/Feb/2008:08:46:48 +0100] [suth.at/sid#8247cc8][rid#841a7f0/subreq] (1) pass through /index.pl
    213.185.165.242 - - [07/Feb/2008:08:46:48 +0100] [suth.at/sid#8247cc8][rid#841a7f0/subreq] (2) init rewrite engine with requested uri /index.php
    213.185.165.242 - - [07/Feb/2008:08:46:48 +0100] [suth.at/sid#8247cc8][rid#841a7f0/subreq] (1) pass through /index.php
    213.185.165.242 - - [07/Feb/2008:08:46:48 +0100] [suth.at/sid#8247cc8][rid#841c7f8/initial] (2) init rewrite engine with requested uri /
    213.185.165.242 - - [07/Feb/2008:08:46:48 +0100] [suth.at/sid#8247cc8][rid#841c7f8/initial] (1) pass through /
    213.185.165.242 - - [07/Feb/2008:08:46:48 +0100] [suth.at/sid#8247cc8][rid#841a7f0/subreq] (2) init rewrite engine with requested uri /index.html
    213.185.165.242 - - [07/Feb/2008:08:46:48 +0100] [suth.at/sid#8247cc8][rid#841a7f0/subreq] (1) pass through /index.html
    213.185.165.242 - - [07/Feb/2008:08:46:48 +0100] [suth.at/sid#8247cc8][rid#841a7f0/subreq] (2) init rewrite engine with requested uri /index.htm
    213.185.165.242 - - [07/Feb/2008:08:46:48 +0100] [suth.at/sid#8247cc8][rid#841a7f0/subreq] (1) pass through /index.htm
    213.185.165.242 - - [07/Feb/2008:08:46:48 +0100] [suth.at/sid#8247cc8][rid#841a7f0/subreq] (2) init rewrite engine with requested uri /index.cgi
    213.185.165.242 - - [07/Feb/2008:08:46:48 +0100] [suth.at/sid#8247cc8][rid#841a7f0/subreq] (1) pass through /index.cgi
    213.185.165.242 - - [07/Feb/2008:08:46:48 +0100] [suth.at/sid#8247cc8][rid#841a7f0/subreq] (2) init rewrite engine with requested uri /index.pl
    213.185.165.242 - - [07/Feb/2008:08:46:48 +0100] [suth.at/sid#8247cc8][rid#841a7f0/subreq] (1) pass through /index.pl
    213.185.165.242 - - [07/Feb/2008:08:46:48 +0100] [suth.at/sid#8247cc8][rid#841a7f0/subreq] (2) init rewrite engine with requested uri /index.php
    213.185.165.242 - - [07/Feb/2008:08:46:48 +0100] [suth.at/sid#8247cc8][rid#841a7f0/subreq] (1) pass through /index.php
    213.185.165.242 - - [07/Feb/2008:08:46:48 +0100] [suth.at/sid#8247cc8][rid#84167e0/initial] (2) init rewrite engine with requested uri /fileadmin/green_acre
    s/images/header.jpg
    213.185.165.242 - - [07/Feb/2008:08:46:48 +0100] [suth.at/sid#8247cc8][rid#84167e0/initial] (1) pass through /fileadmin/green_acres/images/header.jpg
    213.185.165.242 - - [07/Feb/2008:08:46:50 +0100] [suth.at/sid#8247cc8][rid#84187e8/initial] (2) init rewrite engine with requested uri /produkte.html
    213.185.165.242 - - [07/Feb/2008:08:46:50 +0100] [suth.at/sid#8247cc8][rid#84187e8/initial] (1) pass through /produkte.html
    [/TS]

    Vielleicht hilft das mit den "Fehler" (falsche Konfig) zumindest zuzuordnen Apache2 oder typo3.

    Bitte um eure Mithilfe!

  • felis felis
    Sternenflotten-Admiral
    0 x
    249 Beiträge
    0 Hilfreiche Beiträge
    11. 02. 2008, 20:28

    Hat denn niemand eine Idee!!!!!!!!!! Das ist das einzige was mich von meiner Seite trennt :D

    Muß mann bei typo noch was machen? Hab das im Install - tool von 0 auf 1 gesetzt (config.sim......) und im Template steht:

    config.simulateStaticDocuments_noTypeIfNoTitle = 1

    fehlt da noch was! Irgendwo muß doch der Fehler liegen #angry#

    Nachdem ich nach wie vor denke das Apache das Richtige tut - keine für mich ersichtliche Fehlermeldung im rewrite.log.

    Stimmen wie weiter oben angedeutet die "typo3 rootPfade" nicht?

    Die wären (frei gewählt: fqdn.net):
    [TS]...
    DocumentRoot /data/www/stt.fqdn.net/htdocs
    ...
    <Directory /data/www/stt.fqdn.net/htdocs>
    AllowOverride None
    Order allow,deny
    Allow from all
    <Directory>
    [/TS]
    und dann nochmal, in der Zwischenzeit mit RealURL(!, laut [HowTo]RealURL aus diesem Forum) die .htaccess:
    [TS]#
    RewriteEngine On
    #
    Options +FollowSymLinks
    #

    #
    RewriteBase /
    #
    #
    RewriteRule ^typo3$ - [L]#
    RewriteRule ^typo3/.*$ - [L]#
    #
    RewriteRule ^(typo3|banner|typo3temp|typo3conf|t3lib|tslib|fileadmin|uploads|showpic\.php)/ - [L]#
    #
    RewriteCond %{REQUEST_FILENAME} !-f
    #
    RewriteCond %{REQUEST_FILENAME} !-d
    #
    RewriteCond %{REQUEST_FILENAME} !-l
    #
    #
    RewriteRule (\.html|/)$ index.php
    [/TS]

    Für mich stellt der Pfad (s.o. DocumentRoot) den root-Pfad dar, hier liegt die .htaccess drin & von hier gehen die SymLinks zu typo3, etc.

  • Dirk1 Dirk1
    R2-D2
    0 x
    126 Beiträge
    0 Hilfreiche Beiträge
    16. 04. 2008, 02:20

    Hallo,

    ist dein Problem noch akut?
    Ich vermute, das Problem liegt bei der rewrite-Option in Apache.

    RealUrl verkompliziert das Problem eher.

    Versuche es doch mal mit einem simplen 2-Zeiler in der .htaccess (Das die vom server verarbeitet, hast du sicherlich gecheckt)

    Gruß
    Dirk

  • 1