Seiteninhalt "Bild" ohne Tabelle [Gelöst]

  • Frisbee Frisbee
    Padawan
    0 x
    32 Beiträge
    0 Hilfreiche Beiträge
    27. 01. 2008, 14:58

    Hallo!

    In der Designvorlage habe ich diesen Marker:
    [HTML]<div id="picture-layer">
    ###HEADPICTURE###
    </div>[/HTML]

    Diesen fülle ich mit:
    [TS]HEADPICTURE = CONTENT
    HEADPICTURE {
    table = tt_content
    select.orderBy = sorting
    select.where = colPos = 1
    } # end HEADPICTURE[/TS]

    Ich lege einen Seiteninhalt an, der nur ein Bild enthält. Somit erhalte ich in der Ausgabe:
    [HTML]<div id="picture-layer">
    <a id="c2"></a>
    <!-- Versteckter Header:-->
    <img src="clear.gif" width="1" height="6" border="0" class="spacer-gif" alt="" title="" />
    <br />
    <div style="text-align:center;">
    <table width="759" border="0" cellspacing="0" cellpadding="0" style="margin-left: auto; margin-right: auto" class="imgtext-table">
    <tr>
    <td colspan="1">
    <img src="clear.gif" width="759" height="1" alt="" />
    </td>
    </tr>
    <tr>
    <td valign="top">
    <img src="uploads/pics/firma_top1.jpg" width="759" height="157" border="0" align="top" alt="" title="" />
    <br />
    </td>
    </tr>
    </table>
    </div>
    </div>
    [/HTML]
    So wird das Bild aber dauernd nach unten verschoben. Was ich also gerne ausgegeben hätte, ist nur:
    [HTML]<div id="picture-layer">
    <img src="uploads/pics/firma_top1.jpg" width="759" height="157" border="0" align="top" alt="" title="" />
    </div>[/HTML]

    Ich habe infolgedessen gegoogelt und bei den Constants im Template diese Zeilen eingefügt, um die Zeilenumbrüche und die clear.gif's zu entfernen:
    [TS]content.headerSpace = 0|0
    content.space = 0|0
    content.wrap.header = |
    [/TS]
    Ohne Erfolg. Kann mir jemand einen Tipp geben, wie ich zur gewünschten Ausgabe komme?

    Gruss
    René


  • 1
  • just2b just2b
    TYPO3-Yoda
    0 x
    18741 Beiträge
    2 Hilfreiche Beiträge
    28. 01. 2008, 07:56

    nimm css_styled_content statt content(default)

    georg

  • Evchen Evchen
    Padawan
    0 x
    62 Beiträge
    0 Hilfreiche Beiträge
    28. 01. 2009, 08:27

    Hab das gleiche Problem... Habe zwar keinen Marker in meinem Template aber ich würde auch gerne das clear.gif vor den Bildern entfernen.. content(default) hab ich schon deaktiviert, aber leider hat das nichts gebracht :-(

  • 1