Content-Slide mit Content-Elementen (kb_tv_cont_slide) / Manuelle Änderungen in XML-Datenstruktur werden bei Mapping überschrieben

  • jessij jessij
    T3PO
    0 x
    23 Beiträge
    0 Hilfreiche Beiträge
    04. 11. 2007, 17:34

    Hallo,

    vielleicht ist es ja ein ganz einfaches Problemchen, wobei ich selbst noch nicht auf die richtige Idee gekommen bin?

    Ich habe einen Content-Slide mit Content-Elementen (kb_tv_cont_slide) wie folgt in meiner XML Datenstruktur eingerichtet:

    [TS]<typoscript><![CDATA[
    10= RECORDS
    10.source.postUserFunc = tx_kbtvcontslide_pi1->main
    10.source.postUserFunc.field = field_meinslideinhalt
    10.tables = tt_content
    10.wrap = <!--TYPO3SEARCH_begin--> | <!--TYPO3SEARCH_end-->
    ]]></typoscript>
    [/TS]

    Klappt auch alles wunderbar und auch wie gewünscht, ABER: wenn ich nun am Ursprungstemplate (an der HTML-Datei) was ändere und ein neues Mapping durchführe, dann sind die gemachten manuellen Änderungen in der XML-Datenstruktur wieder weg. Sie werden einfach wieder mit den Default-Werten überschrieben.

    Hat das jemand auch? Wie kann man die einmal gemachten Änderungen in der XML-Datenstruktur "konservieren", damit sie beim Aktualisieren des Mappings nicht verlorengehen?

    Danke für jede Idee!

    Jessi


  • 1
  • claudia2 claudia2
    Jedi-Meister
    0 x
    296 Beiträge
    0 Hilfreiche Beiträge
    06. 11. 2007, 22:12

    Hallo Jessi,

    ähnliches Problem hatte ich auch neulich...

    Wie kann man die einmal gemachten Änderungen in der XML-Datenstruktur "konservieren", damit sie beim Aktualisieren des Mappings nicht verlorengehen?

    indem du deine Änderungen direkt im TO unter "Lokale Verarbeitung (XML)" hineinkopierst, hier findest du eine Beschreibung:
    [url]http://wiki.typo3.org/index.php/TemplaVoila/FCE#Overriding_values_from_Template_Objects[/url]

    lg claudia

  • 1