Kann Extension-Liste nicht runterladen...

  • Sturmi Sturmi
    Sternenflotten-Admiral
    0 x
    215 Beiträge
    0 Hilfreiche Beiträge
    11. 09. 2007, 10:18

    Hallo zusammen,

    Ich habe gerade meinen eigenen Server aufgesetzt und Typo3 aufgespielt. Immer wenn ich auf den Button "Retrieve/Update" klicke kommt folgende Meldung: [b]Error in XML parser while decoding extensions XML file. Line 12103: not well-formed (invalid token)[/b]

    Muss ich zusätzlich noch etwas auf den Server installieren, damit das funktioniert?

    Bin für jede Hilfe sehr dankbar...


  • 1
  • einpraegsam.net einpraegs...
    MacGyver
    0 x
    9340 Beiträge
    80 Hilfreiche Beiträge
    11. 09. 2007, 11:30

    Vorschoben: Hat nichts mit Anfängerfragen und noch weniger mit Typoscript zu tun!

    in2code.de - Wir leben TYPO3
    - Möchtest du TYPO3 komplett verstehen? Eigene Erweiterungen erstellen? Bei uns gibt es auch Schulungen https://www.in2code.de/produkte/typo3-schulungen/
    - Die Arbeit mit TYPO3 macht dir Spaß? Du stehst auf Berge? Komm zu uns! https://www.in2code.de/agentur/karriere/

  • mmecker mmecker
    Padawan
    0 x
    49 Beiträge
    0 Hilfreiche Beiträge
    11. 09. 2007, 12:36

    Ein häufiges Problem an dieser Stelle ist der extreme Speicherbedarf der Extension-List beim Download - irgendwie passt aber die Fehlermeldung nicht so recht dazu.

    Aber vielleicht trotzdem mal die Resource Limits in der php.ini überprüfen, insbesondere memory_limit (ich setze das mittlerweile immer schon auf 24M).

  • Sturmi Sturmi
    Sternenflotten-Admiral
    0 x
    215 Beiträge
    0 Hilfreiche Beiträge
    11. 09. 2007, 13:35

    Hmmm???? Danke für die Antwort(en), aber mein memory_limit liegt bei 64M ...
    Muss ich vielleicht noch irgendeinen XML-Parser installieren?

    Selbst wenn ich auf typo3.org eine Ext. runterlade und sie im Ext. Manager normal hochladen möchte, erscheint die Meldung: [b]file is empty![/b]

    Woran kann das nur liegen?

    Danke.

  • mmecker mmecker
    Padawan
    0 x
    49 Beiträge
    0 Hilfreiche Beiträge
    17. 09. 2007, 23:12

    Die erste Meldung wird in Zeile 350ff. der typo3/mod/tools/em/class.em_xmlhandler.php erzeugt. Diese nutzt die PHP-XML-Parserfunktionen, zu denen php.net sagt:

    These functions are enabled by default, using the bundled expat library. You can disable XML support with --disable-xml. If you compile PHP as a module for Apache 1.3.9 or later, PHP will automatically use the bundled expat™ library from Apache. In order you don't want to use the bundled expat library configure PHP --with-expat-dir=DIR, where DIR should point to the base installation directory of expat.

    Die Fehlermeldung wird auch genau unter Verwendung dieser PHP-Funktionen erzeugt. Das ist also (vermutlich) nicht das Problem.
    Die zweite Meldung "File is empty" kommt wohl aus der function importExtFromRep (Zeile 1695 der typo3/mod/tools/em/class.em_index.php).

    Hmmm...
    Wenn es für beide Fehler eine gemeinsame Ursache geben sollte (was ich nicht so recht glaube), kann es nur entweder an einer zerschossenen Extension-Manager-Bibliothek liegen oder aber daran, dass tatsächlich beim Laden der Dateien ein Problem entsteht (außerhalb von Typo3).

  • 1