Simulate static - URL Anhang loswerden [Gelöst]

  • nobbi nobbi
    Padawan
    0 x
    58 Beiträge
    0 Hilfreiche Beiträge
    22. 08. 2007, 10:02

    Hallo,
    ich benutze Simulate static auf dieser Page:

    [url]http://www.ford-kroeschel.de/Werkstatt.3.0.html[/url]

    Wie man bei der obigen URL sehen kann, hängt da noch '.3.0' dran - was praktisch die Page ID ist.

    Wie kann man diesen Anhang "loswerden"?

    Gewünscht wäre also 'www.ford-kroeschel.de/Werkstatt.html'

    Hier die Einstellungen:

    [TS]#Simulate static
    config.simulateStaticDocuments = 1
    config.simulateStaticDocuments_addTitle = 100
    config.simulateStaticDocuments_pEnc = md5[/TS]

    Hier die [b].htaccess:[/b]

    RewriteEngine On
    RewriteRule ^[^/]*.html$ /index.php


  • 1
  • einpraegsam.net einpraegs...
    MacGyver
    0 x
    9340 Beiträge
    80 Hilfreiche Beiträge
    23. 08. 2007, 06:52

    [TS]config.simulateStaticDocuments_noTypeIfNoTitle = 1[/TS]
    Deaktiviert nach Möglichkeit den Type

    Aber um die Zahl gänzlich zu entfernen solltest du schon RealURL nehmen

    in2code.de - Wir leben TYPO3
    - Möchtest du TYPO3 komplett verstehen? Eigene Erweiterungen erstellen? Bei uns gibt es auch Schulungen https://www.in2code.de/produkte/typo3-schulungen/
    - Die Arbeit mit TYPO3 macht dir Spaß? Du stehst auf Berge? Komm zu uns! https://www.in2code.de/agentur/karriere/

  • Graf Typo Graf Typo
    Padawan
    0 x
    44 Beiträge
    0 Hilfreiche Beiträge
    23. 08. 2007, 16:00

    Eine andere Möglichkeit ist es, jeder Seite in den Seiteneigenschaften einen Alias zu geben. Der erscheint dann in der URL:

    http://www.domain.de/alias.html

    Beste Grüße,
    der Graf

  • 0 x
    15 Beiträge
    0 Hilfreiche Beiträge
    23. 08. 2007, 16:31

    Hallo,

    habe gerade simulateStatic deinstalliert und alias eingegeben

    Bei mir geht das nicht es kommt
    /typo/index.php?id=konzepte

    habe ich was falsch gemacht? oder muss sonst noch was eingestellt werden?

    Grüße

  • staeubel staeubel
    Sternenflotten-Admiral
    0 x
    166 Beiträge
    0 Hilfreiche Beiträge
    23. 08. 2007, 17:21

    Hallo

    Ich habe es auch so wie wunschtacho schon schrieb gemacht:

    [quote="wunschtacho"]
    [TS]config.simulateStaticDocuments_noTypeIfNoTitle = 1[/TS]
    Deaktiviert nach Möglichkeit den Type
    [/quote]

    Diese Option entfernt die Zahlen und du hast nur noch den Namen
    (im Alias definiert) als html.

    z.B. wenn Alias = werkstatt ist, dann heisst die Seite:
    http://www.ford-kroeschel.de/werkstatt.html

    Das funktioniert bei mir ohne Zusätze wie RealUrl etc.

    Viele Grüsse Stäubel

  • 0 x
    15 Beiträge
    0 Hilfreiche Beiträge
    23. 08. 2007, 17:41

    Danke, das war es, habe nun folgendes im Setup stehen und es funktioniert.

    Nun kommt der alias Name als alias.html

    Genau so wollte ich es " Vielen Dank an Alle "

    [TS]simulateStaticDocuments = 1
    simulateStaticDocuments_noTypeIfNoTitle = 1
    [/TS]

  • NWS NWS
    Typ im Roten Hemd
    0 x
    3 Beiträge
    0 Hilfreiche Beiträge
    24. 08. 2007, 05:39

    Hi Leute,
    echt super - bei mir läufts jetzt auch!

    Nur als Referenz, für andere die sich damit später rumplagen werden:
    Bei mir liefs mit:

    1. .htaccess

    RewriteEngine On
    RewriteRule ^[^/]*.html$ /index.php

    2.
    [TS]config.simulateStaticDocuments = 1
    config.simulateStaticDocuments_noTypeIfNoTitle = 1 [/TS]

    3. (...und jetzt sich in Ruhe in realUrl einarbeiten ;)

  • 1