mm_forum: Benutzerprofil erweitern

  • xantos xantos
    Padawan
    0 x
    38 Beiträge
    0 Hilfreiche Beiträge
    04. 07. 2007, 08:33

    Hallo,

    ich habe ein Problem.
    Wenn ich ein neues Feld bei "Benutzerprofil erweitern" erstelle und dieses durch "Feldkonfiguration direkt bearbeiten" konfiguriere funktioniert dieses bei "Profildaten bearbeiten" und direkt beim Profil.

    Jetzt will ich dieses Feld bei der Mietgliederliste ausgeben, bekomme aber nur hier folgenden Fehler:

    1. Fatal error: Call to a member function on a non-object in /var/home/fanta-bande_at/www/wow/typo3conf/ext/mm_forum/pi1/class.tx_mmforum_pi1.php on line 1517

    Hier ist die Feldkonfiguration:

    [TS]label = TEXT
    label {
    value = Test:
    }

    input = COA
    input.wrap = <select name="###USERFIELD_NAME###">|</select>
    input.1 = TEXT
    input.1.value = <option value="0">Bitte auswählen</option>
    input.2 = CASE
    input.2 {
    default = TEXT
    default.value = <option value="1">Test 1</option>
    1 = TEXT
    1.value = <option value="1" selected="">Test 1</option>
    key.field = fieldvalue
    }
    input.3 = CASE
    input.3 {
    default = TEXT
    default.value = <option value="2">Test 2</option>
    2 = TEXT
    2.value = <option value="2" selected="">Test 2</option>
    key.field = fieldvalue
    }

    output = CASE
    output {
    key.field = fieldvalue
    default = TEXT
    default.value =
    1 = TEXT
    1.value = Test 1
    2 = TEXT
    2.value = Test 2
    }[/TS]

    Hoffentlich kann mir wer helfen.

    Danke Valentin


  • 1
  • xantos xantos
    Padawan
    0 x
    38 Beiträge
    0 Hilfreiche Beiträge
    10. 07. 2007, 09:01

    hm, kennt niemand eine Lösung ??

    // edit:
    fast vergessen, der code block der bei zeile 1517 ist:

    1. if(strlen($arr['config'])>0) {
    2. $parser->parse($arr['config']);
    3. $config = $parser->setup;
    4. } else $config = array();

  • 1