mm_forum und RealUrl [Gelöst]

  • Junior Junior
    Jedi-Ratsmitglied
    0 x
    545 Beiträge
    0 Hilfreiche Beiträge
    19. 06. 2007, 17:03

    [b]Achtung [url=http://www.typo3.net/forum/list/list_post//61451/?page=4]Doppelpost[/url]: das verlinkte Thema steht auf gelöst, was nicht geändert wird und ich habe das Gefühl, dass dort nicht mehr reingeschaut wird. Daher hier nochmals:[/b]

    Crosspost: http://www.typo3forum.net/forum/forum-extension/21443-mm_forum-und-realurl.html

    Hi,

    ich schaffe es nicht in meinem mm_forum RelUrl zu aktivieren.

    Folgenden localconf.php Eintrag habe ich:

    1. <?php
    2. $TYPO3_CONF_VARS['EXTCONF'] ['realurl'] ['_DEFAULT'] = array(
    3.  
    4.  
    5.  
    6. 'init' => array(
    7. 'enableCHashCache' => 1,
    8. 'enableUrlDecodeCache' => 1,
    9. 'enableUrlEncodeHash' => 1,
    10. 'respectSimulateStaticURLs'=>1,
    11. 'postVarSet_failureMode' => 'redirect_goodUpperDir',
    12.  
    13. ),
    14. 'rewrite' => array(
    15. ),
    16. 'preVars' => array(
    17.  
    18. 'GETvar' => 'L',
    19. 'valueMap' => array(
    20. 'de' => '0',
    21. 'en' => '1',
    22. ),
    23. 'noMatch' => 'bypass',
    24. //'valueDefault' => 'de',
    25. ),
    26. 'GETvar' => 'no_cache',
    27. 'valueMap' => array(
    28. 'no_cache' => 1,
    29. ),
    30. 'noMatch' => 'bypass',
    31. ),
    32. ),
    33.  
    34. 'pagePath' => array(
    35. 'type' => 'user',
    36. 'userFunc' => 'EXT:realurl/class.tx_realurl_advanced.php:&tx_realurl_advanced->main',
    37. 'spaceCharacter' => '-',
    38. 'languageGetVar' => 'L',
    39. 'expireDays' => 3,
    40. 'rootpage_id' => 2,
    41. ),
    42.  
    43. 'fileName' => array (
    44. 'defaultToHTMLsuffixOnPrev' => 0,
    45. 'index' => array(
    46. 'page.html' => array(
    47. 'keyValues' => array (
    48. 'type' => 1,
    49. ),
    50. ),
    51. ),
    52. ),
    53.  
    54. 'fixedPostVarSets' => array(),
    55. 'fixedPostVars' => array(
    56. 'mm_forum_pi3' => array(
    57. 'GETvar' => 'tx_mmforum_pi3[folder]',
    58. 'valueMap' => array(
    59. 'posteingang' => 'inbox',
    60. 'postausgang' => 'send',
    61. 'archiv' => 'archiv'
    62. )
    63. ),
    64. 'GETvar' => 'tx_mmforum_pi3[action]',
    65. 'valueMap' => array(
    66. 'lesen' => 'message_read',
    67. 'schreiben' => 'message_write',
    68. 'loeschen' => 'message_del'
    69. )
    70. ),
    71. 'GETvar' => 'tx_mmforum_pi3[messid]',
    72. 'lookUpTable' => array(
    73. 'table' => 'tx_mmforum_pminbox' ,
    74. 'id_field' => 'uid',
    75. 'alias_field' => 'subject',
    76. 'addWhereClause' => ' AND NOT deleted',
    77. 'useUniqueCache' => 1,
    78. 'useUniqueCache_conf' => array(
    79. 'strtolower' => 1,
    80. 'spaceCharacter' => '_',
    81. ),
    82. ),
    83. ),
    84. 'GETvar' => 'tx_mmforum_pi3[userid]',
    85. 'lookUpTable' => array(
    86. 'table' => 'fe_users' ,
    87. 'id_field' => 'uid',
    88. 'alias_field' => 'username',
    89. 'addWhereClause' => ' AND NOT deleted',
    90. 'useUniqueCache' => 1,
    91. 'useUniqueCache_conf' => array(
    92. 'strtolower' => 1,
    93. 'spaceCharacter' => '_',
    94. ),
    95. ),
    96. )
    97. ),
    98. 'mm_forum_pi1' => array(
    99. 'GETvar' => 'tx_mmforum_pi1[action]',
    100. 'valueMap' => array(
    101. 'themen' => 'list_topic',
    102. 'beitraege' => 'list_post',
    103. 'benutzer' => 'forum_view_profil',
    104. 'antworten' => 'new_post',
    105. 'eroeffnen' => 'new_topic',
    106. 'melden' => 'post_alert',
    107. 'bearbeiten' => 'post_edit',
    108. 'loeschen' => 'post_del',
    109. 'alle_beitraege' => 'post_history',
    110. 'unbeantwortet' => 'list_unans',
    111. 'ungelesen' => 'list_unread',
    112. 'alles_gelesen' => 'reset_read',
    113. 'abonnieren' => 'set_havealook',
    114. 'abo_loeschen' => 'del_havealook',
    115. 'favorit' => 'set_favorite',
    116. 'kein_favorit' => 'del_favorite',
    117. 'praefix' => 'list_prefix'
    118. ),
    119. ),
    120. 'GETvar' => 'tx_mmforum_pi1[fid]',
    121. 'lookUpTable' => array(
    122. 'table' => 'tx_mmforum_forums' ,
    123. 'id_field' => 'uid',
    124. 'alias_field' => 'forum_name',
    125. 'addWhereClause' => ' AND NOT deleted',
    126. 'useUniqueCache' => 1,
    127. 'useUniqueCache_conf' => array(
    128. 'strtolower' => 1,
    129. 'spaceCharacter' => '_',
    130. ),
    131. ),
    132. ),
    133. 'GETvar' => 'tx_mmforum_pi1[tid]',
    134. 'lookUpTable' => array(
    135. 'table' => 'tx_mmforum_topics' ,
    136. 'id_field' => 'uid',
    137. 'alias_field' => 'topic_title',
    138. 'addWhereClause' => ' AND NOT deleted',
    139. 'useUniqueCache' => 1,
    140. 'useUniqueCache_conf' => array(
    141. 'strtolower' => 1,
    142. 'spaceCharacter' => '_',
    143. ),
    144. ),
    145. ),
    146. 'GETvar' => 'tx_mmforum_pi1[pid]',
    147. ),
    148. 'GETvar' => 'tx_mmforum_pi1[page]',
    149. ),
    150. 'GETvar' => 'tx_mmforum_pi1[user_id]',
    151. 'lookUpTable' => array(
    152. 'table' => 'fe_users' ,
    153. 'id_field' => 'uid',
    154. 'alias_field' => 'username',
    155. 'addWhereClause' => ' AND NOT deleted',
    156. 'useUniqueCache' => 1,
    157. 'useUniqueCache_conf' => array(
    158. 'strtolower' => 1,
    159. 'spaceCharacter' => '_',
    160. ),
    161. ),
    162. ),
    163.  
    164. ),
    165. '122' => 'mm_forum_pi1',
    166. '125' => 'mm_forum_pi3'
    167. ),
    168.  
    169. 'fixedPostVarSets' => array(
    170. ),
    171.  
    172. 'postVarSets' => array(
    173. '_DEFAULT' => array(
    174. //archive
    175. 'period' => array (
    176. 'condPrevValue' => -1,
    177. 'GETvar' => 'tx_ttnews[pS]',
    178. //'valueMap => array()
    179. ),
    180. 'GETvar' => 'tx_ttnews[pL]',
    181. //'valueMap => array()
    182. ),
    183.  
    184. 'GETvar' => 'tx_ttnews[arc]',
    185. 'valueMap' => array(
    186. 'non-archived' => -1,
    187. ),
    188. ),
    189. ),
    190.  
    191. 'browse' => array (
    192. 'GETvar' => 'tx_ttnews[pointer]',
    193. ),
    194. ),
    195. 'select' => array (
    196. 'GETvar' => 'tx_ttnews[cat]',
    197. 'lookUpTable' => array (
    198. 'table' => 'tt_news_cat',
    199. 'id_field' => 'uid',
    200. 'alias_field' => 'title',
    201. 'addWhereClause'=> 'AND NOT deleted',
    202. 'useUniqueCache'=> 1,
    203. 'useUniqueCache_conf' => array (
    204. 'strtolower' => 1,
    205. 'spaceCharacter' => '-',
    206. ),
    207. ),
    208. ),
    209. ),
    210. 'article' => array(
    211. 'GETvar' => 'tx_ttnews[backPid]',
    212. // 'valueMap => array(
    213. // ),
    214. ),
    215. 'GETvar' => 'tx_ttnews[tt_news]',
    216. 'lookUpTable' => array (
    217. 'table' => 'tt_news',
    218. 'id_field' => 'uid',
    219. 'alias_field' => 'title',
    220. 'maxLength' => 12,
    221. 'addWhereClause'=> 'AND NOT deleted',
    222. 'useUniqueCache'=> 1,
    223. 'useUniqueCache_conf' => array (
    224. 'strtolower' => 1,
    225. 'spaceCharacter' => '-',
    226. ),
    227. ),
    228. ),
    229. ),
    230.  
    231. ),
    232. ),
    233.  
    234. );
    235. ?>

    1. <?php
    2. '122' => 'mm_forum_pi1',
    3. '125' => 'mm_forum_pi3'
    4. ?>

    122 entspricht der ID der Seite auf der das Forum eingefügt ist; 125 der auf der die PNs eingetragen sind.

    Ich habe weiterhin unter "Allgemeine Einstellungen" das Häkchen bei "RealURL-Unterstützung aktivieren" gesetzt und alle Caches gelöscht.

    Das Forum wird weiterhin ohne RealUrl Config angezeigt. Die Doku unter http://typo3.org/documentation/document-library/extension-manuals/mm_forum/0.1.1/view/1/6/#id3569537 habe ich mehr als einmal gelesen.

    Was mache ich falsch?

    Danke und lieben Gruss


  • 1
  • 1