mm_forum Alpha 0.0.5 released

  • b.detert b.detert
    Jedi-Ritter
    0 x
    132 Beiträge
    0 Hilfreiche Beiträge
    07. 05. 2007, 16:59

    Hallo zusammen,
    heute haben wir die [B]Alpha 0.0.5[/B] Version fertigstellen können.
    Wie gewohnt kann die Erweiterung über die [url="http://www.typo3.net/downloads/"]Download-Seite[/URL] oder über die [url="http://www.typo3.net/mm_forum/"]Projekt-Seite[/URL] herunter geladen werden.

    Zusätzlich wurde nun die Möglichkeit eingebaut im WebSVN den derzeitigen Entwicklungsstand als Tar.gz zu beziehen. ;)

    [B][U]Änderungen & Neuerungen der Alpha 0.0.5 Version:[/U][/B]

    • [B]Theme-Support[/B]
      Es ist nun möglich komfortabel über das Backend Modul eigene Themes anzulegen. Hierbei wird eine Kopie der "default" Theme unter gewünschtem Namen abgelegt. Die "default" Theme wird weiterhin wie gewohnt bei einem Update überschrieben, eigene Themes bleiben dadurch unangetastet. Die Textarea zur Bearbeitung der Templates beherrscht nun auch die "Tab" Eingabe.
    • [B]Synthax-Highlighting[/B]
      Das Hervorheben von Code Fragmenten kann nun besser gesteuert werden. Im Backend Modul ist es nun möglich genau anzugeben welche Programmiersprachen unterstützt werden sollen.
    • [B]Konfigurierbare Eingabe-Maske "FrontEnd=> Neue Posts/Themen"[/B]
      Die Bearbeitungsleiste und auch die Smilie-Auswahl der Eingabe-Maske können nun im Backend genau angegeben werden. Es kann nun eingestellt werden welche Icons für BB-Code, Smilies und auch Synthax Highlighting dargestellt werden sollen. Ebenfalls ist es möglich bestimmte Smilies, BB-Codes, oder auch das hervorheben von bestimmten Code zu aktivieren ohne dafür Buttons darstellen zu lassen.
    • [B]CHC-Import[/B]
      Es besteht nun die Möglichkeit einen Import aus dem CHC Forum in das MM-Forum vor zu nehmen. Die Firma Nepa Design entwicklte hierfür den Source Code und stellte diesen freundlicherweise zur Verfügung. Vielen Dank dafür!
    • [B]Import Features[/B]
      Es ist nun ebenfalls möglich von einer externen MySQL Datenbank zu importieren (Externe Zugriffsberechtigung vorrausgesetzt).
    • [B]Verbesserung der RealUrl Kompatibilität[/B]
      Es wurden Verbesserungen an der RealUrl Kompatibilität vorgenommen. Dies ermöglicht eine suchmaschinen-freundlichere Darstellung des Forums. Um die Einrichtung von RealUrl zu erleichtern wurde die Dokumentation um das Kapitel "mm_forum & RealUrl" erweitert.
    • [B]Diverse Bugfixes[/B]
      Es wurden diverse Fehler/Unschönheiten behoben. Genaueres kann aus dem BugTracker und dem WebSVN entnommen werden.


  • Sailor Sailor
    Jedi-Meister
    0 x
    318 Beiträge
    0 Hilfreiche Beiträge
    07. 05. 2007, 18:16

    Hallo Björn,

    hatte gerade die neue Version getestet, aber gleich ein merkwürdiges Verhalten festgestellt.

    Sämtliche Formatierungen werden nicht mehr dargestellt. Das heißt, es gibt keine farblich abgesetzten Container mehr. Alles ist dann nur noch wie in einer Tabelle aber ohne Rahmen. Hoffe ich konnte dies Problem halbwegs verständlich schildern.

    Hab erstmal wieder auf die 4 Version zurück gesetzt.

    Gruß
    Kim

  • Junior Junior
    Jedi-Ratsmitglied
    0 x
    545 Beiträge
    0 Hilfreiche Beiträge
    07. 05. 2007, 19:09

    Hast du unter Templates die mm Templates eingebunden?

    Bei mir funktioniert das Update einwandfrei.

    Lieben Gruss

  • m.helmich m.helmich
    Jedi-Meister
    0 x
    416 Beiträge
    0 Hilfreiche Beiträge
    07. 05. 2007, 19:11

    Hallo,

    in der TypoScript-Architektur wurde einiges umgestellt, unter Umständen einfach mal den Cache löschen.

    MfG,
    Martin Helmich

  • Sailor Sailor
    Jedi-Meister
    0 x
    318 Beiträge
    0 Hilfreiche Beiträge
    07. 05. 2007, 19:12

    Steh gerade auf dem Schlauch.....
    Hatte im Designvorlage zwar was ausgewählt, aber keinen Erfolg damit gehabt oder
    was meinst du damit genau????

    Gruß
    Kim

  • Sailor Sailor
    Jedi-Meister
    0 x
    318 Beiträge
    0 Hilfreiche Beiträge
    07. 05. 2007, 19:13

    @Martin

    ich hatte den Cache Front und Back gelöscht aber kein anderes Ergebnis bekommen.

    Woran kann es liegen....warscheinlich sitzt der Fehler (ich) vor dem PC.

    Gruß
    Kim

  • Junior Junior
    Jedi-Ratsmitglied
    0 x
    545 Beiträge
    0 Hilfreiche Beiträge
    07. 05. 2007, 19:15

    [quote="Sailor"]Das heißt, es gibt keine farblich abgesetzten Container mehr. Alles ist dann nur noch wie in einer Tabelle aber ohne Rahmen. Hoffe ich konnte dies Problem halbwegs verständlich schildern.[/quote]
    Die Lösung deines Problems sind die Templates (BE mm_forum). Wähle dort das "default" Template, dann wird dir im FE alles "normal" angezeigt.

    Theme1-3 ist wohl z.Z. noch ohne Bedeutung, bzw. ohne CSS 8-)

    Lieben Gruss

  • Sailor Sailor
    Jedi-Meister
    0 x
    318 Beiträge
    0 Hilfreiche Beiträge
    07. 05. 2007, 19:24

    Das sind Freudenstränen :D
    Es hat geklappt!!

    Nur etwas ist noch merkwürdig, schau dir mal das an:
    [url]http://www.world-of-sailing24.com/27.html?&tx_mmforum_pi1[action]=list_post&tx_mmforum_pi1[tid]=71[/url]

    Da stimmt die Darstellung nicht...warum ?? Es fehlt doch eigentlich ein Umbruch, denn Profil und www müßten etwas tiefer angeordnet sein oder??

    Gruß
    Kim

  • Junior Junior
    Jedi-Ratsmitglied
    0 x
    545 Beiträge
    0 Hilfreiche Beiträge
    07. 05. 2007, 19:30

    Mhm... also bei mir (auf deiner Seite) steht "Profil" und "www" an der Stelle, an der ich es vermute...

    Schön, dass es wieder klappt :D

    Lieben Gruss

  • Sailor Sailor
    Jedi-Meister
    0 x
    318 Beiträge
    0 Hilfreiche Beiträge
    07. 05. 2007, 19:35

    Mit Firefox neuste Version klappt es .... gerade getestet

    aber mit MS IE Version 6 wird es nicht richtig angezeigt.

    Gruß
    Kim