mm_forum - SQL Probleme

  • bfeser bfeser
    Padawan
    0 x
    38 Beiträge
    0 Hilfreiche Beiträge
    30. 04. 2007, 08:58

    Hallo zusammen,

    Bei der Überprüfung im Install-Tool erhalte ich folgende Ausgabe:

    1. Changing fields ALTER TABLE tx_mmforum_favorites DROP PRIMARY KEY;
    2. ALTER TABLE tx_mmforum_favorites ADD PRIMARY KEY (uid);
    3. ALTER TABLE tx_mmforum_forums DROP PRIMARY KEY;
    4. ALTER TABLE tx_mmforum_forums ADD PRIMARY KEY (uid);
    5. ALTER TABLE tx_mmforum_mailkey DROP PRIMARY KEY;
    6. ALTER TABLE tx_mmforum_mailkey ADD PRIMARY KEY (uid);
    7. ALTER TABLE tx_mmforum_post_alert DROP PRIMARY KEY;
    8. ALTER TABLE tx_mmforum_post_alert ADD PRIMARY KEY (uid);
    9. ...
    10. ...(usw)

    Diese SQL-Anweisungen lassen sich aber nicht ausführen. PHPMyAdmin meldet nämlich:
    Incorrect table definition; there can be only one auto column and it must be defined as a key

    [b]Haben auch andere dieses Problem und was hab ich zu tun?[/b]

    [b]Ist das der Grund, warum ich bei der DB-Überprüfung Dutzende Meldungen bekomme?[/b] Warning: mysql_fetch_assoc(): supplied argument is not a valid MySQL result resource in /var/www/virtual/globaleOrdner/typo3-Pakete/typo3_src-4.1RC1/t3lib/class.t3lib_db.php on line 796

    Warning: mysql_free_result(): supplied argument is not a valid MySQL result resource in /var/www/virtual/globaleOrdner/typo3-Pakete/typo3_src-4.1RC1/t3lib/class.t3lib_db.php on line 823

    Warning: mysql_fetch_assoc(): supplied argument is not a valid MySQL result resource in /var/www/virtual/globaleOrdner/typo3-Pakete/typo3_src-4.1RC1/t3lib/class.t3lib_db.php on line 796

    Warning: mysql_free_result(): supplied argument is not a valid MySQL result resource in /var/www/virtual/globaleOrdner/typo3-Pakete/typo3_src-4.1RC1/t3lib/class.t3lib_db.php on line 823

    Warning: mysql_fetch_assoc(): supplied argument is not a valid MySQL result resource in /var/www/virtual/globaleOrdner/typo3-Pakete/typo3_src-4.1RC1/t3lib/class.t3lib_db.php on line 796

    Warning: mysql_free_result(): supplied argument is not a valid MySQL result resource in /var/www/virtual/globaleOrdner/typo3-Pakete/typo3_src-4.1RC1/t3lib/class.t3lib_db.php on line 823

    Warning: mysql_fetch_assoc(): supplied argument is not a valid MySQL result resource in /var/www/virtual/globaleOrdner/typo3-Pakete/typo3_src-4.1RC1/t3lib/class.t3lib_db.php on line 796

    ... (usw)[/quote]

    Danke im Voraus , Bernd


  • 1
  • bfeser bfeser
    Padawan
    0 x
    38 Beiträge
    0 Hilfreiche Beiträge
    14. 05. 2007, 12:00

    Mal nach oben schieb... hat wirklich keiner ne Idee?

    Danke Bernd

  • b.detert b.detert
    Jedi-Ritter
    0 x
    132 Beiträge
    0 Hilfreiche Beiträge
    16. 05. 2007, 13:09

    Hallo,

    wir konnten den Fehler bzg. der SQL Fehlermedlungen im Ext-Manager nun endlich lokalisieren und er lag auf unserer Seite.

    Da hatte sich in der ext_tables.sql wohl nen Leerzeichen zuviel eingeschlichen! ;)

    Wird also mit der nächsten Version ebenfalls behoben sein.

  • bfeser bfeser
    Padawan
    0 x
    38 Beiträge
    0 Hilfreiche Beiträge
    16. 05. 2007, 13:27

    Danke

  • 1