Einsteigerproblem Templates

  • batshy batshy
    TYPO3-Anwärter
    0 x
    5 Beiträge
    0 Hilfreiche Beiträge
    22. 03. 2007, 23:36

    Hallo,
    ich beschäftige mich gerade ganz frisch mit Typo3 und habe als Hilfe das Typo3-Buch von Altmann, Fritz, Hinderink.
    Ich spiele gerade das "Hello World!"-Beispiel durch (Kap. 6.2.5):
    Solange ich nur ein Root-Template habe wird mir auch was angezeigt. Sobald ich ein Extension-Template einbinde bekomme ich beim Anzeigen der Site die Meldung "No Template Found!"
    Ich habe Typo3 4.0.2 auf einem Apache (Win) laufen.

    Ich würde gerne weiter kommen- Hilfe...

    Grüße

    Thomas


  • 1
  • Dander Dander
    Flash Gordon
    0 x
    2287 Beiträge
    0 Hilfreiche Beiträge
    23. 03. 2007, 09:31

    1. wo bindest du das extension template ein? (mit seitenbau)
    2. was steht in diesen templates

  • batshy batshy
    TYPO3-Anwärter
    0 x
    5 Beiträge
    0 Hilfreiche Beiträge
    23. 03. 2007, 09:57

    Hallo Dander,

    ich erstelle das extension template im Web > Template > "Click here to edit whole template record" > im Formularbereich "Include basis template" betätige ich das + Symbol (add new basis template).

    - im root-template steht:

    [TS]# Default PAGE object:
    page = PAGE
    page.typeNum = 0
    page.10 = TEXT
    page.10.value = HELLO WORLD!
    page.10.wrap = <strong>|</strong>
    page.20 < temp.meinInhalt[/TS]

    - im extension-template steht:

    [TS]temp.meinInhalt = TEXT
    temp.meinInhalt.value = Eine Textausgabe[/TS]

    Grüße

    Thomas

  • 1