Absatzformat wird nicht in der RTE-Listbox zum Auswählen angezeigt [Gelöst]

  • alexander_ro alexander...
    Padawan
    0 x
    61 Beiträge
    0 Hilfreiche Beiträge
    05. 03. 2007, 10:21

    Hallo,

    nach langem suchen am Wochenende bin ich der Lösung leider nicht viel näher gekommen. Ich möchte ein Absatzformat im RTE definieren das dann nur eine breite von 70% hat. Mir wird aber in der RTE-Listbox mein selbst definiertes Format nicht zur Auswahl angeboten.

    Typo3 Version: 4.0.2
    RTE Version : 1.4.3

    Aus meiner bisherigen Suche nach der Lösung sind folgendes TS und CSS entstaden:
    [TS]

    // RTE Konfiguration
    RTE.classes {
    breite70 {
    name = breite70
    value = width: 70%;
    }
    }

    RTE.default {
    // Stylesheet für eigene Text/Absatzformate
    contentCSS = fileadmin/css/rte_formate.css

    // Eigene Formate freigeben
    proc.allowedClasses := addToList (breite70)

    // Als Absatzformat auszuwählen im RTE
    classes = breite70
    classesParagraph := addToList (breite70)

    showTagFreeClasses = 1

    // Buttons die gezeigt/versteckt werden
    showButtons =

    // Hält die RTE Icons gegroupt zusammen
    keepButtonGroupTogether = 1

    }

    [/TS]

    [HTML]

    .breite70
    {
    width: 70%;
    }

    [/HTML]

    Ich denke es fehlt noch irgend eine Konfigoption damit es geht aber ich finde sie nicht. Muß ich irgendwo noch freischalten das eigene Formate im RTE angezeigt werden?

    Gruß
    Alexander


  • alexander_ro alexander...
    Padawan
    0 x
    61 Beiträge
    0 Hilfreiche Beiträge
    20. 03. 2007, 20:12

    Gut, sehr gut, so gehts dann.

    Die möglichkeit TS-Code bei den Seiteneigenschaften unterzubringen war mir bisher nicht bekannt oder nicht bewusst aufgefallen. In dem Howto hier wird zwar in einem folge Posting ungefähr beschrieben wo es hin soll. Das versteht man aber nur wenn man weiss dass es da unterschiede gibt. Nach anderen Threads hier bin ich nicht der einzge der darüber gestolpert ist. Vielleicht will ja mal jemand das Howto um einen Hinweis ergänzen und evtl. auch einen Hinweis dass man das CSS auch für das Frontend im TS-Seiten-Template einbinden muß wenn man in der RTE-Konfiguration auf die dann im HTML-Code unschönen "value" angaben verzichten will. Was natürlich nicht zwingend erforderlich ist aber wie ich finde eine Interessante alternative. Das Howto mit den folge Postings ist auf alle Fälle eine feine Sache weil man auf viele Fragen hilfreiche Antworten bekommt.

    Ich habe mir das Buch "Das Typo3 Anwenderhandbuch" vom Addison-Wesley Verlag gekauft. Dort wird in dem Kapitel über die RTE Konfiguration der Umstand auch nirgends erwähnt.

    Gruß
    Alexander