NewLoginBox [Gelöst]

  • kolki kolki
    Jedi-General
    0 x
    1044 Beiträge
    5 Hilfreiche Beiträge
    07. 08. 2006, 15:40

    Nach anfänglichen kleinen Schwierigkeiten habe ich die Extension "newloginbox" samt "newloginbox_tmplable", "sr_feuser_register", "kb_md5fepw" usw. erfolgreich installiert. Soweit läuft nun fast alles.

    Nur eine Sache bekomme ich einfach einfach nicht hin:
    Bei "Passwort vergessen" werden 2 Mails generiert. Die eine ist vollkommen korrekt, die andere enthält zum einen als Absender den Namen "www-data" und eine Absender-Adresse "wwwrun@providername.de"

    Außerdem (unter Benutzung von "newloginbox_tmplable") wird in der Nachricht der Benutzername und das Passwort folgendermaßen maskiert:
    Die Anführungszeichen erscheinen in der Nachricht nicht als " sondern HTML-eigenes Zeichen: & quot; . Deinstalliert man die "newloginbox_tmplable" tritt der "-Fehler nicht mehr auf. OK, passt man das Aussehen halt über die "tx_newloginbox_pi1" an. Ist ja nicht schlimm.
    Doch nach Deinstallation wird bei der über Marker bzw. Subpart eingebundenen Box der Link "Passwort vergessen" nicht mehr angezeigt. Binde ich die gleiche Box als Seitenelement ein kommt der Link...


  • 1
  • kolki kolki
    Jedi-General
    0 x
    1044 Beiträge
    5 Hilfreiche Beiträge
    09. 08. 2006, 14:00

    Ich habe herausgefunden, daß man das "Maskierungsproblem" bearbeiten kann, wenn man die entsprechende Maskierung bzw. Anführungszeichen in der pi1/locallang.php der Extension editiert. Also auch bei installierter Templ.-Ext.

    Warum standartmäßig eine Mail mit Absendedaten "wwwrun@providername.de (www-data)" verschickt wird konnte ich indes noch nicht klären.
    Nur soviel:
    Verwende ich die Einstellungen
    [TS]plugin.tx_newloginbox_pi1.email_from = xxx@xxxx.xx
    plugin.tx_newloginbox_pi1.email_fromName = xxx [/TS]
    generiert Typo3 zwei Mails von denen eine den obigen falschen Absender trägt und die andere korrekt ist. Da nun zweimal ein neues PW generiert wird enthält die jeweils letzte Mail die korrekten Anmeldedaten.

    Wer weiß, wie man die Mail mit Absendedaten "wwwrun@providername.de (www-data)" eleminieren kann?

  • kolki kolki
    Jedi-General
    0 x
    1044 Beiträge
    5 Hilfreiche Beiträge
    09. 08. 2006, 16:34

    Potz Blitz, ich hab's!

    Die Lösung des Problem's:
    In meiner Testumgebung hatte ich das Loginformular permanent eingebunden und zu Testzwecken den Seiteninhalt "Login" nicht versteckt. (Was schon mal ein Fehler war.)
    Fordert man nun ein neues Passwort an, werden nun [u]beide[/u] auf der Seite befindlichen Loginformulare verarbeitet und es werden nunmehr zwei neue Mails samt Passwörter generiert.
    Das nun eine Mail korrekt und die andere falsche Absendedaten enthielt, lag nun daran, das das Seitenelement "Login" die Informationen aus den Constants entnimmt, somit korrekt arbeitet.
    Das direkt über Subpart verwendete Login benutzt diese Information aus den Constants nicht. Als ich diese im TS eingefügt hatte, waren sie auch noch versehentlich unterhalb subparts.LOGIN < plugin.tx_newloginbox_pi1 gerutscht und konnte somit auch nicht aufgelöst werden. Stattdessen verarbeitete Typo3 die Standartwerte des Webservers.

    Vielen Dank für den Monolog...

  • TYP3 TYP3
    T3PO
    0 x
    15 Beiträge
    0 Hilfreiche Beiträge
    11. 08. 2006, 08:41

    Hallo Kolki!

    Du hast genau die Kombination, die ich benötige: "newloginbox", "sr_feuser_register", "kb_md5fepw"! Mit der Newloginbox und der FE User Registration das klappt auch alles soweit, aber was zur Hölle muss ich tun, damit das zusammen mit dem md5fepw funktioniert?? #angry# Ich hab mich hier im Forum schon dumm und dämlich gesucht und auch gegoogelt und zahlreiche Kommentare und Codesnippets, sogar ein PDF gefunden, welches die Verwendung von MD5 beschreibt. Aber all das gelesene bringt in der Umsetzung leider keinen Erfolg. Die Passwörter werden weder MD5-verschlüsselt noch im BE verschlüsselt angezeigt. Kannst du mir vielleicht kurz erklären was du gemacht hast, damit das mit der MD5-Verschlüsselung klappt?

    Was bei mir auch nicht fuktioniert ist die 'Passwort vergessen'-Funktion. Man gibt eine eMail-Adresse an, es wurde dann auch angeblich eine eMail verschickt, aber es kommt keine an (und geht auch keine raus).

    Ich verwende TYPO3 Version 4.0.1, newloginbox 2.2.11, sr_feuser_register 2.5.0, kb_md5fepw 0.4.0. Das Login-Feld wird auf allen Seiten angezeigt.

    Gruß,
    Tobias

  • kolki kolki
    Jedi-General
    0 x
    1044 Beiträge
    5 Hilfreiche Beiträge
    11. 08. 2006, 09:30

    Also zum Thema Verschlüsselung kann ich nur sagen, das es wohl darauf ankommen soll, das man die verschiedenen Extensions in der richtigen Reihenfolge installiert. Also zuerst die fh_library, static_info_tables und sr_static_info, newloginbox, sr_feuser_register usw. Erst zu guter letzt installiert man die kb_md5fepw. Ich hab's jedenfalls so gemacht und es funktionierte auf Anhieb.
    Was Dein "Mailproblem" angeht, kann ich Dir nicht helfen. Ich hatte eher das umgekehrte Problem, das er zuviel Mails versendet.

  • TYP3 TYP3
    T3PO
    0 x
    15 Beiträge
    0 Hilfreiche Beiträge
    11. 08. 2006, 10:09

    Hallo Kolki!

    Danke schon mal für die Antwort! Wird die fh_library dafür benötigt? Hast du sonst noch irgendwelche Anpassungen bei der Newloginbox oder der FE User Registration machen müssen, damit das mit der MD5-Verschlüsselung funktioniert? In dem Manual zur Erweiterung kb_md5fepw steht einiges zu den Anpassungen.

    Gruß,
    Tobias

  • kolki kolki
    Jedi-General
    0 x
    1044 Beiträge
    5 Hilfreiche Beiträge
    11. 08. 2006, 10:17

    in sachen fh_library bin ich überfragt. ich hab sie halt mit dabei und es geht. für die kb_md5fepw habe ich keinerlei anpassungen vorgenommen. die newloginbox und erst recht die sr_feuser_register benötigen sehr wohl einen arsch voller anpassungen die allerdings wenig mit der verschlüsselung zu tun haben.

  • TYP3 TYP3
    T3PO
    0 x
    15 Beiträge
    0 Hilfreiche Beiträge
    11. 08. 2006, 10:48

    Jo, gerade die sr_feuser_register benötigt wirklich verdammt viele Anpassungen. Für mich war nur wichtig, ob irgendwelche Anpassungen in Bezug auf die kb_md5fepw nötig sind.

  • 1