Typo3-4.0 und SuSE 10.0 [Gelöst]

  • hkalka hkalka
    T3PO
    0 x
    27 Beiträge
    0 Hilfreiche Beiträge
    15. 05. 2006, 13:54

    Finde ich jemand der kan mir helfen?
    Ich habe typo3 schon auf mehrere Linuxsystemen instaliert Fedora,Debian,Mandriva ales ok ales palleti und auch auf windows auf eigenem server läuft Typo3. Wolte aber mit SuSE 10.0 Instalieren weil ich will mit dem system arbeiten und typo3 auf SuSE besonders gut laufen soll.
    Ich habe mich gefreut,ales gemacht wie üblich und geht nichts mehr...jetzt habe ich ein harte stein getrofen und weiß ich nicht wie soll weiter gehen oto meldung bei start installation: You don't have permission to access /cms/typo3/install/index.php on this server.
    Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request.
    Apache/2.0.54 (Linux/SUSE) Server at localhost Port 80
    Auf meinem Server laufen auch portale zb. Joomla.
    Was tun,ich habe ale möglichkeiten versucht das was schreibt install.txt und andere. Vieleich ich habe etwas vergessen? Oder verstehe ich nicht gut. Das ist aber möglich!
    Bitte vielleicht kann mir jemand helfen werde ich sehr dankbar.


  • ttb ttb
    Jedi-Ritter
    0 x
    143 Beiträge
    0 Hilfreiche Beiträge
    16. 05. 2006, 05:37

    Mhhh...du hattest doch nicht etwa die anderen Scripte bzw. CMS' auf dem Server unter root laufen? Denn:

    You don't have permission...

    Die Dateirechte stimmen nicht...mittels chown bzw. chgroup kannst du sie entsprechend ändern und dann sollte es klappen.

  • hkalka hkalka
    T3PO
    0 x
    27 Beiträge
    0 Hilfreiche Beiträge
    16. 05. 2006, 15:14

    tja... ich habe auch so gedacht ich danke dir für Deine interesse ich freue mich vieleich finden wir was ist den los. Ich habe SuSE 10.1 heruntergeladen möchte instalieren und noch mal alles prüfen was hast Du gesagt. Brauche ich noch par tagen zum prüfen Warte auf mein signall. Danke ttb

  • hkalka hkalka
    T3PO
    0 x
    27 Beiträge
    0 Hilfreiche Beiträge
    17. 05. 2006, 18:52

    Ok melde ich mich wieder...
    Ich habe neue version SuSE 10.1 installiert. Alle Wege wie beschrieben Tgz-INSTAL.txt geführt. keine Änderung.
    Ich glaube, weil SuSE hat einen einfachen Server www aus Apache2.2, vielleicht habe ich nicht alle Module drin oder Extensionen für php.
    Oder Konfigurationen bei Apache und php.ini sind noch nicht richtig gamacht.
    Jetzt weiß ich nicht mehr. Der gleiche Typo3 läuft auf Linux:- Mandriva, Debian, Fedora-Core 5.
    SuSE hat DocumentRoot /srv/www/htdocs, und dort sind beide /Typo3_src-4.0 als Verzeichnis, und Dummy-4.0 als /cms Verzeichnis.
    Beim startenauf http://localhost/cms/ Browser "Mozilla-Firefox oder Konqueror" ergäntzt die adresse auf: http://localhost/cms/typo3/install/index.php?mode=123&step=1&password=joh316
    dan komm Meldunk:
    Forbidden
    You don't have permission to access /typo3/install/index.php on this server.
    Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request.
    Apache/2.2.0 (Linux/SUSE) Server at localhost Port 80

    PS.
    Was sagen Sie , Herr Woida dazu? Können Sie ein gutes oder schlechtes wort sagen?
    Ich würde mich freuen, wenn Sie mir Ihre Meinung mitteilen könnten
    Mit freundlichen Grüß.

  • woida woida
    Flash Gordon
    0 x
    2356 Beiträge
    1 Hilfreiche Beiträge
    18. 05. 2006, 08:54

    Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request.
    Apache/2.2.0 (Linux/SUSE) Server at localhost Port 80

    Was steht denn im error.log?

  • hkalka hkalka
    T3PO
    0 x
    27 Beiträge
    0 Hilfreiche Beiträge
    18. 05. 2006, 11:00

    Guten Tag Herr woida oto inhalt error_log von apache2:
    [Mon May 15 21:45:14 2006] [warn]Init: Session Cache is not configured [hint: SSLSessionCache]
    [Mon May 15 21:45:14 2006] [notice]suEXEC mechanism enabled (wrapper: /usr/sbin/suexec2)
    [Mon May 15 21:45:15 2006] [notice]Apache/2.2.0 (Linux/SUSE) configured -- resuming normal operations
    [Mon May 15 21:59:55 2006] [notice]caught SIGTERM, shutting down
    [Mon May 15 21:59:56 2006] [warn]Init: Session Cache is not configured [hint: SSLSessionCache]
    [Mon May 15 21:59:56 2006] [notice]suEXEC mechanism enabled (wrapper: /usr/sbin/suexec2)
    [Mon May 15 21:59:56 2006] [notice]Apache/2.2.0 (Linux/SUSE) configured -- resuming normal operations
    [Mon May 15 22:09:27 2006] [error][client ::1] Symbolic link not allowed or link target not accessible: /srv/www/htdocs/cms/typo3
    [Mon May 15 22:09:34 2006] [error][client ::1] Symbolic link not allowed or link target not accessible: /srv/www/htdocs/cms/typo3
    [Mon May 15 22:09:47 2006] [error][client ::1] Symbolic link not allowed or link target not accessible: /srv/www/htdocs/cms/typo3
    [Mon May 15 22:19:25 2006] [notice]caught SIGTERM, shutting down
    [Mon May 15 22:21:36 2006] [warn]Init: Session Cache is not configured [hint: SSLSessionCache]
    [Mon May 15 22:21:36 2006] [notice]suEXEC mechanism enabled (wrapper: /usr/sbin/suexec2)
    [Mon May 15 22:21:36 2006] [notice]Apache/2.2.0 (Linux/SUSE) configured -- resuming normal operations
    [Mon May 15 22:29:41 2006] [notice]caught SIGTERM, shutting down
    [Mon May 15 22:29:41 2006] [warn]Init: Session Cache is not configured [hint: SSLSessionCache]
    [Mon May 15 22:29:41 2006] [notice]suEXEC mechanism enabled (wrapper: /usr/sbin/suexec2)
    [Mon May 15 22:29:42 2006] [notice]Apache/2.2.0 (Linux/SUSE) configured -- resuming normal operations
    [Mon May 15 22:29:59 2006] [error][client ::1] Symbolic link not allowed or link target not accessible: /srv/www/htdocs/cms/typo3, referer: http://localhost/cms/
    [Mon May 15 22:30:29 2006] [error][client ::1] Symbolic link not allowed or link target not accessible: /srv/www/htdocs/cms/typo3
    [Mon May 15 22:30:37 2006] [error][client ::1] Symbolic link not allowed or link target not accessible: /srv/www/htdocs/cms/typo3

  • woida woida
    Flash Gordon
    0 x
    2356 Beiträge
    1 Hilfreiche Beiträge
    18. 05. 2006, 11:03

    Symbolic link not allowed or link target not accessible

    => SymLinks nicht erlaubt => "Options Indexes FollowSymLinks" im vHost.

  • hkalka hkalka
    T3PO
    0 x
    27 Beiträge
    0 Hilfreiche Beiträge
    18. 05. 2006, 11:20

    das ist mein vhost

    # VirtualHost template
    # Note: to use the template, rename it to /etc/apache2/vhost.d/yourvhost.conf.
    # Files must have the .conf suffix to be loaded.
    #
    # See /usr/share/doc/packages/apache2/README.QUICKSTART for further hints
    # about virtual hosts.
    #
    # NameVirtualHost statements can be added to /etc/apache2/listen.conf.
    #
    # Almost any Apache directive may go into a VirtualHost container.
    # The first VirtualHost section is used for requests without a known
    # server name.
    #
    <VirtualHost *:80>
    ServerAdmin webmaster@dummy-host.example.com
    ServerName dummy-host.example.com

    # DocumentRoot: The directory out of which you will serve your
    # documents. By default, all requests are taken from this directory, but
    # symbolic links and aliases may be used to point to other locations.
    DocumentRoot /srv/www/vhosts/dummy-host.example.com

    # if not specified, the global error log is used
    ErrorLog /var/log/apache2/dummy-host.example.com-error_log
    CustomLog /var/log/apache2/dummy-host.example.com-access_log combined

    # don't loose time with IP address lookups
    HostnameLookups Off

    # needed for named virtual hosts
    UseCanonicalName Off

    # configures the footer on server-generated documents
    ServerSignature On

    # Optionally, include *.conf files from /etc/apache2/conf.d/
    #
    # For example, to allow execution of PHP scripts:
    #
    # Include /etc/apache2/conf.d/mod_php4.conf
    #
    # or, to include all configuration snippets added by packages:
    # Include /etc/apache2/conf.d/*.conf

    # ScriptAlias: This controls which directories contain server scripts.
    # ScriptAliases are essentially the same as Aliases, except that
    # documents in the realname directory are treated as applications and
    # run by the server when requested rather than as documents sent to the client.
    # The same rules about trailing "/" apply to ScriptAlias directives as to
    # Alias.
    #
    ScriptAlias /cgi-bin/ "/srv/www/vhosts/dummy-host.example.com/cgi-bin/"

    # "/srv/www/cgi-bin" should be changed to whatever your ScriptAliased
    # CGI directory exists, if you have one, and where ScriptAlias points to.
    #
    <Directory "/srv/www/vhosts/dummy-host.example.com/cgi-bin">
    AllowOverride None
    Options +ExecCGI -Includes
    Order allow,deny
    Allow from all
    </Directory>

    # UserDir: The name of the directory that is appended onto a user's home
    # directory if a ~user request is received.
    #
    # To disable it, simply remove userdir from the list of modules in APACHE_MODULES
    # in /etc/sysconfig/apache2.
    #
    <IfModule mod_userdir.c>
    # Note that the name of the user directory ("public_html") cannot simply be
    # changed here, since it is a compile time setting. The apache package
    # would have to be rebuilt. You could work around by deleting
    # /usr/sbin/suexec, but then all scripts from the directories would be
    # executed with the UID of the webserver.
    UserDir public_html
    # The actual configuration of the directory is in
    # /etc/apache2/mod_userdir.conf.
    Include /etc/apache2/mod_userdir.conf
    # You can, however, change the ~ if you find it awkward, by mapping e.g.
    # http://www.example.com/users/karl-heinz/ --> /home/karl-heinz/public_html/
    #AliasMatch ^/users/([a-zA-Z0-9-_.]*)/?(.*) /home/$1/public_html/$2
    </IfModule>

    #
    # This should be changed to whatever you set DocumentRoot to.
    #
    <Directory "/srv/www/vhosts/dummy-host.example.com">

    #
    # Possible values for the Options directive are "None", "All",
    # or any combination of:
    # Indexes Includes FollowSymLinks SymLinksifOwnerMatch ExecCGI MultiViews
    #
    # Note that "MultiViews" must be named *explicitly* --- "Options All"
    # doesn't give it to you.
    #
    # The Options directive is both complicated and important. Please see
    # http://httpd.apache.org/docs-2.2/mod/core.html#options
    # for more information.
    #
    Options Indexes FollowSymLinks

    #
    # AllowOverride controls what directives may be placed in .htaccess files.
    # It can be "All", "None", or any combination of the keywords:
    # Options FileInfo AuthConfig Limit
    #
    AllowOverride None

    #
    # Controls who can get stuff from this server.
    #
    Order allow,deny
    Allow from all

    </Directory>

    </VirtualHost>

  • woida woida
    Flash Gordon
    0 x
    2356 Beiträge
    1 Hilfreiche Beiträge
    18. 05. 2006, 11:33

    Schön. Und was ist die Frage?

  • hkalka hkalka
    T3PO
    0 x
    27 Beiträge
    0 Hilfreiche Beiträge
    18. 05. 2006, 11:59

    Danke Herr woida, ich habe geschaft.
    Mit freundlichen Grüß