pdf_generator2 und CSS Problem

  • cikono1 cikono1
    T3PO
    0 x
    25 Beiträge
    0 Hilfreiche Beiträge
    12. 05. 2006, 10:14

    Hallo Leute,

    hab mir mal die extension pdf_generator2 darauf genudelt.

    PDF wird auch sauber erzeugt und angezeigt.

    Mein Problem, alles wird in times New Roman angezeigt, ich will aber mein eigene CSS Datei einbinden. Hier im Forum habe ich auch schon was gefunden, aber er will einfach net funtzen, es wird einfach alles in TNR angezeigt.

    Hier mal das TS:
    [TS]footernav.21 = TEXT
    footernav.21.value = </li><li class="pdf">
    footernav.22 = TEXT
    footernav.22.value = PDF
    footernav.22.postUserFunc = tx_pdfgenerator2->makePdfLink
    footernav.22.postUserFunc.target = _blank

    pdf_generator2 {
    stylesheet = fileadmin/pdf_template/pdf_style.css
    10 = TEMPLATE
    10.template = FILE
    10.template.file = fileadmin/pdf_template/pdf_template.html
    10.workOnSubpart = MAIN
    10.marks.CONTENT = CONTENT
    10.marks.CONTENT {
    table = tt_content
    select.orderBy = sorting
    select.where = colPos = 0
    }
    }
    [/TS]

    Und Hier mal mein Template:

    [HTML]<!--###MAIN###-->
    <div id="rahmen">
    <div id="content">
    ###CONTENT###
    </div>
    </div>
    <!--###MAIN###-->

    MFG[/HTML]


  • 1
  • cikono1 cikono1
    T3PO
    0 x
    25 Beiträge
    0 Hilfreiche Beiträge
    14. 05. 2006, 16:33

    Kann mir denn keiner helfen???

    Es ist wirklich wichtig!!!!!!!!!!!!

  • Merlin732 Merlin732
    R2-D2
    0 x
    120 Beiträge
    0 Hilfreiche Beiträge
    15. 06. 2006, 13:05

    habe das gleiche Problem ... ab Version 4 geht das bei mir aufeinmal nicht mehr ... d.h. CSS wird einfach nicht übernommen.

  • dorf dorf
    Sternenflotten-Admiral
    0 x
    189 Beiträge
    0 Hilfreiche Beiträge
    23. 06. 2006, 14:02

    hallo cikono1,
    hab deinen code (fast) einszueins übernommen, bekomme damit aber keine ausgabe einer pdf.

    [TS]temp.downpdf = TEXT
    temp.downpdf {
    value = PDF des Artikels anzeigen
    postUserFunc = tx_pdfgenerator2->makePdfLink
    postUserFunc.target = _blank
    }

    pdf_generator2 {
    stylesheet = fileadmin/test/pdf/pdf.css
    10 = TEMPLATE
    10.template = FILE
    10.template.file = fileadmin/test/pdf/pdf.html
    10.workOnSubpart = BODY
    10.marks.CONTENT = CONTENT
    10.marks.CONTENT {
    table = tt_content
    select {
    orderBy = sorting
    where = colPos = 0
    languageField = sys_language_uid
    }
    }
    }[/TS]
    alss EXT laufen:
    pdf_generator2 + pdf_generator2_fonts

    verwende bei Include static: lanuage.de, content(default) <-- fehlt da vielleicht was?
    und nichts bei Include static (from extensions)

    ich zermatere mir schon seit tagen den kopf, mit dem pdf_generator geht alles wunderbar, will aber bestimmte fonts in der pdf verwenden darum brauch in den pdf_generator2

    [url]http://typo3.net/forum/list/list_post//45077/[/url]
    [url]http://typo3.net/forum/list/list_post//45028/[/url]
    sind keine doppelt post sondern verzweifelte versuche die ext zum laufen zu bringen. hat nicht jemnad die ext schon zum laufen beracht oder ne anleitung?

    gruß dorf

  • 1