Bilder ohne Ubruch einfügen?

  • Maxi Maxi
    Padawan
    0 x
    37 Beiträge
    0 Hilfreiche Beiträge
    14. 01. 2006, 19:01

    Ich hab ein Problem. Ich versuche ein Beispiel aus dem Buch EINSTIEG IN TYPO3 umzusetzen.
    Dort werden in eine Tabelle auf diese Weise die Bilder eingefügt:

    marks.HEADERIMGLEFT< styles.content.getLeft
    marks.HEADERIMG < styles.content.getRight

    Die beiden Bilder werden also als Inhalt/Content eingetragen. Ich hab dafür den Seiteninhalt BILDER verwendet. Im Prinzip gehts, jedoch wird immer mit dem Bild ein <BR> eingefügt. Dadurch verschiebt sich die Tabelle unter dem Bild so das ein weisser Rand entsteht. Wie kann ich verhindern das <BR> kommt. Ich will lediglich ein Bild ohne Text und Umbruch als Content.

    Das Beispiel war glaub für Typo 3.7 und ich nutze halt 3.81. Aber daran kanns doch nicht liegen, oder?


  • 1
  • Maxi Maxi
    Padawan
    0 x
    37 Beiträge
    0 Hilfreiche Beiträge
    14. 01. 2006, 20:57

    Dieser Code (Auszug) wird generiert:

    <td width="571"><a name="18"></a><div style="text-align:center;"><table width="571" border="0" cellspacing="0" cellpadding="0" style="margin-left: auto; margin-right: auto" class="imgtext-table"><tr><td colspan="1"><img src="clear.gif" width="571" height="1" alt="" /></td></tr><tr><td valign="top"><img src="uploads/pics/hausheader_01.jpg" width="571" height="150" border="0" align="top" alt="" title="" /><br /></td></tr></table></div><img src="clear.gif" width="1" height="10" border="0" class="spacer-gif" alt="" title="" /><br /></td>

    Woher kommt die Höhe 10 in dieser Zeile????
    ... <img src="clear.gif" width="1" height="10" ...

    Der Abstand sollte eigentlich nur 1 Pixel sein

  • 1