direct_mail funktioniert nicht so wie es soll

  • stefansvw stefansvw
    Jedi-Ritter
    0 x
    129 Beiträge
    0 Hilfreiche Beiträge
    15. 12. 2005, 10:35

    Hallo,

    habe folgend Ext:

    tt_address
    direct_mail
    plugin_mgm
    sr_direct_mail_ext
    direct_mail_subscription

    Habe ein Verzeichnis "Newsletter" der wie folgt aussieht:

    +Seite
    Newsletter1 -> Standard
    Newsletter2 -> Standard
    Newsletter -> Sysfolder
    ...+ Inhalt des Sysfolder
    ...+ Seite -> Newsletter 1 -> Standard
    ...+ Versandobjekte -> Newsletter zum Versenden 1 -> Standard
    ...+ Versandgruppen -> test und newsletter

    +Seiteninhalt
    Plugin -> Direct Anmeldung

    +Template
    main

    constants

    1. plugin.feadmin.dmailsubscription.pid=157
    2. plugin.feadmin.dmailsubscription.file.templateFile = EXT:direct_mail_subscription/pi/fe_admin_dmailsubscrip.tmpl
    3. plugin.feadmin.dmailsubscription.email = newsletter@xxx.de
    4. plugin.feadmin.dmailsubscription.emailName = Newsletter
    5. plugin.feadmin.dmailsubscription.enablePlain = 1
    6. plugin.feadmin.dmailsubscription.enableHTML = 1

    setup

    1. plugin.feadmin.dmailsubscription.create.overrideValues.module_sys_dmail_html = 1
    2.  
    3. config{
    4.  
    5. admPanel=0
    6.  
    7. no_cache = 0
    8. locale_all = de_De
    9. index_enable = 1
    10. index_externals = 1
    11.  
    12. setJS_openPic = 1
    13.  
    14. stat_apache = 1
    15. stat_apache_logfile = {$logFile}
    16.  
    17. ###E-Mail Adresse ohne @###
    18. #spamProtectEmailAddresses = 2
    19. #spamProtectEmailAddresses_atSubst = (at)
    20.  
    21. ###XHTML###
    22. #doctype = xhtml_trans
    23. #xhtml_cleaning = all
    24. htmlTag_langKey = de
    25. removeDefaultJS = external
    26. inlineStyle2TempFile = 1
    27.  
    28. ###User Track###
    29. tx_loginusertrack_enable = 1
    30.  
    31. setJS_openPic = 1
    32.  
    33. ###proalias + simulateStatic###
    34. simulateStaticDocuments = 1
    35. simulateStaticDocuments_aliasPro = 1
    36. simulateStaticDocuments_noTypeIfNoTitle = 1
    37. #absRefPrefix =
    38.  
    39. ###email-charset###
    40. notification_email_encoding = quoted-printable
    41. notification_email_charset = utf-8
    42.  
    43. }

    +Adresse
    Auflistung von ca. 300 Adressen

    +Newsletter Kategrie
    Kat 1

    [b]Was geht nicht richtig ?[/b]

    a)Meine Anmeldung erscheint nur auf englisch trotz (page.config.language = de)
    b)Wie bekomme ich die Kategorien weg, im Template selbst ?
    c)Kann ich es einem Frontenduser während seiner Neuregistrierung bzw. Profiledit auch anbieten Newsletter in HTML bzw. TXT anzuklicken und Ihn dynamisch in die Newslettergruppe zu schreiben ?
    d) wie trenne ich den am besten zwischen TXT und HTML-Kunden? Mit Gruppen ?

    Wer kann mich ein wenig aufklären, was mir noch fehlt bzw. was ich hier wiederrum falsch mache.

    Ich bin noch am verzweifeln bei manchen Typo3-Punkten

    PS: Ich habe auch eine eigene PHP-Applikation für Newsletter und wäre eigentlich sehr froh, wenn ich diese mit allen denkbaren Features in Typo3 einbinden könnte.

    Gruß
    Stefan


  • 1
  • stefansvw stefansvw
    Jedi-Ritter
    0 x
    129 Beiträge
    0 Hilfreiche Beiträge
    15. 12. 2005, 17:47

    habe das template eingedeutscht

    nur kann mir jemand sagen wie ich diesen Array "TCA_INPUT_module_sys_dmail_category" von 10 Subjects auf einen einzigen trosseln kann?

    Ich habe nur ein Newsletter und möchte bei der Registrierung nur diesen Sehen und nicht 10 checkbox-Felder.

    Kann mir jemand helfen?

    Weiterhin habe ich in meiner Verteilergruppe von dmail nur die tt_adress-Daten stehen aber die feuser welche sich beim registrieren fürs Newsletter entscheiden werden nicht in die Gruppe integriert. Was mache ich hier noch falsch?

    Und zu guter letzt:

    Wie kann ich am besten die HTML-Empfänger und die TXT dynamisch trennen?

    Kann mir bitte jemand helfen?
    Ich mache jetzt schon ein paar Tage an diesen Problemen rum und verzweifle.

    Gruß
    Stefan

  • stefansvw stefansvw
    Jedi-Ritter
    0 x
    129 Beiträge
    0 Hilfreiche Beiträge
    21. 12. 2005, 13:48

    Kann mir den niemand einen Rat geben bevor ich verzweifle.

  • stefansvw stefansvw
    Jedi-Ritter
    0 x
    129 Beiträge
    0 Hilfreiche Beiträge
    22. 12. 2005, 09:19

    wenigstens nur, das die anderen 9 checkbox verschwinden

  • stefansvw stefansvw
    Jedi-Ritter
    0 x
    129 Beiträge
    0 Hilfreiche Beiträge
    09. 01. 2006, 10:25

    hat den noch keiner das Problem mit diesen 10 Checkboxen bei der Registrierung gehabt. Habe ich in der Doc was überflogen ?

    >Ich verzweifle<

  • freyherr freyherr
    Padawan
    0 x
    47 Beiträge
    0 Hilfreiche Beiträge
    17. 01. 2006, 13:32

    Hi, anscheinend habt ihr ja die Extension sauber installiert bekommen. Bei mir kommt die Fehlermeldung, dass einige Tabellen nicht angelegt werden. Es scheint mit der MySQL-Version zusammen zu hängen.
    Konntet ihr eine saubere Installation der Extensions vornehmen? Wie?

    GRüße von einem ratlosen

    Peter

  • kaftanwo kaftanwo
    TYPO3-Anwärter
    0 x
    5 Beiträge
    0 Hilfreiche Beiträge
    18. 01. 2006, 17:41

    Hallo und guten Abend,

    ich habe auch ein paar Probleme mit dieser extension. Das Problem der deutschen Seite hab ich wie folgt gelöst:
    Im Ordner typo3/ext/direct_mail_subscrition/pi liegt eine Datei "fe_admin_dmailsubscr.tmpl". Diese Datei ist wohl das Template für das Generieren der Mails. Dort können die Kategorien editiert und das Ganze ins Deutsche übersetzt werden.

    Gruß

  • kaftanwo kaftanwo
    TYPO3-Anwärter
    0 x
    5 Beiträge
    0 Hilfreiche Beiträge
    18. 01. 2006, 17:45

    Noch ein Zusatz:

    das Typoscript im setup hab ich nicht eingesetzt. Wohl aber die constants.

    Gruß

    Wolfgang

  • n00k n00k
    Sternenflotten-Admiral
    0 x
    179 Beiträge
    0 Hilfreiche Beiträge
    26. 01. 2006, 15:24

    Ich habe jetzt folgendes in mein Setup geschrieben, in der Hoffnung das er mein übersetztes Template annimmt, was er aber nicht tut.
    Habe ich den falschen Pfad oder muss das in die Constants?

    ###DIRECT_MAIL###
    plugin.feadmin.dmailsubscription {
    file.templateFile = fileadmin/files/templates/fe_admin_dmailsubscrip_de.tmpl
    }

  • Freshmeat Freshmeat
    Sternenflotten-Admiral
    0 x
    194 Beiträge
    0 Hilfreiche Beiträge
    10. 05. 2006, 12:32

    wahrscheinlich hat sich das Problem schon erübrigt bei dir.. aber sonst für alle die es in der Zukunft noch haben könnten...

    Wenn ihr das File über den Objectbrowser angebt dann seht ihr schnell dass die korrekte Konfiguration wie folgt aussehen muss...

    [TS]plugin.feadmin.dmailsubscription {
    templateFile = fileadmin/templates/newsletterMask_template.html
    }
    [/TS]

  • 1