css wird nicht erkannt

  • 0 x
    13 Beiträge
    0 Hilfreiche Beiträge
    13. 11. 2005, 21:11

    hallo.

    ich bin sicher schon der 100000 der diese frage stellt, aber eines der ersten Probleme die ich hatte, ist dass das
    CSS nicht erkannt wird. Ich hab leider keine Ahnung woran das
    liegen kann, bin alles auf Tippfehler durchgegangen,
    habe aber nichts gefunden.

    So schaut meine stlye.CSS-Datei aus:

    body,
    html {
    margin: 0px;
    padding: 0px;
    }

    .statisch {
    font-family: verdana, arial, helvetica, sans-serif;
    color: #FFFFFF;
    font-weight: bold;
    font-size: 10px;
    text-decoration: none;
    padding-top: 4px;
    }
    .
    .
    .

    So ist es in der vorlage2.HTML-Datei eingebunden:

    <html>

    <head>
    <title>Domendos Homepage</title>
    <meta http-equiv="Content-Type" content="text/html;
    charset=iso-8859-1">
    <link rel="stylesheet" type="text/css"
    href="fileadmin/domendos/style.css" />
    </head>

    <body link="#FFFFFF" vlink="#FFFFFF" alink="#FFFFFF">
    <!-- ###DOKUMENT### begin -->
    .
    .
    .

    Und im typoscript-code:

    stylesheet = fileadmin/domendos/style.css

    Das ganze liegt in fileadmin/domendos

    es sollte doch alles stimmen oder?

    danke für die hilfe!!!!


  • 1
  • Norman2k Norman2k
    Jedi-General
    0 x
    1639 Beiträge
    75 Hilfreiche Beiträge
    13. 11. 2005, 21:28

    Du zeigst ein bißchen wenig von deinem TS. Wenn du wirklich nur "stylesheet = fileadmin/domendos/style.css" geschrieben hast ohne "page" davor, kann es nicht funtionieren.

    Probier es mal so:

    1. page.includeCSS.file1 = fileadmin/domendos/style.css

    Norman

  • 0 x
    13 Beiträge
    0 Hilfreiche Beiträge
    13. 11. 2005, 21:40

    page = PAGE
    page {
    typeNum = 0
    # Allgemeine Seiteneigenschaften setzen
    bodyTag = <body bgcolor="#FFFFFF" topmargin="0" leftmargin="0">
    meta.AUTHOR = Richard Schermann
    meta.DESCRIPTION = Domendos Homepage
    stylesheet = fileadmin/domendos/style.css
    bgImg = fileadmin/domendos/domendos3.gif

    ja sorry, aber das page davor is eh.
    und das mit dem includeCSS hat leider auch nicht funktioniert
    ich habs ohne page davor innerhalb der klammern probiert und mit page außerhalb der klammern

  • Norman2k Norman2k
    Jedi-General
    0 x
    1639 Beiträge
    75 Hilfreiche Beiträge
    13. 11. 2005, 21:50

    Was wird denn im Quelltext deiner Seite angezeigt? Ist die CSS dort eingebunden?

    Norman

  • 0 x
    13 Beiträge
    0 Hilfreiche Beiträge
    13. 11. 2005, 22:04

    [b]<style type="text/css">
    /*<![CDATA[*/
    <!--[/b]/* default styles for extension "tx_mininews_pi1" */
    .tx-mininews-pi1 .tx-mininews-pi1-listrow P.tx-mininews-pi1-listrowField-title { font-weight:bold; }
    .tx-mininews-pi1 .tx-mininews-pi1-listrow P.tx-mininews-pi1-listrowField-teaser { margin-bottom:15px; }
    .tx-mininews-pi1 .tx-mininews-pi1-fp_listrow P.tx-mininews-pi1-fp_listrowField-title { font-weight:bold; }
    .tx-mininews-pi1 .tx-mininews-pi1-fp_listrow P.tx-mininews-pi1-fp_listrowField-teaser { margin-top:0px; margin-bottom:10px; }
    .tx-mininews-pi1 .tx-mininews-pi1-singleView P.tx-mininews-pi1-singleViewField-teaser { font-style:italic; margin-top:5px; margin-bottom:10px; }
    .tx-mininews-pi1 .tx-mininews-pi1-browsebox P SPAN.tx-mininews-pi1-browsebox-strong { font-weight:bold; }
    .tx-mininews-pi1 .tx-mininews-pi1-listrow P.tx-mininews-pi1-listrowField-teaser A { color:black; text-decoration:none; }
    .tx-mininews-pi1 .tx-mininews-pi1-listrow P.tx-mininews-pi1-listrowField-teaser A:hover { color:black; text-decoration:none; }
    -->
    /*]]>*/
    [b]</style>
    <link rel="stylesheet" href="fileadmin/domendos/style.css" />
    <link rel="stylesheet" href="fileadmin/domendos/style.css" />[/b]

    keine ahnung wieso er das doppelt verlinkt aber ich glaub es müsste ja trotzdem gehn

  • 1