Typo3 meint "save_mode=on" phpInfo meint "sa

  • 0 x
    28 Beiträge
    0 Hilfreiche Beiträge
    28. 10. 2004, 10:28

    Hallo Gemeinede,

    ich weiss, ich bin nicht der erste, aber ich habe ein Problem mit save_mode und ImageMagick.

    Save_Mode:
    Im TYPO3 3.7.0 Install Tool steht
    unter Basic Configuration:
    "Safe mode turned on"

    unter php-info steht bei safe_mode:
    safe_mode Off Off
    safe_mode_exec_dir /home/www/empty/
    safe_mode_gid Off

    ImageMagick:
    Typo3 erkennt zwar ImageMagick,

    [code:1:1d7e83c52f]ImageMagick enabled: 1
    ImageMagick path: /usr/local/imagemagick-4.2.9/bin/ ()
    ImageMagick path/LZW: /usr/local/imagemagick-4.2.9/bin/ ()
    Version 5 flag: 0

    GDLib enabled: 1
    GDLib using PNG: 1
    GDLib 2 enabled: 0
    IM5 effects enabled: 0 (Blurring/Sharpening with IM 5+)
    Freetype DPI: 96 (Should be 96 for Freetype 2)
    [/code:1:1d7e83c52f]

    aber beim "Image Processing" tut sich nichts. (Test skipped)

    Wo ist mein Fehler?

    Gruss
    Andreas


  • 1
  • jweiland jweiland
    Jedi-General
    0 x
    1933 Beiträge
    1 Hilfreiche Beiträge
    28. 10. 2004, 10:54

    Hi Andreas,

    sind die Rechte für IM auf ausführbar gesetzt? Was passiert, wenn man IM von der Shell aus aufruft?

    Jochen

  • 0 x
    28 Beiträge
    0 Hilfreiche Beiträge
    28. 10. 2004, 11:29

    Alle Rechte sind bei 755.

    Über shell habe ich es noch nicht probiert. Was soll passieren? Welche Parameter muss ich eingeben.

    Gruss
    Andreas

  • jweiland jweiland
    Jedi-General
    0 x
    1933 Beiträge
    1 Hilfreiche Beiträge
    28. 10. 2004, 11:51

    Einfach mal convert, combine oder identify aufrufen und sehen, ob eine Fehlermeldung kommt. Normalerweise wird eine Liste der mögl. Parameter ausgegeben.

    Jochen

  • Alegria Alegria
    T3PO
    0 x
    24 Beiträge
    0 Hilfreiche Beiträge
    29. 10. 2004, 21:58

    Hallo
    Ich hab im Verzeichnis safe_mode_exec_dir hier: /home/www/empty/ einfach Symlinks auf meine Imagemagick Dateien gemacht und damit gehts bei mir
    Gruß
    Jens

  • 1