AWSTATS Installations-Probleme

  • 0 x
    9 Beiträge
    0 Hilfreiche Beiträge
    04. 08. 2004, 15:21

    Hallo Forum,

    ich habe folgendes Problem bei der Installation von AWSTATS:

    Perl was not found at '/usr/local/bin/perl'. The awstats.pl script can't be executed!

    Weiß jemand was ich falsch gemacht habe?


  • 1
  • jweiland jweiland
    Jedi-General
    0 x
    1933 Beiträge
    0 Hilfreiche Beiträge
    04. 08. 2004, 15:58

    Entweder ist Perl nicht auf dem Server installiert -> installieren

    -oder-

    Perl ist installiert, befindet sich aber in einem anderen Verzeichnis -> erste Zeile im AWSTATS Perl-Script anpassen

    Jochen Weiland

  • 0 x
    9 Beiträge
    0 Hilfreiche Beiträge
    04. 08. 2004, 18:18

    Hallo Herr Weiland,

    vielen Dank für die schnelle Antwort. Ich weiß leider nicht, wo das awstats.pl korrekterweie hingehört.

    In der Datei /typo3config/ext/cc_awstats/nod1/index.php steht ab Zeile 255:

    if (is_executable ("/usr/bin/perl")) {
    $perl = "/usr/bin/perl ";
    } else {
    f (is_executable ("/usr/local/bin/perl")) {
    $perl = " ";

    im selben Ordner ist auch das awstats.pl die erste Zeile lautet hier:

    #!/usr/bin/perl

    Ich habe auf Verdacht eine Kopie in html/cgi-bin/awstats.pl gelegt. Es geht leider immer noch nicht.

    Viele Grüße

    Dominique

    PS: habe gerade Ihr Tutorial: Statische Seiten simulieren ausprobiert :-)

  • jweiland jweiland
    Jedi-General
    0 x
    1933 Beiträge
    0 Hilfreiche Beiträge
    04. 08. 2004, 18:28

    Die awstats.pl bleibt an der Stelle, wo sie bei der Installation der Extension gelandet ist.

    Die Frage ist, wo auf dem Rechner (Linux?) befindet sich "perl"

    Jochen Weiland

  • 0 x
    9 Beiträge
    0 Hilfreiche Beiträge
    04. 08. 2004, 18:54

    Ja, ist Linux.
    Aber wo Perl ist müßte ich den Provider fragen.

    Dominique

  • maxhb maxhb
    Flash Gordon
    0 x
    2148 Beiträge
    0 Hilfreiche Beiträge
    04. 08. 2004, 20:14

    [quote:8813ee5f00="Dominique"]Ja, ist Linux.
    Aber wo Perl ist müßte ich den Provider fragen.[/quote:8813ee5f00]
    Falls Du einen ssh-Zugang hast kannst Du Dir durch folgendes Shellkommando anzeigen lassen, wo perl installiert ist:
    [code:1:8813ee5f00]which perl[/code:1:8813ee5f00]
    CU
    maxhb

  • 0 x
    9 Beiträge
    0 Hilfreiche Beiträge
    05. 08. 2004, 11:05

    Das mit dem Pfad ist geklärt. der Pfad zu Perl lautet: /usr/bin/perl
    Das steht auch in der ersten Zeile des awstats.pl
    Da Pearl trotzdem nicht gefunden wurde, habe ich den Tip unter:

    http://lists.netfielders.de/pipermail/typo3-at/2004-May/001554.html

    ausprobiert und in der typo3conf/ext/cc_awstats/mod1/index.php die beiden is_executable - Abfragen auskommentiert.

    Das Ergebniss ist:

    Warning: escapeshellcmd() has been disabled for security reasons in
    /typo3conf/ext/cc_awstats/mod1/index.php on line 269

    Warning: passthru() has been disabled for security reasons in
    /typo3conf/ext/cc_awstats/mod1/index.php on line 269

    Ich verzichte mal einfach auf Awstats. Trotzdem herzlichen Dank für die Antworten!!!

    Viele Grüße

    Dominique

  • lukas lukas
    Padawan
    0 x
    33 Beiträge
    0 Hilfreiche Beiträge
    12. 10. 2004, 14:22

    sali dominique, falls du es trotzdem nocheinmal probieren willst: ich hatte genau dasselbe problem wie du (perl pfad eigentlich richtig, und trotzdem funzts nicht).

    mir hat schliesslich folgender beitrag von emanuel geholfen: http://www.typo3.net/viewtopic.php?p=62621#62621

  • 0 x
    9 Beiträge
    0 Hilfreiche Beiträge
    13. 10. 2004, 17:06

    Hallo Lucas,

    vielen Dank für Deine Antwort. Ich werd es ausprobieren.

    Viele Grüße

    Dominique

  • 1