[Frage] go_maps_ext NoApiKey TYPO3-Version: 7.6.32


  • 1
  • 0 x
    3243 Beiträge
    151 Hilfreiche Beiträge
    09. 06. 2021, 23:18

    Wenn Du bereits ahnst, dass noch etwas zu konfigurieren sein müsste, dann kann doch der Abschnitt "Configuration" aus der Dokumentation der Extension gar nicht so verkehrt sein...
    Und siehe da, als fünfte Konstante wird aufgeführt:

    settings.apiKey
    Set the API key. Required for new domains.

    https://docs.typo3.org/p/clickstorm/go_maps_ext/4.0/en-us/Configuration/Reference/Index.html#constants

  • 3dxO 3dxO
    R2-D2
    0 x
    122 Beiträge
    1 Hilfreiche Beiträge
    10. 06. 2021, 08:14

    Danke dir. Da hatte ich auch geschaut. aber diese Zeile in meinem Template-Setup bzw. Konstanten hat nicht geholfen:

    plugin.go_maps_ext.settings.apiKey = ...

    Ich geh ja erstmal von einem Fehler meinerseits aus. Was ist an der Zeile falsch?

    edit: im Objekt-Browser wird die Variable auch korrekt angezeigt. Und eine eigene Test-Html auf dem Server funktioniert auch. Liegt es jetzt an der Version? go_maps_ext 2.6.0 (das war die neueste Version die ich für Typo3 7.6.32) installieren konnte.

  • 0 x
    3243 Beiträge
    151 Hilfreiche Beiträge
    10. 06. 2021, 08:52

    Du musst auf die Benennungen etwas besser achten. Ich weiß, TYPO3 macht es da einem nicht immer so leicht beim Einstieg...

    Die TypoScript-Konstante heißt `plugin.tx_gomapsext.settings.googleMapsLibrary`.
    In TypoScript taucht der Extensionkey immer *ohne* Unterstriche, dafür aber mit "tx_"-Prefix auf.

  • 3dxO 3dxO
    R2-D2
    0 x
    122 Beiträge
    1 Hilfreiche Beiträge
    10. 06. 2021, 09:39

    boah, sauber. Danke vielmals. Das muss man natürlich wissen :)

  • 1