[Frage] Nach Update auf 10.4.6 Exception TYPO3-Version: 10.4.5

  • trashi trashi
    T3PO
    0 x
    27 Beiträge
    0 Hilfreiche Beiträge
    31. 07. 2020, 13:37

    Hallo Leute vielleicht könnt ihr mir weiterhelfen.

    Habe heute im Halbschlaf ein System einem Update unterzogen.
    Danach funktioniert die Seite sowie backend nicht mehr.

    In der Console wird folgendes Angezeigt:
    https://prnt.sc/trqpc4

    Im Frontend sieht es wie folgt aus:
    http://prntscr.com/trqq5e

    Hat jemand ggf. die selbe Fehlerausgabe?
    Caches habe ich auch bereits alle manuell gelöscht, und hatte auch versucht heraus zu finden was genau das Problem ist (ggf ja eine Extension?). Allerdings wird dieser Fehler direkt in der Funktion extendService in der ServiceProviderCompilationsPass.php geworfen.
    Zuvor läuft dort core durch, und sobald backend.routes angegangen wird, wird dieser Fehler geworfen.
    Muss dann ja irgendwie ein Systemfehler von Typo3 sein? Aber dann hätte man wohl mehr Fehler im Netz gefunden, allerdings ist dort wenig bis gar nichts zu finden ?!.

    Falls wer ne Idee hat immer gern her damit :)

    Viele Grüße und bleibt gesund.


  • 1
  • trashi trashi
    T3PO
    0 x
    27 Beiträge
    0 Hilfreiche Beiträge
    03. 08. 2020, 08:29

    Okay okay Entwarnung.
    Nach einigen Stunden des Debugging konnte das wirkliche Problem identifiziert werden.

    https://prnt.sc/tt0db1

    Es lag schlicht und einfach daran, dass die Backende Extension zu spät geladen wurde und eine andere Abhängigkeit diese aber vorausgesetzt hatte anscheinend. Nachdem die Extension Backend wieder nach allen anderen Sys-Extensions wie core, extbase, fluid ... geladen wurde, funktionierte alles wieder und das Backend war wieder erreichbar.

    Viele Grüße,
    trashi

  • 1