19. 07. 2020, 21:44

Hallo liebe Community,

folgendes Problem.

Ich habe Aufgrund von Server-Restriktionen folgende Struktur.

/var/www/domainname/private
/var/www/domainname/web

Das Webroot ist /var/www/domainname/web

Meine composer.json liegt im private Ordner.

Wärend der Installation (composer und anschließendem BE) werden im private Ordner folgende Ordner angelegt.

/var/www/domainname/private/vendor
/var/www/domainname/private/var
/var/www/domainname/private/typo3conf
/var/www/domainname/private/typo3temp
/var/www/domainname/private/fileadmin

im web folgendes

/var/www/domainname/web/index.php
/var/www/domainname/web/typo3
/var/www/domainname/web/typo3conf
/var/www/domainname/web/typo3temp

Als ich dann im Backend in den Fileadmin wechseln wollte bekam ich folgende Meldung

[code]PHP Warning: touch(): Unable to create file /var/www/meinedomain/web/fileadmin/aAbB because No such file or directory in /var/www/meinedomain/web/typo3/sysext/core/Classes/Resource/StorageRepository.php line 266[/code]

lag einfach daran, das der fileadmin nicht im Webverzeichnis existierte.

Ich bin etwas verwirrt, das jetzt auch typo3conf,typo3temp,fileadmin im private Ordner angelegt werden und nicht im Web Verzeichnis.

Kann man das noch irgendwie steuern oder setzt TYPO3 es zwingend Voraus, dass die Ordner parallel zum Vendor angelegt werden?

Danke schon mal im Voraus für die Mühe

Gruß Michael

PS: meine composer.json

[code]

{
"name": "typo3/cms-base-distribution",
"description" : "TYPO3 CMS Base Distribution",
"license": "GPL-2.0-or-later",
"minimum-stability": "dev",
"prefer-stable": true,
"config": {
"platform": {
"php": "7.2"
},
"sort-packages": true,
"cache-dir": "./composer-cache/",
"git-clone-depth": 100,
"process-timeout": 900,
"optimize-autoloader": true
},
"repositories": [
{
"type": "path",
"url": "./local-repo/*/*",
"options": {
"symlink": false
}
}
],
"require": {
"fluidtypo3/vhs": "^6.0",
"helhum/typo3-console": "^6.0.0",
"ichhabrecht/content-defender": "^3.0",
"typo3/cms-about": "^10.4",
"typo3/cms-backend": "^10.4",
"typo3/cms-belog": "^10.4",
"typo3/cms-beuser": "^10.4",
"typo3/cms-core": "^10.4",
"typo3/cms-dashboard": "^10.4",
"typo3/cms-extbase": "^10.4",
"typo3/cms-extensionmanager": "^10.4",
"typo3/cms-felogin": "^10.4",
"typo3/cms-filelist": "^10.4",
"typo3/cms-filemetadata": "^10.4",
"typo3/cms-fluid": "^10.4",
"typo3/cms-fluid-styled-content": "^10.4",
"typo3/cms-form": "^10.4",
"typo3/cms-frontend": "^10.4",
"typo3/cms-impexp": "^10.4",
"typo3/cms-info": "^10.4",
"typo3/cms-install": "^10.4",
"typo3/cms-linkvalidator": "^10.4",
"typo3/cms-lowlevel": "^10.4",
"typo3/cms-opendocs": "^10.4",
"typo3/cms-recordlist": "^10.4",
"typo3/cms-recycler": "^10.4",
"typo3/cms-redirects": "^10.4",
"typo3/cms-reports": "^10.4",
"typo3/cms-rte-ckeditor": "^10.4",
"typo3/cms-scheduler": "^10.4",
"typo3/cms-seo": "^10.4",
"typo3/cms-setup": "^10.4",
"typo3/cms-sys-note": "^10.4",
"typo3/cms-t3editor": "^10.4",
"typo3/cms-tstemplate": "^10.4",
"typo3/cms-viewpage": "^10.4",
"typo3/cms-workspaces": "^10.4"
},
"extra": {
"typo3/cms": {
"cms-package-dir": "{$vendor-dir}/typo3/cms",
"web-dir": "../web"
}
},
"scripts":{
"typo3-cms-scripts": [
"typo3cms install:fixfolderstructure",
"typo3cms install:generatepackagestates"
],
"post-autoload-dump": [
"@typo3-cms-scripts"
]
}
}

[/code]