[Frage] Extension abhängig von nicht existierender TYPO3-Version 8.7.99? TYPO3-Version: 8.7.27

  • miniton miniton
    T3PO
    0 x
    14 Beiträge
    1 Hilfreiche Beiträge
    05. 12. 2019, 12:27

    Hallo allerseits,
    ich habe mich schon öfter gefragt, warum für manche Extensions als Abhängigkeit z. B. die Version 8.7.99 angegeben ist, obwohl es diese Version gar nicht gibt. Die letzte Version ist m. W. die 8.7.29.

    Aktuell will ich Calendar Base (cal) installieren, da ist das beispielsweise so.
    https://extensions.typo3.org/extension/cal/

    Kann mir das jemand erklären?

    Danke und viele Grüße
    Christian


  • 1
  • 0 x
    3120 Beiträge
    137 Hilfreiche Beiträge
    06. 12. 2019, 12:16

    Hallo Christian.

    Da scheinen auf extension.typo3.org aktuell die Angaben in den Extensions nicht ganz korrekt ausgelesen zu werden :-(

    Im konkreten Fall von EXT:cal steht sowohl in der ext_emconf.php wie auch in der composer.json eine Äbhängigkeit "'typo3' => '8.7.13 - 9.5.99'". "9.5.99" gibt es zwar nicht, meint aber 9.5.*, also *irgendeine* 9.5-Version.

  • miniton miniton
    T3PO
    0 x
    14 Beiträge
    1 Hilfreiche Beiträge
    11. 12. 2019, 20:43

    Hallo Julian,
    danke für die Antwort, aber das ist es nicht. In der Version 2.0.0, die im TER zur Verfügung steht, ist die 8.7.99 angegeben. In der 2.0.1 auf Github ist das anders. Ich habe gedacht, es ist vielleicht eine "Best Practice", aber so ist wohl nur ein Versehen des Autors.
    Viele Grüße
    Christian

  • 0 x
    3120 Beiträge
    137 Hilfreiche Beiträge
    13. 12. 2019, 09:41

    Ah, Du hast Recht. Hatte mir die Dateien nur im Git-Repo angeschaut. In die Version, die im TER ist, ist tatsächlich ein Fehler reingerutscht, was die Versionsabhängigkeit angeht. Die Angabe macht keinen Sinn (bzw. gestattet derzeit nur 9er-Versionen von TYPO3).

  • 1