[Frage] Übersetzung aus Langfiles in eigener Extension greift nicht mehr [Gelöst] TYPO3-Version: 9.5.7

  • dercin dercin
    R2-D2
    0 x
    95 Beiträge
    0 Hilfreiche Beiträge
    10. 07. 2019, 11:45

    Hi,

    ich habe eine Website mit zwei Sprachen in TYPO3 9.5: deutsch + englisch und aktuell noch das Ganze über ein Pfadsegment konfiguriert. Inhalte, Menü u.s.w. werden alle korrekt übersetzt. Allerdings greifen u.a. die Sprachfiles nicht mehr, wie es früher in TYPO3 8 etc. war.

    Ich habe für manche Texte in einer eigenen Extension eine Sprachdatei für allgemeine Texte z.B. den Breadcrumb abgelegt:

    Language/locallang.xlf und Language/en.locallang.xlf

    Beispiel für die englische Datei:
    [code]<?xml version="1.0" encoding="utf-8" standalone="yes" ?>
    <xliff version="1.0">
    <file source-language="de" target-language="en" datatype="plaintext" original="messages" date="2014-07-02T14:45:11Z" product-name="myextension">
    <header/>
    <body>
    <trans-unit id="you_are_here">
    <source>Sie sind hier</source>
    <target>You are here</target>
    </trans-unit>

    </body>
    </file>
    </xliff>

    [/code]

    So greife ich in meinem Template darauf zu:
    <f:translate extensionName="myextension" key="you_are_here"/>

    Den deutschen Inhalt zieht es sich. Den englischen nicht.

    Auch habe ich manche Texte mancher Extensions über TS übersetzt.

    Beispiel NEWS:

    [code]plugin.tx_news._LOCAL_LANG.de.back-link = Übersicht
    plugin.tx_news._LOCAL_LANG.en.back-link = Overview
    [/code]

    Auch hier greift nur die deutsche Variante.

    Die Site-Konfiguration in der YAML sieht wie folgt aus:
    [code]languages:
    -
    title: Deutsch
    enabled: true
    languageId: '0'
    base: /
    typo3Language: de
    locale: de_DE
    iso-639-1: de
    navigationTitle: Deutsch
    hreflang: de-DE
    direction: ltr
    flag: de
    -
    title: English
    enabled: true
    languageId: '1'
    base: /en/
    typo3Language: default
    locale: en_GB.UTF-8
    iso-639-1: en
    navigationTitle: English
    hreflang: en-GB
    direction: ''
    fallbackType: strict
    fallbacks: ''
    flag: gb

    [/code]

    Hat jemand eine Idee, was noch fehlen könnte?

    Beste Grüße und Danke
    Nico

    http://www.nicolas-stey.de - Webentwicklung
    http://www.steyle.com - Fotografie

  • dercin dercin
    R2-D2
    0 x
    95 Beiträge
    0 Hilfreiche Beiträge
    10. 07. 2019, 15:44 - Lösung

    Ich hab den Grund herausgefunden. Im Backend kann man in der Site Configuration nur "English [default]" wählen, müsste aber eigentlich "English [en]" angeben können, was ich jetzt in der config.yaml selbst getan habe.

    http://www.nicolas-stey.de - Webentwicklung
    http://www.steyle.com - Fotografie


  • 1
  • dercin dercin
    R2-D2
    0 x
    95 Beiträge
    0 Hilfreiche Beiträge
    10. 07. 2019, 15:44

    Ich hab den Grund herausgefunden. Im Backend kann man in der Site Configuration nur "English [default]" wählen, müsste aber eigentlich "English [en]" angeben können, was ich jetzt in der config.yaml selbst getan habe.

    http://www.nicolas-stey.de - Webentwicklung
    http://www.steyle.com - Fotografie

  • 1