19. 06. 2019, 13:50

Hallo ins Forum,

ich habe eine Seite mit dem Plugin der Suche, als auch eine Suchbox die auf allen Seiten angezeigt wird. Die Suche funktioniert, die Resultsliste wird angezeigt.

Probleme gibt es nur, wenn mehr Treffer vorhanden sind als auf Seite 1 angezeigt werden. Es wird dann die Paginierung angezeigt, mit Klickt man auf "Seite 2" erscheint aber statt der weiteren Treffer nur die Meldung "Keine Ergebnisse gefunden".

Die Paginierung sieht im HTML so aus:
[code]<ul class="tx-indexedsearch-browsebox">
<li class="tx-indexedsearch-browselist-currentPage"><strong><a href="#" onclick="document.getElementById('tx_indexedsearch_pointer').value='0';document.getElementById('tx_indexedsearch').submit();return false;">Seite 1</a></strong></li>
<li><a href="#" onclick="document.getElementById('tx_indexedsearch_pointer').value='1';document.getElementById('tx_indexedsearch').submit();return false;">Seite 2</a></li>
<li><a href="#" onclick="document.getElementById('tx_indexedsearch_pointer').value='1';document.getElementById('tx_indexedsearch').submit();return false;">Nächste &gt;</a></li>
</ul>
[/code]

Aufgefallen ist mir, dass die <ul class="tx-indexedsearch-browsebox"> im Template search.html (alle Templates habe ich in ein eigenes Verzeichnis gelegt und eingebunden) nicht vorhanden ist. Hier steht was mit <ul class="tx-indexedsearch-browsebox">. Wo kommt das <ul> her? Hängt das ggf. mit dem Problem zusammen?

Hier noch die Einstellungen
[code][tx_indexedsearch]

[settings]

[targetPid]= 60
[displayRules]= 1 # show the rules
[displayAdvancedSearchLink]= 0 # show a link to the advanced search
[displayResultNumber]= 0 # show the number of results
[breadcrumbWrap]= / || /
[displayParsetimes]= 0 # show the parse times
[displayLevel1Sections]= 1
[displayLevel2Sections]= 0
[displayLevelxAllTypes]= 0
[displayForbiddenRecords]= 0
[alwaysShowPageLinks]= 1
[mediaList]=
[rootPidList]= 1
[page_links] = 10
[detectDomainRcords]= 0 # @deprecated left for BC reasons, will be removed in 10
[detectDomainRecords]= 0
[defaultFreeIndexUidList]=
[searchSkipExtendToSubpagesChecking]= 0
[exactCount]= 0

[forwardSearchWordsInResultLink]= 0

[no_cache] = 1

[results]

[titleCropAfter]= 50 # various crop/offset settings for single result items
[titleCropSignifier]= ...
[summaryCropAfter]= 180
[summaryCropSignifier]=
[hrefInSummaryCropAfter]= 60
[hrefInSummaryCropSignifier]= ...
[markupSW_summaryMax] = 300
[markupSW_postPreLgd] = 60
[markupSW_postPreLgd_offset] = 5

[markupSW_divider] = ...
[noTrimWrap]= | | |

[blind]

[searchType]= 0 # Blinding of option-selectors / values in these (advanced search)
[defaultOperand]= 0
[sections]= 0
[freeIndexUid]= 1
[mediaType]= 0
[sortOrder]= 0
[group]= 0
[languageUid]= 0
[desc]= 0
[numberOfResults]= 10,25,50,100 # List of available number of results. First will be used as default.

[defaultOptions][defaultOperand]= 0
[sections]= 0
[freeIndexUid]= -1
[mediaType]= -1
[sortOrder]= rank_flag
[languageUid]= -1
[sortDesc]= 1
[searchType]= 1
[extResume]= 1

[view]

[templateRootPaths]

[0]= EXT:indexed_search/Resources/Private/Templates/
[10]= EXT:myExt/Resources/Private/Templates/indexed_search/

[partialRootPaths]

[0]= EXT:indexed_search/Resources/Private/Partials/
[10]= EXT:myExt/Resources/Private/Partials/indexed_search/

[layoutRootPaths][0]= EXT:indexed_search/Resources/Private/Layouts/
[10]= EXT:indexed_search/Resources/Private/Layouts/

[features]

[requireCHashArgumentForActionArguments]= 0
[/code]

Bin für jeden Tipp dankbar.

Gruß mimii