[Frage] Nach Upgrade auf v9.5.5 Fehlermeldung im IT -> Fehlermelung wegen broken Extension TYPO3-Version: -

  • 0 x
    64 Beiträge
    1 Hilfreiche Beiträge
    02. 04. 2019, 22:20

    Hallo,

    ich habe mich heute mal mit einem Upgrade beschäftigt. Leider kann ich das Upgrade nicht ausführen, da im Installtool immer nur eine Fehlermeldung angezeigt wird. Wenn ich auf Ajax error klicke erscheint:

    [code]Deprecated: Automatic TCA migration done during bootstrap. Please adapt TCA accordingly, these migrations will be removed. The backend module "Configuration -> TCA" shows the modified values. Please adapt these areas: The TCA table 'pages_language_overlay' is not used anymore and has been removed automatically in order to avoid negative side-effects. in /usr/www/users/dddd/typo3_src-9.5.5/typo3/sysext/core/Classes/Utility/ExtensionManagementUtility.php on line 1718
    {"success":true,"status":[],"suggestions":[{"key":"addField","label":"Add fields to tables","enabled":true,"children":[{"hash":"ec83bc9fc3ffe6d38b7f017f066fafff","statement":"ALTER TABLE `pages` ADD `rowDescription` TEXT DEFAULT NULL"},{"hash":"6c7fdfbc8c0148bb84599038e076daa2","statement":"ALTER TABLE `pages` ADD `sys_language_uid` INT DEFAULT 0 NOT NULL"},{"hash":"2c32155d25bf71b98bef5f4d9cdf1a92","statement":"ALTER TABLE `pages` ADD `l10n_source` INT UNSIGNED DEFAULT 0 NOT NULL"},{"hash":"53a09e809aa4e9c96d90e72f7b27beb6","statement":"ALTER TABLE `pages` ADD `l10n_state` TEXT DEFAULT NULL"},{"hash":"66af1b5c6887a23b11a7590113dfb5c0","statement":"ALTER TABLE `pages` ADD `l10n_diffsource` MEDIUMBLOB DEFAULT NULL"},{"hash":"3ce886fa2dd1bd744fa60c10a04eebb1","statement":"ALTER TABLE `pages` ADD `slug` VARCHAR(2048) DEFAULT NULL"},{"hash":"70269dc0df6e872e22c5e43d21710aaf","statement":"ALTER TABLE `pages` ADD `legacy_overlay_uid` INT UNSIGNED DEFAULT 0 NOT [/code]

    Ich habe fast alle EXT deaktiviert, jedoch erscheint die Fehlermeldung trotzdem und ich kann mein Upgrade durchführen. Ich habe auf dem Server parallel mal 9.5.5 neu installiert und das funktioniert ohne Probleme. Der Fehler muss daher ja irgendwo bei der alten v8 Version liegen - nur wo.


  • 1
  • 0 x
    64 Beiträge
    1 Hilfreiche Beiträge
    03. 04. 2019, 19:35

    Fehler gefunden. In der LocalConfiguration hat unter SYS ein Eintrag gefehlt, welcher für v9 benötigt wird. Des Weiteren war dort noch ein Eintrag vorhanden, welcher in v9 nicht mehr interpretiert werden kann. Kleine Ursache, großer Fehler.

  • 1