[Frage] Original Content wird in allen Sprachen angezeigt TYPO3-Version: 8.7.19

  • miniton miniton
    Typ im Roten Hemd
    0 x
    3 Beiträge
    0 Hilfreiche Beiträge
    06. 12. 2018, 18:11

    Hallo liebe Typo3-Gemeinde,

    ich habe schon mehrere Tage ein Problem mit einer mehrsprachigen Seite, für das ich auch nach intensiven Suchen noch keine Lösung gefunden habe.

    Es geht um eine mehrsprachige Seite (DE/EN/FR), basierend auf dem bootstrap_package von Benjamin Kott. Die Mehrsprachigkeit ist, soweit ich es sehe, richtig konfiguriert (syslanguage_mode = content_fallback).

    Und auf den meisten Seiten, bei denen die Übersetzungen mit dem Original verbunden sind, funktioniert auch alles einwandfrei.

    Ich habe aber eine Seite auf der die übersetzen Inhalte anders sortiert werden müssen. Und auf dieser Seite wird auf den übersetzten Seiten neben dem übersetzten Inhalt auch noch das Original angezeigt :-(

    Also die Ausgabe ist so:
    - deutsche Seite: deutscher Content
    - englische Seite: deutscher und englischer Content
    - französische Seite: deutscher und französisch Content

    Aaaargh.

    Für mich wirkt es so, als ob die Inhalte der Originalsprache sich so verhalten, als ob die Sprache auf ALL gesetzt wäre, was sie aber nicht ist.

    Hat von Euch jemamd eine Idee dazu?

    Viele Grüße
    Christian


  • 1
  • miniton miniton
    Typ im Roten Hemd
    0 x
    3 Beiträge
    0 Hilfreiche Beiträge
    07. 12. 2018, 10:36

    Jetzt habe ich die Lösung gefunden, für diese Seite muss der Language Overlay abgeschaltet werden, da sonst der deutsche Content als nicht übersetzter Content angezeigt wird.

    config.sys_language_overlay = 0

  • 1