[Frage] Template-Pfade werden nicht in Extension übernommen TYPO3-Version: 8.7.4

  • schumiel schumiel
    R2-D2
    0 x
    86 Beiträge
    0 Hilfreiche Beiträge
    23. 10. 2018, 16:46

    Hallo,

    das ist mein typoscript:

    [code]module.tx_test {
    view {
    # cat=plugin.tx_test/file; type=string; label=Path to template root (BE)
    templateRootPath = EXT:test/Resources/Private/Backend/Templates/
    # cat=plugin.tx_test/file; type=string; label=Path to template partials (BE)
    partialRootPath = EXT:test/Resources/Private/Backend/Partials/
    # cat=plugin.tx_test/file; type=string; label=Path to template layouts (BE)
    layoutRootPath = EXT:test/Resources/Private/Backend/Layouts/
    }
    standaloneView {
    # cat=plugin.tx_test/file; type=string; label=Path to template root (Standalone BE)
    templateRootPath = EXT:test/Resources/Private/Standalone/Templates/
    # cat=plugin.tx_test/file; type=string; label=Path to template partials (Standalone BE)
    partialRootPath = EXT:test/Resources/Private/Standalone/Partials/
    # cat=plugin.tx_test/file; type=string; label=Path to template layouts (Standalone BE)
    layoutRootPath = EXT:test/Resources/Private/Standalone/Layouts/
    }
    [/code]

    Und darüber möchte ich die Informationen in meiner Extension nutzen:

    [code]$extbaseFrameworkConfiguration = $this
    ->configurationManager
    ->getConfiguration(
    \TYPO3\CMS\Extbase\Configuration\ConfigurationManagerInterface::CONFIGURATION_TYPE_FULL_TYPOSCRIPT,
    $extensionName='test'
    );
    [/code]

    Mache ich ein var_dump(); auf "$extbaseFrameworkConfiguration['standaloneView']['templateRootPath']", ist diese leer. Warum? Was mache ich falsch?


  • 1
  • schumiel schumiel
    R2-D2
    0 x
    86 Beiträge
    0 Hilfreiche Beiträge
    24. 10. 2018, 11:33

    Hm, dass hatte ich in Configuration/TypoScript/constants.ts und setup.ts drin gehabt. Wenn ich das im TYPO3-Backend als Template einbinde, funktioniert es.

  • 1