[Frage] [Frage] Seitenbaum und Inhalte werden nicht richtig aus meiner Distribution importiert TYPO3-Version: 8.7.17

  • anordoanrywizard anordoanr...
    Jar Jar Binks
    0 x
    1 Beiträge
    0 Hilfreiche Beiträge
    31. 07. 2018, 10:34

    Hallo Zusammen

    Ich möchte mit meiner Extension einen Seitenbaum mit Inhalten und Bildern mitliefern, so wie das auch z.B. die introduction Distribution macht. Dazu habe ich mit dem import/export Modul eine data.xml Datei erstellt. Die Bilder habe ich auch mit exportieren lassen. Diese sind jetzt in einem data.xml.files Ordner so wie das auch in der introduction Distribution aussieht. https://github.com/FriendsOfTYPO3/introduction/tree/master/Initialisation

    Allerdings läuft dann beim Import durch das Installieren der Distribution einiges falsch. Zwar werden die Seiten und Inhalte alle vollständig importiert, jedoch bekommen sie die falschen ID's und alle File-References fehlen in den Inhaltselementen. Das ist natürlich ein Problem, weil meine Extension davon ausgeht, dass die Navigation oder einzelne Inhaltselemente eine bestimmte ID haben. Ich installierte die Distribution auch auf einer neuen Installation ohne Seiten und Inhalten, damit es nicht zu ID-Konflikten kommen konnte.

    Ich habe auch mal den Export Preset vom introduction package ausprobiert, das hat aber die gleichen Resultate erbracht.
    https://github.com/FriendsOfTYPO3/introduction/blob/master/Resources/Private/ImportExportPreset.sql

    Hat jemand eine Idee wie ich das mit dem Import korrekt hinkriegen kann?


  • 1
  • pstranghoener pstrangho...
    Die Macht
    0 x
    530 Beiträge
    24 Hilfreiche Beiträge
    28. 08. 2018, 08:07

    Hey anordoarywizard,
    hast du mittlerweile eine Lösung gefunden? Sonst schau ich mir das nochmal an. Das scheint ja doch ein etwas komplexeres Problem zu sein.

    Grüße
    Philipp

  • 1