[Frage] Große Original-Bilder statt kleiner processed Bilder bei Anzeige von Datensätzen im Backend TYPO3-Version: 8.7.17

  • dirk.f dirk.f
    Padawan
    0 x
    40 Beiträge
    2 Hilfreiche Beiträge
    30. 07. 2018, 12:13

    Hallo,
    ich habe ein merkwürdiges Phänomen.

    Das Image-Processing an sich funktioniert im Frontend und Backend.
    In der Ansicht "Seite" werden in den Datensätzen aber die großen Original-Bilder statt der kleinen (processed) Bilder angezeigt.

    Beispiel:
    Wenn ich in einem Element "Text & Media" ein Bild einbinde, dann wird es dort korrekt verkleinert dargestellt. Pfad des Bildes fileadmin/_processed_/...
    Alles korrekt. GraphicsMagick arbeitet im Install-Tool einwandfrei.
    In der Dateiliste werden die Thumbnails auch korrekt angezeigt.

    In der Ansicht "Seite" werden die Bilder aber als Original riesengroß mit entsprechendem Pfad dargestellt: fileadmin/bilder/bild1.jpg
    Gleiches passiert bei News in der Ansicht "Liste". Bearbeite ich die News-Datensätze, sind dort die Bilder klein (processed).

    Irgendeine Idee, warum die Bilder nur in der Hauptansicht des Backends bei Anzeige der Datensätze die Bilder im Original anzeigt?
    Wie gesagt, in den Datensätzen, im Frontend und der Dateiliste werden korrekt die processed Bilder angezeigt.

    Grüße Dirk


  • 1
  • dirk.f dirk.f
    Padawan
    0 x
    40 Beiträge
    2 Hilfreiche Beiträge
    30. 07. 2018, 20:54

    Nach langem Suchen habe ich die Lösung gefunden.
    Es lag an GraphicsMagick. TYPO3 ist auf einem WebPack bei Host Europe installiert.
    (Bevor ein Kommentar kommt ... ich weiß, dass die WebPacks Schrott sind. ;-) )

    Dort gibt es weder GraphicsMagick noch ImageMagick vorinstalliert, also wird dort seit Jahren eine kompilierte Version von GraphicsMagick verwendet. Lief immer gut, scheint aber mit TYPO3 8.7 Probleme zu machen. Test im Install-Tool lief zwar, aber es trat der oben beschriebene Fehler auf.
    Eine neue kompilierte Version hat Abhilfe geschaffen.
    Siehe auch:
    https://wiki.typo3.org/De:Installation_at_Hosteurope#Einrichten_von_GraphicsMagick_f.C3.BCr_TYPO3_bei_Hosteurope

  • 1